• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Dom is autmaticaly placing my limit orders as market.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dom is autmaticaly placing my limit orders as market.

    Every time I place a buy or sell above or below price they are being filled immediately as market orders.

    #2
    Try middle click your mouse

    or holding down CNTRL and middle click your mouse to get a buy stop limit above market

    Comment


      #3
      Hi sphereless,

      Thank you for your post.

      Limit orders will be filled at the price they are placed at or better, and since the last traded price is presently better than the limit price it will fill immediately.

      You will want to use a Stop Limit as Laserdan suggested, or a Stop Market order. Please see the following link.
      http://www.ninjatrader-support.com/H...ManagingOrders
      Ryan O.NinjaTrader Customer Service

      Comment


        #4
        Thank you very much.. Very new to this platform.

        Comment


          #5
          It is not working now.. I am placing my cursor at a price above or below market and holding the cntrl key down while hitting the left click on the mouse. I have no idea how to pull this off.

          Comment


            #6
            Hi sphereless,

            To place a stop market order you will hold CTRL+Middle Mouse Click, and for a stop limit order it will be a Middle Mouse Click (scroll wheel).

            So rather than use the left mouse click please try with the middle mouse click and let me know if you are then able to input stop limit or stop market orders.
            Ryan O.NinjaTrader Customer Service

            Comment


              #7
              I also just have a laptop and don't have a scroll wheel for middle clicking.

              Comment


                #8
                sphereless,

                I have provided the steps below to help with the configuration.
                • Start Menu
                • Control Panel
                • Mouse
                • Buttons
                • Under the buttons tab you should have an option to make the middle mouse wheel a button.
                If this option is not available reference the mouse software you have installed to change any settings.


                If that does not work for configuring your laptop you may try using both the left and right click at the same time to simulate a middle mouse click.
                Ryan O.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by thgamey, Yesterday, 08:38 PM
                1 response
                9 views
                0 likes
                Last Post NinjaTrader_Marco  
                Started by stredtity, Today, 01:21 AM
                0 responses
                4 views
                0 likes
                Last Post stredtity  
                Started by superg3, Yesterday, 10:12 PM
                0 responses
                8 views
                0 likes
                Last Post superg3
                by superg3
                 
                Started by johnnybegoode, Yesterday, 07:02 PM
                0 responses
                10 views
                0 likes
                Last Post johnnybegoode  
                Started by YevhenShynkarenko, Yesterday, 05:02 PM
                1 response
                15 views
                0 likes
                Last Post YevhenShynkarenko  
                Working...
                X