• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Error on loading chart data

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Error on loading chart data

    Hi guys
    I have a problem with loading a few charts, everytime I become this message (jpg attachment)
    How can I fix that?

    thanks
    Michael
    Attached Files

    #2
    Hello Michael,

    Can you please tell me what exact PRA instrument you are trying to plot. Are you referring to the PRA traded on the Nyse?

    Please delete any instrument listed PRA in the Instrument Manager in NinjaTrader. Subsequently connect to IB and navigate to the Control Center-->Orders-tab. Set 'Type' to Stock and type in 'PRA' in the Name field and hit Enter.

    The PRA has now been added to the Instrument Manager. Please add it to an instrument list in the Instrument Manager. Create a new chart and select the PRA from your instrument list and check if the requested data is loaded without error.

    Let me know if this will not work for you.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Hi Jason

      PRA is traded on the XETRA

      Comment


        #4
        Hi Jason
        unfortenately it does not work, also SPR, GMM all on XETRA and in Euro are impossible.

        "Control Center-->Orders-tab. Set 'Type' to Stock and type in 'PRA' in the Name field and hit Enter."

        when I do this, on the left side in the Bid, Ask and Last are nothing changing.

        Comment


          #5
          Hello Michael,

          Unfortunately I am still not sure what exact PRA instrument you refer. When I type the symbol in TWS, I list the instruments in the attached screenshot.

          Yes, those instructions will not work - they will only work for the PRA traded on Nyse.

          Can you please try the following. Please only enable the Xetra exchange for the instrument in the Definition-tab. Check if this will make a difference.
          Attached Files
          JasonNinjaTrader Customer Service

          Comment


            #6
            Originally posted by NinjaTrader_Jason View Post
            Hello Michael,

            Unfortunately I am still not sure what exact PRA instrument you refer. When I type the symbol in TWS, I list the instruments in the attached screenshot.

            Yes, those instructions will not work - they will only work for the PRA traded on Nyse.

            Can you please try the following. Please only enable the Xetra exchange for the instrument in the Definition-tab. Check if this will make a difference.

            Instrument are the stock Praktiker Bau und Heimwerk "PRA"

            I have only enabled the XETRA
            Last edited by michi08; 09-08-2010, 04:40 AM.

            Comment


              #7
              Hello Michael,

              I tested it on my end using the IB demo connection and I was able to receive real-time data for the PRA. Do you receive real-time data on your end as well?

              Unfortunately we do not have a live IB account available that is enabled for such data to test historical data.
              Attached Files
              JasonNinjaTrader Customer Service

              Comment


                #8
                Originally posted by NinjaTrader_Jason View Post
                Hello Michael,

                I tested it on my end using the IB demo connection and I was able to receive real-time data for the PRA. Do you receive real-time data on your end as well?

                Unfortunately we do not have a live IB account available that is enabled for such data to test historical data.
                How you can see i have the same values on my NT 6.5 and also in the NT 7. You can see that in Control Center there are no change. I testet now more different small cap stocks without a result, i got only errors.

                (under Instrument Editor Misc- IB are also PRA, I forgot to make a scan)
                Attached Files
                Last edited by michi08; 09-08-2010, 08:11 AM.

                Comment


                  #9
                  The screenshots displays you manually setup the PRA instrument in the Control Center-->Orders-tab.

                  Please proceed as follows. Delete any instrument listed in the Instrument Manager named PRA.

                  Subsequently click New to create a new instrument. Configure the instrument as per the attached screenshots.

                  Add the newly created PRA to your default instrument list.
                  http://www.ninjatrader-support.com/H...eFromList.html

                  Select the PRA from your instrument list in the Control Center-->Orders-tab (set 'Type' to <Default>) and check if you receive data.
                  JasonNinjaTrader Customer Service

                  Comment


                    #10
                    Now I did like you told me and it is running, but i must restart the NT!! without restart there are no changes.

                    Ok, I wil test now the other stocks too, hopping that it wil work well.

                    Thanks for everthing
                    Michael

                    Comment


                      #11
                      Good to hear you now receive data. Let me know if you require any additional assistance.
                      JasonNinjaTrader Customer Service

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by Hanstanz, Today, 04:44 AM
                      0 responses
                      4 views
                      0 likes
                      Last Post Hanstanz  
                      Started by juniortut, Today, 04:38 AM
                      0 responses
                      4 views
                      0 likes
                      Last Post juniortut  
                      Started by rojiinko, Today, 03:58 AM
                      0 responses
                      4 views
                      0 likes
                      Last Post rojiinko  
                      Started by mreanuzlazx, Today, 01:30 AM
                      0 responses
                      4 views
                      0 likes
                      Last Post mreanuzlazx  
                      Started by xinepev, Today, 12:33 AM
                      0 responses
                      4 views
                      0 likes
                      Last Post xinepev
                      by xinepev
                       
                      Working...
                      X