• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Multiple Monitors & WorkSpaces

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Multiple Monitors & WorkSpaces

    is there any way to have difference workspaces open on different monitors?

    #2
    Hi jupiejupe,

    Thank you for your post.

    Within NinjaTrader you can have one workspace visible at a time, but each workspace comprises of multiple NinjaTrader windows so it would be possible to configure multiple monitors as you would like and save that setup as part of one workspace. More information at:
    http://www.ninjatrader.com/support/h...gingWorkspaces
    Ryan ONinjaTrader Customer Service

    Comment


      #3
      yeah but that means i have to have more charts open in every work space. those that i am trading and those that i am following.

      could you send this to the design team, workspaces assigned to monitors. thanks

      Comment


        #4
        Hi jupiejupe,

        Yes, I have forwarded this suggestion to development for inclusion on the list of possible future enhancements.

        It is possible to have multiple workspaces open at a time within the File-->Workspace menu, and then you can switch between them but you would only be able to view one workspace at a time.

        Either of those methods, or used in conjunction should work presently for configuring your workspaces, but the ability to have multiple workspaces open at a time has been forwarded to our development team.
        Ryan ONinjaTrader Customer Service

        Comment


          #5
          yes this is what i am doing currently, issue, limited view, having to switch between views, and waiting from them to load.

          control workspace
          charts that i am following on one screen so i know which charts i want to trade.

          even having workspaces as self contained windows and flipping thur them as needed. would be cool.

          Comment


            #6
            Hi jupiejupe,

            You mention having the ability to flip through workspaces, and this is presently possible.

            If you go to File-->Workspaces-->Open you can open multiple workspaces at a time, and they will remain open, though not always visible.

            Then you can go to File-->Workspaces and select the open workspace to view other workspaces, and since they are already open they should not take anytime to load.

            You can also cycle through workspaces that are open by hitting the Shift+F3 keys at the same time.
            Ryan ONinjaTrader Customer Service

            Comment


              #7
              Originally posted by NinjaTrader_RyanOlson View Post
              If you go to File-->Workspaces-->Open you can open multiple workspaces at a time, and they will remain open, though not always visible.
              .

              expect these does not have the instrument tied to the workspaces, which mean everytime you change a workspace you need to also change after it loads the instrument to match which is not the same as what i just suggested.

              Comment


                #8
                Hi jupiejupe,

                If you create individual workspaces for individual instruments then when you first load the workspace upon connecting it should load for the saved instruments, and then you can have open workspaces for individual instruments by creating the windows viewing a specific instrument, and then saving that workspace. The component windows will be saved with the instrument saved, also.
                Ryan ONinjaTrader Customer Service

                Comment


                  #9
                  i only wish this were true.

                  i spend more time readjusting my time axis (x axis) and bar width every time i change to a workspace and then select the instrument for that workspace. as this process rearranges both the time axis and bar width. i have to go thur this process everytime i look at a different workspace. which cause much anger daily for something so simple that has been overlooked.

                  Comment


                    #10
                    Hello,

                    Is this NinjaTrader 6.5 or NinjaTrader 7?

                    Also, Have you heard or considered using our linking feature to link all the windows to a market analyzer and then just click on instruments in the market analyzer to swtich all the charts and windows to the new instrument with no need to run multiple workspaces?

                    I look forward to assisting you further.
                    BrettNinjaTrader Product Management

                    Comment


                      #11
                      my NT is current. not that i matters but i am a licensed customer.

                      yes i already have all of my charts and time and sales linked, for every workspace.


                      just click on instruments in the market analyzer to swtich all the charts and windows to the new instrument with no need to run multiple workspaces?
                      the problem with this solution is it does not change the time frames that are unique to each instrument.

                      your assistance is needed to figure out a way to link instruments to workspaces so that when a workspaces is selected the instrument for the workspace is also loaded, such as the data series and indicators setting and chart layout. also a way to limit the duration of time in which the time axis (x axis) & bar width is charted in a workspace.
                      Last edited by jupiejupe; 11-24-2010, 01:45 PM.

                      Comment


                        #12
                        Hi jupiejupe,

                        When creating a workspace from the File-->Workspaces-->New you can create the component charts and specify the interval and the number of days to load in your chart and then save those settings as a chart template by right-clicking on the chart and then selecting Templates-->Save As.

                        This template will save all applied indicators and chart settings including the bar width. Then with the charts open as part of the newly created workspace you can save that workspace with the charts as they were created instrument and settings wise as part of the workspace.

                        If these things are not occurring when creating and saving your workspaces then can you please remove your current workspaces, and then create them anew referring to the following link on managing workspaces.
                        http://www.ninjatrader.com/support/h...gingWorkspaces

                        Because the workspace saves component windows in a grouping with their settings you should be able to create individualized workspaces, and if not then please use the steps below to remove your workspaces.

                        To move your workspaces:
                        • Please close NinjaTrader and go to your desktop Start menu
                        • Open My Documents
                        • Go to the NinjaTrader 6.5 folder
                        • Go to the Workspaces folder
                        • Right click on all XML documents and select Cut
                        • Navigate to the Desktop and then right click and select Paste
                        • Now restart the application and it should start up normally
                        Ryan ONinjaTrader Customer Service

                        Comment


                          #13
                          Originally posted by NinjaTrader_RyanOlson View Post
                          Hi jupiejupe,

                          When creating a workspace from the File-->Workspaces-->New you can create the component charts and specify the interval and the number of days to load in your chart and then save those settings as a chart template by right-clicking on the chart and then selecting Templates-->Save As.
                          ¿starting at the beginning are we?

                          This template will save all applied indicators and chart settings including the bar width. Then with the charts open as part of the newly created workspace you can save that workspace with the charts as they were created instrument and settings wise as part of the workspace.
                          yes in defaul the bar width and time frame, also chart layout and indicator settings are all saved to a workspace. the issue is switch from one instruments workspace to another instruments workspace, the instrument does not load with it's corresponding workspace, and upon the switching back to a workspace the time frame and bar width may change.

                          If these things are not occurring when creating and saving your workspaces then can you please remove your current workspaces, and then create them anew referring to the following link on managing workspaces.
                          http://www.ninjatrader.com/support/h...gingWorkspaces
                          the issue is not creating the workspace but the limited tasks that the workspaces saves, as this would not help me.

                          Because the workspace saves component windows in a grouping with their settings you should be able to create individualized workspaces, and if not then please use the steps below to remove your workspaces.
                          yes again we are saying the same thing here, the workspaces saves everything expect what i have asked about, which is the instrument that the work space is/was created for. and then after said workspace has been loaded the default time shown (x axis) and bar width, will or may change when switch back to workspace.
                          /QUOTE]

                          please take the time to understand what it is i am asking because so for i have said all of this in less detail, but will realign such response until my question has been properly addressed.

                          Comment


                            #14
                            Hi jupiejupe,

                            What we have discussed here is how the workspaces are designed to function, but not how they are working for you. Regarding multiple workspaces open at a time I have forwarded that suggestion to development, but as for your current workspaces where the instruments and the bars do not remain set can you please go to Tools-->About and let me know the version of NinjaTrader, whether 6.5 or 7 you are presently using so that I can test with that version.

                            Then can you please let me know the precise steps you take when switching your workspaces so that I can attempt to duplicate this issue on my end.
                            Ryan ONinjaTrader Customer Service

                            Comment


                              #15
                              64 bit 7.0.0.23

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Emma1, Today, 02:42 PM
                              1 response
                              12 views
                              0 likes
                              Last Post NinjaTrader_DrewO  
                              Started by fx.practic, Today, 03:10 PM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by jertrade, Today, 02:50 PM
                              1 response
                              9 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by RedDuke, Today, 01:59 PM
                              1 response
                              18 views
                              0 likes
                              Last Post NinjaTrader_Kate  
                              Started by MarianApalaghiei, Today, 01:18 PM
                              1 response
                              15 views
                              0 likes
                              Last Post NinjaTrader_PatrickG  
                              Working...
                              X