• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

IQ FEED Sleeping?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    IQ FEED Sleeping?

    On a daily basis, I normally connect to both my PATS system, and IQFeed.
    When I first connect to both, I can view historical data fast and load it fast. However 6 hours later, when I want to view historical data on a new chart, IQFEED stalls with the Loading Data being displayed, along with the instrument.

    Have Ninjatrader development Identify why the IQFEED seems to sleep after along period of inactivity for new data?

    #2
    Hi:

    Thank you for posting.

    What steps to you do perform to submit the new data request after an absence of using the IQ feed?

    Do you open a new chart, change instruments on an existing chart or go to Tools > Historical data > Reload?

    Also, which datafeed are you connected to first, Pats or the IQ feed?

    Best regards,
    RyanNinjaTrader Customer Service

    Comment


      #3
      What steps to you do perform to submit the new data request after an absence of using the IQ feed?

      Do you open a new chart, change instruments on an existing chart or go to Tools > Historical data > Reload?

      NO. I use market Analyser-> Send to Chart. I sometimes change the instrument on an existing chart as well, that also hangs it.

      Also, which datafeed are you connected to first, Pats or the IQ feed?
      I connect to PATS, then IQFEED.

      Comment


        #4
        Hi:

        Thank you for clarifying.

        "NO. I use market Analyser-> Send to Chart. I sometimes change the instrument on an existing chart as well, that also hangs it."

        As per your first post,

        "However 6 hours later, when I want to view historical data on a new chart, IQFEED stalls with the Loading Data being displayed, along with
        the instrument."

        We would need to know which instrument(s) and also if you are attempting to load a tick based or volume based chart?

        If you are running a chart with tick based data on a connection to DTNiQ and do not need to request historical data for a long period of time (i.e. 6 hrs), it is possible to experience slowness in the request.

        Tick/volume based data requests from DTNiQ is much slower and will take longer than historical minute data requests.

        Best regards,
        RyanNinjaTrader Customer Service

        Comment


          #5
          We would need to know which instrument(s) and also if you are attempting to load a tick based or volume based chart?

          I have experience that with the YI, YM, ER2, ES on different days however. Today I was looking at YI. Minute Based charts.

          I have a ES tick based chart displaying today's data. Not too sure whether it is probably taking that info from PATS, as the IQFEED symbols ES##, YM## are not being reflected in the Market Analyser.






          If you are running a chart with tick based data on a connection to DTNiQ and do not need to request historical data for a long period of time (i.e. 6 hrs), it is possible to experience slowness in the request.

          Tick/volume based data requests from DTNiQ is much slower and will take longer than historical minute data requests.

          Comment


            #6
            Hi:

            Thank you for replying.

            I will be testing this on my pc, but would like some more information to make this a re-producible scenario.

            1. How often does this occur, once in a while or every day?

            2. How many days back or bars back are you requesting?

            3. How many indicators are you running on your charts?

            4. Any custom or third party indicators?

            Best regards,
            RyanNinjaTrader Customer Service

            Comment


              #7
              I will be testing this on my pc, but would like some more information to make this a re-producible scenario.

              1. How often does this occur, once in a while or every day?
              It occurs just about every day, once you leave the connections up
              for about 6 hours. I login from around 7AM ET, and come home for lunch around 2PM ET. It is when I forget about the glitch, I suffer. Ensure that you don't have a chart running with the instrument you attempt to bring up.

              2. How many days back or bars back are you requesting?
              I have about 30 days.
              3. How many indicators are you running on your charts?
              I have about 3.
              4. Any custom or third party indicators?
              I have 2 customer indicators none memory intensive, and simple calculations, however it doesn't matter, as this was happening before I coded the indicators.

              Comment


                #8
                Hello:

                Thank you for the clarification.

                A colleague and I tested the connection to DTNiQ and ran several scenarios using both tick and minute based charts of the YI, YM, ER2, and ES.

                Some of the charts we opened directly and others we opened from the Market Analyzer. We used a few indicators on these charts and opened a few more using 3rd Party indicator templates.
                From our tests, the charts opened successfully each time and with limited delay. I did notice that it took longer to load historical tick data as opposed to minute data.

                I would suggest the following...

                1. Reduce the amount of days back you are requesting for data.

                2. Test on an alternate pc if available to see if this could be pc spcecific

                3. Test using an alternate ISP as it could be ISP specific

                4. Please review our tips on overall Performance of NinjaTrader, using the link below:
                http://www.ninjatrader-support.com/H...anceTips1.html

                Best regards,
                RyanNinjaTrader Customer Service

                Comment


                  #9
                  RYAN,
                  Did I mention leaving the system idle for about 6 hours?
                  If I open a new Ninja Session and perform test, it works fine. Probably arise after leaving for a few hours... Not minutes. Just leave your connection for IQ up over nigth, and load a historical chart and let me know how it goes. Changing you system time is not a true reflection of pasting 6 hours real time.

                  Comment


                    #10
                    Hi:

                    The idleness of NT while connected to the IQ feed is a variable not accounted for in our testing.

                    I will attempt to run a test for us tomorrow. Unfortunately, I cannot set this up to run overnight.

                    Thanks again and will let you know how this goes tomorrow afternoon.
                    RyanNinjaTrader Customer Service

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by curious, Today, 02:17 AM
                    0 responses
                    1 view
                    0 likes
                    Last Post curious
                    by curious
                     
                    Started by pmmkm, Yesterday, 11:13 PM
                    0 responses
                    3 views
                    0 likes
                    Last Post pmmkm
                    by pmmkm
                     
                    Started by pulpiwapi, 03-04-2019, 11:18 PM
                    11 responses
                    149 views
                    0 likes
                    Last Post music_p13  
                    Started by indy73, 06-25-2019, 10:52 PM
                    3 responses
                    20 views
                    0 likes
                    Last Post sledge
                    by sledge
                     
                    Started by priceisking, Yesterday, 12:51 PM
                    1 response
                    23 views
                    0 likes
                    Last Post NinjaTrader_PaulH  
                    Working...
                    X