I have installed today the latest version of NT7. I am using it in simulation mode after opening a demo account at ZenFire.

I have a most peculiar issue that I cannot resolve despite many efforts: after I successfully connect to ZenFire and I open an E6 Chart, the chart is stuck in the "loading data..." phase. The screenshot attached shows the status the app is in after about an hour waiting on it to load the data. Even more strange, it did successfully load the data ONCE, meaning that no security application or firewall is blocking it.

This happens on both NT7 and NT6.5 (latest versions of both).

I have tried the following:
- uninstalled and reinstalled NinjaTrader (both 6.5 & 7)
- deleted historical data from control center
- tried loading data on charts with no indicators (vanilla) and charts with indicators
- Windows firewall does not block it
- Router does not block anything
- Did bandwidth speed tests - my download / upload speeds are fine and according to ISP service

My PC setup:
- Windows Vista 64 bit
- Quad Core CPU
- 8 GB of RAM
- Normal HD with 120GB free
- 4Mbit ADSL internet connection

Please Help!

By the way - nice job on NT7.
Attached Files