No announcement yet.

Partner 728x90


Chart stuck at "Loading Data..."

  • Filter
  • Time
  • Show
Clear All
new posts

    Chart stuck at "Loading Data..."


    I have installed today the latest version of NT7. I am using it in simulation mode after opening a demo account at ZenFire.

    I have a most peculiar issue that I cannot resolve despite many efforts: after I successfully connect to ZenFire and I open an E6 Chart, the chart is stuck in the "loading data..." phase. The screenshot attached shows the status the app is in after about an hour waiting on it to load the data. Even more strange, it did successfully load the data ONCE, meaning that no security application or firewall is blocking it.

    This happens on both NT7 and NT6.5 (latest versions of both).

    I have tried the following:
    - uninstalled and reinstalled NinjaTrader (both 6.5 & 7)
    - deleted historical data from control center
    - tried loading data on charts with no indicators (vanilla) and charts with indicators
    - Windows firewall does not block it
    - Router does not block anything
    - Did bandwidth speed tests - my download / upload speeds are fine and according to ISP service

    My PC setup:
    - Windows Vista 64 bit
    - Quad Core CPU
    - 8 GB of RAM
    - Normal HD with 120GB free
    - 4Mbit ADSL internet connection

    Please Help!

    By the way - nice job on NT7.
    Attached Files


    Thanks for your forum post.

    What anti virus are you running? Or are you running any automatic backup software?

    I look forward to assisting you further.
    BrettNinjaTrader Product Management


      To add some other, maybe helpful info here. I had this issue today with 6E and NT7. I had charts open and live data, I changed the contracts and the new data loaded ok. My internet went out for about a minute so I got some coffee. Upon returning to the computer I had my connection back. I reloaded historical data to replace the missing data and when I tried it on the 6E chart it got stuck showing "Loading data" all day. My indicator icon was ghosted but I could add/remove indicators via right clicking on the chart. The chart was updating all day but portions of an indicator on that chart were missing, just a couple of plots. If I tried to reload historical it acted the same way, "loading data". Finally I closed the chart and opened a new one. This one stumped me.

      NinjaTrader Ecosystem Vendor - Integrity Traders


        Hi Brett,

        Thank you for the quick response.

        I am using AVG Anti-Virus 2011 Free Addition + Windows' built-in Firewall. There are no other security apps installed. Furthermore, I do not use any backup software.
        Last edited by Yaron; 12-10-2010, 05:54 PM.


          Originally posted by eDanny View Post
          To add some other, maybe helpful info here. I had this issue today with 6E and NT7...
          Indeed, it was an odd day with regards to 6E data loading.
          Thanks for sharing this.


            I get this same problem with Zenfire. Charts get stuck on loading. It happens all the time and then suddenly after an hour or so it can then just load normally. This happens almost every day.
            Incidently if I load Kinetic connection for (EOD) I get connected within seconds and all charts are shown immediately. This could show that there is something problematic with Zenfire connections that cause the machine to freeze.
            Last edited by perryg; 12-12-2010, 10:12 AM.


              I also see occasional hangs while "Loading Data" (with 7.0.1000.1 and with the earlier Betas that I tried too.)

              I'm also using Zenfire and it has happened with loading instruments ES, YM, TF and 6E (but not simultaneously) so I'd guess it's not instrument related.

              Also, if I click "Abort" in the Control Center, sometimes it will not complete either.

              How about adding a timeout and aborting the Abort if it doesn't complete in a reasonable amount of time (say a minute or two)?

              Also, could a timeout be done for the "Loading Data", so if there's no activity for a while, then quit or retry or something?


                Have the same problems with stuck "Loading Data" or sometimes "Saving".
                I'm also using the 7.0.1000.1 version with Zenfire, Win 7 64bit, but IMHO this has nothing to do with a special instrument, operating system or Zenfire.
                Restarting NT, the PC itself or deleting an old and creating a new connection doesn't help.
                Any ideas NT guys?



                  Guys, there is a known issue with this and Anti Virusus. Essentially the Auto Run Time File Scanning can cause issues with this.

                  Please add a file path exclusion in your AVG or other anti virus to the folder My Documents->NinjaTrader 7. This is not a program exclusion but a Resident Shield or RealTime Anti Virus to set a folder exclusion. So that it does not realtime scan this folder and cause issues with accessing the same file at the same time.

                  NinjaTrader needs to be allowed to create its caches and temporary files, if it is not you can get stuck on the Loading Data...

                  Also, please insure you are loading a reasonable ammount of data. Obviously loading 50 days or greater of Tick Data will take a while to download.

                  I look forward to assisting you further.
                  BrettNinjaTrader Product Management


                    Hello Brett,

                    many thanks for the answers. I have already added a file path exclusion to my anti to virus software (Avira), before I posted this problem.
                    For 6 hours until now the software tries to load some data...
                    Unfortunately, I cannot say, when this happens.



                      If a load takes longer then 20 minutes as a general rule of thumb I would consider it dead in the water. This varies based on computer speed and ammount of data needed to load.

                      Also, please check to make sure you have admin privlidges, other software known to cause this issue is automatic backup software. Are you running any of this, Essentially we need to find something that could access the same file at the same time NinjaTrader would need to access it.

                      This would account for the random nature of this occuring.
                      BrettNinjaTrader Product Management


                        Hmmm... I have admin privileges and my backup software (Acronis) is running its task at 3 AM so that there should no conflict between any programs, because I have started NT some hours after the backup was finished.
                        Maybe some other guys could add their experiences about this behaviour to solve the issue.


                          I do not have any anti virus running at all, so that rules it out. still getting stuck on loading



                            Please try right clicking on NinjaTrader icon to start it and selecting Run As Administrator. Does this make any difference?

                            Also, for the two cases still reported if not, what data feeds are you connected too, also how much data are you trying to download and for what type of chart?

                            I look forward to assisting you further.
                            BrettNinjaTrader Product Management


                              Adminstrator does not help. Am using Mirus with Zenfire. I am using charts of 6A, 6E, 6S. Even the original connection takes a long time to connect, and then the loading gets stuck. If I delete the all the workspaces, including default, I can get a relatively fast connection, but then again if I try to bring up one chart of 1 minute 6E or 6A with from 1 day to 5 days it gets stuck loading.


                              Latest Posts


                              Topics Statistics Last Post
                              Started by futureszone, Yesterday, 06:48 AM
                              4 responses
                              Last Post NinjaTrader_ChristopherS  
                              Started by UliSchmuli, Today, 10:40 AM
                              0 responses
                              1 view
                              Last Post UliSchmuli  
                              Started by Touch-Ups, Today, 06:51 AM
                              1 response
                              Last Post NinjaTrader_Emily  
                              Started by Dice2022, Today, 10:04 AM
                              0 responses
                              Last Post Dice2022  
                              Started by Philippe56140, Today, 09:13 AM
                              1 response
                              Last Post NinjaTrader_Jesse