• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Missing data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing data

    Look at the two screenshots

    this one is ES DAILY




    and this is ES in 1440 minute time frame:



    QUESTION: Do you see how they are different?

    DAILY clearly misses some data,
    I slightly touched on this problem in a different thread, but in this one I would like to get a specific answer to this issue.

    #2
    Hello Eddieban,

    Unfortunately this is as expected. Historical daily data is retrieved from our historical data server, which does not include overnight data - it consists of regular pit trading hours only.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Fortunately, my data is retrieved from 2 different data feeds, the IQFEED and the CQG ones. Both show the same. As well as your server if I am connected only to Zen-Fire. So it is something else.

      Comment


        #4
        eddieban,

        Please see my attached screenshot. What you are experiencing is likely related to different session templates being used on your daily bars versus your minute charts.

        The daily bars utilize the RTH session template. When you pull up a 1440 minute chart with RTH session template it matches up with the daily chart nicely. But, when you pull up the 1440 minute chart with ETH or 24/7 session templates you can get more data and it would look different than what you had in your daily bars.
        Attached Files
        Josh P.NinjaTrader Customer Service

        Comment


          #5
          Bingo!

          Now, my goal is to get the complete version (ETH) of all charts . How can i do this?
          In ver6.5 I've been using 1440, 2880, 4320 and 7200 minute time frames. Worked for me.
          But in ver7 I can't use anything more than 1440. If I put >1440, then I still get the 1440 minute chart.
          Can we do anything about it?

          Comment


            #6
            eddieban,

            If you want more than 1440 minutes you would need to go into the Session Template Manager and adjust the session definitions to span multiple days. The minute setting you choose would only span across the session definition. If the session definition is only one day, you only have 1440 minutes in one day so it would only show that despite trying to punch in >1440 minutes.
            Josh P.NinjaTrader Customer Service

            Comment


              #7
              Josh, you need to get a raise. Wow, thank you so much. Finally my poor soul can relax.

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by localappleseed, Today, 09:59 AM
              0 responses
              1 view
              0 likes
              Last Post localappleseed  
              Started by catinabag, Today, 08:51 AM
              1 response
              12 views
              0 likes
              Last Post NinjaTrader_Jim  
              Started by Nothing323, Today, 09:07 AM
              1 response
              7 views
              0 likes
              Last Post NinjaTrader_Tyler  
              Started by ballboy11, Today, 08:17 AM
              0 responses
              5 views
              0 likes
              Last Post ballboy11  
              Started by cutzpr, Today, 08:26 AM
              1 response
              8 views
              0 likes
              Last Post NinjaTrader_Jim  
              Working...
              X