• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

No eSignal Connection - Error -104

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    No eSignal Connection - Error -104

    Hi,
    It's not possible to get eSignal Realtime Data outside the US. I tried with symbols from Xetra and London. If I attach the eSignal-Symbol e.g. LIN-XET the error message appears. "Error on loading chart Data for "LIN-Default: Error 104 om requesting bars.
    If I change the symbol only to "LIN" there appears no error message, but I receive no data.
    What is the problem?

    #2
    EddyEd,

    Based on this, you'd need to create a second symbol with the XET exchange enabled. This isn't something possible to set within the symbol itself.

    NinjaTrader comes pre-loaded with the most commonly traded instruments however, you may find the need to add an additional instrument. Please follow the instructions below to add an instrument in the Instrument Manager.
    • From the NinjaTrader Control Center window select the menu Tools > Instrument Manager
    • Press the "New" button
    • *Enter in instrument specific information and select the appropriate exchange (add Default exchange for equities in addition to the actual exchange)
    • Fill in any relevant information under the "Misc" tab such as symbol mapping for your target connectivty provider
    • Press the "OK" button

    * If you wish to add an equity, this can be accomplished without following the steps above. Just open a chart (for example) and start typing in the symbol and a new instrument is automatically created.
    The instrument is now added to the master instrument list. Please follow the instructions below if you want to add this instrument to an instrument list.
    • Select the instrument list you wish to add the instrument to via the "Instrument lists" drop down list in the upper left hand corner
    • Select the exchange (Default recommend for equities) as this will route orders to your broker smart routing system
    • Select the appropriate expiration date if this is a futures instrument
    • Press the "<" button to add the instrument to the list

    You are now complete and can press the "OK" button.
    KyleNinjaTrader Customer Service

    Comment


      #3
      NinjaTrader_Kyle,
      Thanks for your prompt reply.
      I already have attached the exchange Xetra and default to the symbol and its also in my instruument list.
      Also I attached the esignal-syntax to the symbol. It doesn't works

      Comment


        #4
        EddyEd,

        To further assist, I'd need you to contact me via email at Support [AT] NinjaTrader [DOT] com with 'ATTN: Kyle' in the subject line.

        In that message, I'd need you to provide me with images of the settings you're trying to use and provide me with the username/password for your eSignal connection so that I could further test on my end.
        KyleNinjaTrader Customer Service

        Comment


          #5
          I have the same error but in other occasion.

          I have historical data from eSignal.

          When I am connected with eSignal and I want to create new chart ( for example CL, ES or eur futures) there is an error : "Error on loading chart data for '6E 03-11 GLOBEX':- 104 on requesting bars".

          How can I fix that?

          Thanks
          Daniel

          Comment


            #6
            Hi Daniel,

            I have a few questions for you:

            1.) Which version of NinjaTrader are you using? (Help > About)

            2.) Which interval are you charting in?
            KyleNinjaTrader Customer Service

            Comment


              #7
              Hello,

              1) 7.0.1000.2

              2) 60 minute

              Daniel

              Comment


                #8
                Hi Daniel,

                Based on what I see listed in eSignal's symbol guide, I think I have the working settings. That said, I'm afraid that my testing account isn't authorized for 6E. Would it be possible to access your eSignal connection so that I may further test?

                If so, please send a note to Support [AT] NinjaTrader [DOT] com wtih 'ATTN: Kyle' in the subject line.

                In the message please include:

                1.) A link to this forum thread.

                2.) The username and password to connect with.
                KyleNinjaTrader Customer Service

                Comment


                  #9
                  Error -104 Any Help Available?

                  Originally posted by EddyEd View Post
                  Hi,
                  It's not possible to get eSignal Realtime Data outside the US. I tried with symbols from Xetra and London. If I attach the eSignal-Symbol e.g. LIN-XET the error message appears. "Error on loading chart Data for "LIN-Default: Error 104 om requesting bars.
                  If I change the symbol only to "LIN" there appears no error message, but I receive no data.
                  What is the problem?

                  Hi,

                  I also just added Xetra subs to my eSignal account, the r/t data works fine in esignal and OmniTrader but NinjaTrader won't take it, the symbols I created new in Instrument Manager and they work fine for daily data but not minute bars - anybody got any ideas?

                  Ta

                  Comment


                    #10
                    Hi,

                    Which instruments are you working with here?
                    KyleNinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by NinjaTrader_Kyle View Post
                      Hi,

                      Which instruments are you working with here?
                      The Dax index and its 30 constituent stocks i.e on esignal $DAX-XET and ADS-XET, ALV-XET, BAS-XET, etc.

                      Tried dropping the -XET out of the symbol mapping and just leaving 'Xetra' set as exchange, this works fine for some but fails or is unreliable for others, get blank charts instead of -104's.

                      Ta

                      Comment


                        #12
                        Hello quaver,

                        You must be the same person I assisted by email this morning. I will post the information I sent you by email here as well.


                        I tested the BAS stock on my end and I was able to load data as per the configuration in the attached screenshots. I have Xetra enabled as well in addition to the Default exchange which is not visible in the screenshots.

                        Once you setup the BAS stock as the attached screenshots, please remove and re-add the BAS tock to your instrument list now that it uses different settings. Highlight the BAS in your instrument list in the Instrument Manager and click the arrow pointing to the left. Highlight the BAS in the 'Available master instruments' section and click the arrow pointing to the left. You could also restart NinjaTrader for the changes to take effect.

                        Please setup the other stock instruments in the the same fashion.
                        Attached Files
                        JasonNinjaTrader Customer Service

                        Comment


                          #13
                          Hi Jason,

                          Thanks a lot for working on this.

                          Unfortunately its not a solution, and in fact I no longer think its anything to do with the symbol mappings - the attached BAS-XET screen shots will show what I mean.

                          With the same symbol mapping setup Ninja Daily bars will load fine and run Live (see with esignal 1min chart in background) whereas simply changing the period in the same Ninja chart to one minute first results in the -104 message and then when OK is pressed results in just the last bar updating - so seems more likely to me maybe its a problem with the connection to the historical data server?

                          (I am off esignal again until I hear back from you, if it starts saying nodata/invalid password fails its because it doesn't like switching ip addresses too often intraday.)

                          Cheers,
                          Roy (yes quaver on forum)
                          Attached Files

                          Comment


                            #14
                            It works on my end without error when I switch a daily BAS chart to an 1 minute interval.

                            Can you please restart NinjaTrader and try again.

                            What happens if you create a new chart that uses an 1 minute interval?
                            JasonNinjaTrader Customer Service

                            Comment


                              #15
                              Hi Jason,

                              As discussed in emails all works just fine on a dualcore laptop, no restarts needed for the instrument manager changes, same esignal account, same exchanges, same symbols, no data issues at all, so its almost certainly timing/threading/buglet issues shown up in Ninja or esignal dll code on my main i7 8 core box.

                              Hoping a dev fix is available,
                              Cheers and thanks for the help,,
                              Roy

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by priceisking, Today, 12:51 PM
                              1 response
                              11 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by chartish, Today, 10:33 AM
                              3 responses
                              18 views
                              0 likes
                              Last Post chartish  
                              Started by casabella, Today, 11:51 AM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by Johnny, Today, 11:42 AM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_Jermaine  
                              Started by habibalex, Today, 09:03 AM
                              2 responses
                              14 views
                              0 likes
                              Last Post sledge
                              by sledge
                               
                              Working...
                              X