• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Not Responding Exit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Not Responding Exit

    For the last couple of days I've been having NinjaTrader abort on me.

    All I did was 1) start NinjaTrader, 2) click on File/New/DynamicSuperDOM... 3) click on File/New/DynamicSuperDOM again.

    Then after a few seconds it displays "(Not Responding)" on the 2nd SuperDOM and NinjaTrader just exits.

    The exit is unlike most aborts that I see, where Windows gives you a dialog asking if you want it to wait or exit now.

    I do not connect to any data feeds, I just do the above 3 steps.

    This is with 6.0.1000.6. I've tried deleting the \db\NinjaTrader.mdb file and I've tried doing a re-install asking for repair, but the problem persists with no changes in symptoms.

    No super rush on this, because I'll be out until early evening.

    #2
    Originally posted by KBJ View Post
    For the last couple of days I've been having NinjaTrader abort on me.

    All I did was 1) start NinjaTrader, 2) click on File/New/DynamicSuperDOM... 3) click on File/New/DynamicSuperDOM again.

    Then after a few seconds it displays "(Not Responding)" on the 2nd SuperDOM and NinjaTrader just exits.

    The exit is unlike most aborts that I see, where Windows gives you a dialog asking if you want it to wait or exit now.

    I do not connect to any data feeds, I just do the above 3 steps.

    This is with 6.0.1000.6. I've tried deleting the \db\NinjaTrader.mdb file and I've tried doing a re-install asking for repair, but the problem persists with no changes in symptoms.

    No super rush on this, because I'll be out until early evening.
    Hello,

    I would like to review your log files to investigate this issue. To send your log files please go to the Control Center --> Help --> Mail to support. Be sure the box to include your log files is checked.

    Comment


      #3
      Done. (See: Ticket #39528)

      Do you need anything more on this?

      Comment


        #4
        Please try this:
        a) make sure Diagnostics tab only has checked Connect, Order and "To File Only"
        b) after starting NT: make sure there is no other form open. Does it still lock up as you open superDOM?
        c) are there any funny messages in the logs?
        d) are you connected as you pull up the superDOM? if so, close connection does it still lock up?
        e) please clear out the sim account to see if that makes any difference
        DierkNinjaTrader Customer Service

        Comment


          #5
          Dierk,

          From your post, I'm unclear as to whether you might have seen my email of this morning (it was to subscriber-support at NT dot com and was in reply to an email Eamon sent me on this topic.) For your reference here are his questions and my reply:

          Hello KBJ,

          Thank you for sending this in to me.

          I have a couple of questions as I can see no activity within your Log files as far as trades. I do see a series of connections and disconnections. Please try this and let me know the results. Connect to your AMP account connection open a DOM window and place a trade into your SIM account. Then disconnect and connect to your Gain Demo account and also place a sim trade. Let me know if you are able to open a DOM window and place a trade when connected to both data feeds separately.


          Sincerely,

          Eamon Murphy
          NinjaTrader Customer Service



          ----- Original Message ----
          To: NinjaTrader Customer Service <[email protected]>
          Sent: Saturday, November 10, 2007 7:35:43 AM
          Subject: Re: [Ticket #39528]: Support request /6.0.1000.6/Microsoft Windows NT 6.0.6000.0)

          Eamon,

          All of this used to work OK. I used to connect to first the Zen-Fire then the Gain datafeed and I was able to do simulated trades on either one. Typically, I would start NT and create multiple SuperDOMs, so NT would save the price data for each of them, that I could later use for market replay. Then a few days ago NT started aborting when I did this, and I found that the minium required to cause the abort was to start NT and without connecting to a datafeed, to then create two SuperDOMs, and it would abort a few seconds after creating the 2nd SuperDOM.

          However, this morning when I do as you suggested, it seems to work fine.

          I'm running Windows Vista, and I'm now wondering if there could be some interaction with another program. I run FireFox and have quite a number of Firefox windows open. Sometimes Firefox gets too huge, taking up so much memory that it gets very, very sluggish, so I restart FireFox and it will reload the saved list of it's windows, and the problem goes away for a while. But I'm now wondering if when Firefox is using too much memory, if this could have some effect on NinjaTrader. One thing to note about the abort that is unusual is that there is no pop-up display or dialog when this occurs; instead NinjaTrader and all its windows just silently disappear from the screen.

          I will try to do some testing when FireFox next gets itself into this condition to see if maybe this is a related factor, and if so, I'll let you (and the world) know about it.

          Best regards,

          KBJ
          In response to your specific instructions:

          a) These selections were already checked without me selecting anything different.

          b) NT started with just the Control Center window, no other forms open. It no longer locks up on starting a SuperDOM. Before it locked up on 2nd SuperDOM with and no other forms and no connections. Now I can start 10 SuperDOMs and no lock-up.

          c) The logs displayed in the "Log" tab only go back to this morning, so don't cover the time period when I was having this touble. I looked at that time and do not remember seeing anything out of the ordinary. Just "Verifying license...." and "Session Break" right after I'd reconnect, no indications of why the abort might have occurred.

          d) At first I was experiencing it by doing Connect first, but then I decided to try starting the SuperDOM right after starting NT but before connecting and that caused the same abort; except that when I connected first NT aborted on the first SuperDOM started, and when not connected NT aborted after 2nd SuperDOM was started (in each case with "(Not responding)" message.)

          I just re-ran FireFox and started a huge number of windows, and NinjaTrader is now experiencing a similar symptom to before. I start NinjaTrader, and create 9 SuperDOMs without connecting and on the 9th one it displays "(Not responding)" and then exits after about a minute. This is repeatable on the 9th SuperDOM when the number of FireFox windws open is not changed (FireFox is using 418Mb of Working Set with 600MB Commit Size.)

          e) I clicked on Tools/Options/Simulator/Reset, but it did not change the repeatable behavior.

          I killed off FireFox, and restarted NinjaTrader and then created 20 SuperDOM windows with no troubles. Also, there were no troubles earlier before I created a gazillion FireFox windows. I just stopped FireFox and tried NinjaTrader again and the problem went away. I restarted FireFor and had it restore the saved windows (same as before I killed it) and the problem comes back. So I think the abort has something to do with running out of memory (although NinjaTrader didn't give any messages to the effect.)

          However, I was able to find the data seen in the attached screen shots by clicking on Start/Programs/Accessories/System Tools/Control Panel/System and Maintenance/View Problem History.

          I'm not saying NinjaTrader should continue functioning under such extreme circumstances, but it would be nice if an error message popped up or was written to the log or something.

          For now, I will leave FireFox and NT in this state. Please let me know if there's anything else you would like me to try.
          Attached Files

          Comment


            #6
            As you probably know windows is a virtual memory management system, meaning it even takes "memory" from harddrive (=swapping, takes a lot of time). That likely causes your issues and can not be controlled by NT.

            Just plug in more RAM or make sure memory used by all apps < available physical RAM.
            DierkNinjaTrader Customer Service

            Comment


              #7
              This doesn't sound like a virtual memory problem to me.

              First, before I got my Vista machine, I ran NinjaTrader using as much or more virtual memory on XP without seeing this type of problem.

              Second, I don't think NinjaTrader is running out of memory, unless NinjaTrader is trying to lock itself in memory so it doesn't do any paging or something. (I don't know if Vista allows for that, I'm thinking of VMS ... one of the old, mainframe operating systems I program from time to time that has features like that.)

              Before I start NinjaTrader the system is using 1.13 GB of physical memory. After the Control Center is started, its using 1.21 GB, and as I create the 9 SuperDOMs that it takes to cause the abort, the memory actually goes down to 1.18GB, so it must be paging some of the virtual memory out to the page file.

              I have 2GB of physical memory on the system, so its never getting close to that figure.

              It may just be some bug or limitation in Vista.
              Attached Files

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by PG7940, Today, 04:26 AM
              0 responses
              2 views
              0 likes
              Last Post PG7940
              by PG7940
               
              Started by marcus2300, Today, 02:25 AM
              0 responses
              2 views
              0 likes
              Last Post marcus2300  
              Started by drpapp, 01-24-2019, 06:57 AM
              5 responses
              69 views
              0 likes
              Last Post pjsmith
              by pjsmith
               
              Started by plydcv, Today, 12:40 AM
              0 responses
              3 views
              0 likes
              Last Post plydcv
              by plydcv
               
              Started by Sh00tHerMcGavin, Yesterday, 07:39 PM
              0 responses
              4 views
              0 likes
              Last Post Sh00tHerMcGavin  
              Working...
              X