• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Copy+Paste problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hello,

    Ok I have tested that and can confirm it.

    This has to due with purely the snap mode.

    When the snap mode is enabled it will snap the drawing objects anchor on move. This is expected as it is simply doing what you have set it to do.

    By setting snap mode you disabled to disable any snapping that might occur that changes the line/angle on the line.

    Let me know if I can be of further assistance.
    BrettNinjaTrader Product Management

    Comment


      #17
      Hello Brett,

      Thanks, ok I understand it.

      But why if I set "Equidistant bar spacing" to "False", the duplicated lines are parallel even if "Snap Mode" is set to "Disabled"? I do not understand this.

      I have another question if you do not mind. Sometimes when I am trying to duplicate a line, I select it, I press Ctrl-c + Ctrl-v and nothing happens, there is not duplicated line. I have to draw a new line and then yes, I can duplicate it with Ctrl-c + Ctrl-v.

      Comment


        #18
        Hello,

        It is my understanding the dupicated lines are always correct when snap mode is disabled correct?

        Also, are you able to reproduce this? If so I would like to login to the PC and then assist with looking into this with you.

        I look forward to assisting you further.
        BrettNinjaTrader Product Management

        Comment


          #19
          Hello Brett,

          Yes, if I set "Snap Mode" to "Disabled" and "Equidistant bar spacing" to "False" the lines are parallel. These are the steps I follow:

          File > Workspaces > New workspace
          File > New > Chart (In my case ES 06-11 and I press OK)
          I set "Snap Mode" to "Disabled"
          I set "Equidistant bar spacing" to "False"
          I draw an "Extended Line"
          I select it and Ctrl-c + Ctrl-v
          The line is parallel.
          I create other duplicated lines (I press Ctrl-v) and all of them are parellels.

          That is what I wanted to explain before. Can you reproduce this?

          Comment


            #20
            Hello,

            Yes I can reproduce this. This is working as expected. It is expected you get parrelel lines when you copy extended lines with snap mode disabled.

            Let me know if I can be of further assistance.
            BrettNinjaTrader Product Management

            Comment


              #21
              Hello Brett,

              Thanks for your answer. I do not know if I have understood, you say that

              Originally posted by NinjaTrader_Brett View Post
              It is expected you get parrelel lines when you copy extended lines with snap mode disabled.
              Then I do not understand why does this happen:
              • I create a new workspace.
              • I create a new chart.
              • I set "Snap Mode" to "Disabled".
              • I create an "Extended line".
              • I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel ---> This line should be parallel because "Snap Mode" is set to "Disabled".
              • I set "Equidistant bar spacing" to "False".
              • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.

              Comment


                #22
                Hello,

                I cannot duplicate this on my side :

                I create a new workspace.
                I create a new chart.
                I set "Snap Mode" to "Disabled".
                I create an "Extended line".
                I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel ---> This line should be parallel because "Snap Mode" is set to "Disabled".


                AT the last step here my extended line is parallel. No issues.

                Best to email me at support at ninjatrader dot com attn: Brett and reference this thread so I can login to your PC.

                I look forward to assisting you further.
                BrettNinjaTrader Product Management

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by dltharpe, Today, 09:17 AM
                0 responses
                7 views
                0 likes
                Last Post dltharpe  
                Started by HiddenPhilosopher, Today, 06:45 AM
                0 responses
                7 views
                0 likes
                Last Post HiddenPhilosopher  
                Started by PG7940, Today, 04:26 AM
                0 responses
                11 views
                0 likes
                Last Post PG7940
                by PG7940
                 
                Started by marcus2300, Today, 02:25 AM
                0 responses
                2 views
                0 likes
                Last Post marcus2300  
                Started by drpapp, 01-24-2019, 06:57 AM
                5 responses
                70 views
                0 likes
                Last Post pjsmith
                by pjsmith
                 
                Working...
                X