• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Copy+Paste problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NinjaTrader_Brett
    replied
    Hello,

    I cannot duplicate this on my side :

    I create a new workspace.
    I create a new chart.
    I set "Snap Mode" to "Disabled".
    I create an "Extended line".
    I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel ---> This line should be parallel because "Snap Mode" is set to "Disabled".


    AT the last step here my extended line is parallel. No issues.

    Best to email me at support at ninjatrader dot com attn: Brett and reference this thread so I can login to your PC.

    I look forward to assisting you further.

    Leave a comment:


  • IkerCB
    replied
    Hello Brett,

    Thanks for your answer. I do not know if I have understood, you say that

    Originally posted by NinjaTrader_Brett View Post
    It is expected you get parrelel lines when you copy extended lines with snap mode disabled.
    Then I do not understand why does this happen:
    • I create a new workspace.
    • I create a new chart.
    • I set "Snap Mode" to "Disabled".
    • I create an "Extended line".
    • I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel ---> This line should be parallel because "Snap Mode" is set to "Disabled".
    • I set "Equidistant bar spacing" to "False".
    • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.

    Leave a comment:


  • NinjaTrader_Brett
    replied
    Hello,

    Yes I can reproduce this. This is working as expected. It is expected you get parrelel lines when you copy extended lines with snap mode disabled.

    Let me know if I can be of further assistance.

    Leave a comment:


  • IkerCB
    replied
    Hello Brett,

    Yes, if I set "Snap Mode" to "Disabled" and "Equidistant bar spacing" to "False" the lines are parallel. These are the steps I follow:

    File > Workspaces > New workspace
    File > New > Chart (In my case ES 06-11 and I press OK)
    I set "Snap Mode" to "Disabled"
    I set "Equidistant bar spacing" to "False"
    I draw an "Extended Line"
    I select it and Ctrl-c + Ctrl-v
    The line is parallel.
    I create other duplicated lines (I press Ctrl-v) and all of them are parellels.

    That is what I wanted to explain before. Can you reproduce this?

    Leave a comment:


  • NinjaTrader_Brett
    replied
    Hello,

    It is my understanding the dupicated lines are always correct when snap mode is disabled correct?

    Also, are you able to reproduce this? If so I would like to login to the PC and then assist with looking into this with you.

    I look forward to assisting you further.

    Leave a comment:


  • IkerCB
    replied
    Hello Brett,

    Thanks, ok I understand it.

    But why if I set "Equidistant bar spacing" to "False", the duplicated lines are parallel even if "Snap Mode" is set to "Disabled"? I do not understand this.

    I have another question if you do not mind. Sometimes when I am trying to duplicate a line, I select it, I press Ctrl-c + Ctrl-v and nothing happens, there is not duplicated line. I have to draw a new line and then yes, I can duplicate it with Ctrl-c + Ctrl-v.

    Leave a comment:


  • NinjaTrader_Brett
    replied
    Hello,

    Ok I have tested that and can confirm it.

    This has to due with purely the snap mode.

    When the snap mode is enabled it will snap the drawing objects anchor on move. This is expected as it is simply doing what you have set it to do.

    By setting snap mode you disabled to disable any snapping that might occur that changes the line/angle on the line.

    Let me know if I can be of further assistance.

    Leave a comment:


  • IkerCB
    replied
    I have just reproduced the example with 30 bars between the anchors and then with 5 bars. Same problem.

    Leave a comment:


  • NinjaTrader_Kyle
    replied
    IkerCB,

    Can you give us an idea of how many bars so that we may more accurately test on our side?

    Leave a comment:


  • IkerCB
    replied
    Hello Brett,

    Thanks for your answer. Yes, the distance between the anchors is more than 2 bars (much more)

    Leave a comment:


  • NinjaTrader_Brett
    replied
    Hello,

    Quick question. When you draw these objects how close are the anchors? Are the at least greater then 2 bars or are the anchors(Where you click to draw it) very close together?

    I look forward to assisting you further.

    Leave a comment:


  • IkerCB
    replied
    Hello,

    I have upgraded to version 7.0.1000.4 and nothing has changed, same behaviour.

    Leave a comment:


  • IkerCB
    replied
    Well, I am back!

    I have done some tests and I have found two ways to duplicate objects without problems (at the moment)

    My intention was to duplicate a line and to move it with "Snap Mode" set to "Disabled" because if you set it to "Bar" (default value) the inclination of the line sometimes changes a little when you move it.

    First way:

    • "Snap Mode" set to "Bar" (default value)
    • I create an "Extended line".
    • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.
    • I set "Snap Mode" to "Disabled".
    • I move the line and its inclination never changes.
    • This way works ok, but everytime that I want to duplicate a line (or any other drawing object) I must set "Snap Mode" to "Bar" and then set it to "Disabled" when I move the line.


    Second way:

    • "Snap Mode" set to "Disabled".
    • I create an "Extended line".
    • I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel.
    • I set "Equidistant bar spacing" to "False".
    • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.
    • I draw and duplicate other drawing objects and everything works ok.
    • And of course, I can move the line and its inclination never changes because "Snap mode" is set to "Disabled"


    Well, that is really strange.

    I do not know if other people have the same problem, but it seems like I am the only one (?)

    Leave a comment:


  • NinjaTrader_Chip
    replied
    Sounds good IkerCB – keep us posted on your progress

    Leave a comment:


  • IkerCB
    replied
    Hello Chip, thanks!

    It is very strange, if I set Equidistant spacing to false it works ok. I will do some tests before upgrading, maybe I find a solution.

    Thanks Chip, I will notice here if I find any solution.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by darkgreen, Today, 09:36 AM
1 response
4 views
0 likes
Last Post NinjaTrader_Kate  
Started by JuanPabloQuevedo, Today, 01:04 PM
1 response
6 views
0 likes
Last Post NinjaTrader_Tyler  
Started by augustfay, Today, 10:46 AM
1 response
18 views
0 likes
Last Post NinjaTrader_Kate  
Started by neilzep, Today, 11:16 AM
3 responses
20 views
0 likes
Last Post NinjaTrader_PaulH  
Started by thebanik, Today, 10:18 AM
1 response
11 views
0 likes
Last Post NinjaTrader_ChristopherS  
Working...
X