• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Copy+Paste problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Copy+Paste problems

    Hello,

    I am working with NinjaTrader 7.0.1000.3 on Windows 7.

    I will try to explain my problem:

    • I create a new chart.
    • In the new chart window I set "Snap Mode" to "Disabled".
    • I draw an "Extended line" in the chart.
    • I select this new line and do CTrl-C and Ctrl-V (I also tried right click and copy+paste ) to paste a parallel line. The inclination of the new line is totally different, is not parallel.

    By the way, "Equidistant bar spacing" is set to "True"

    I read some other threads about similar problems but seems that they solved the problem with the 7.0.0.17 version on NinjaTrader.

    Thanks in advance.

    #2
    Hello

    Thank you for your post.

    I followed the steps you outlined but upon pasting the Extended Line drawing object the line that results is parallel. I am using NinjaTrader 7 version 4
    ChipNinjaTrader Customer Service

    Comment


      #3
      Hello Chip,

      Thank you very much for your answer.

      I have restarted right now NinjaTrader, I created a new workspace and I followed the same steps and I have the same problem, the line is not parallel.

      Is strange, but I have tried setting "Equidistant bar spacing" to "False" and it works fine, every duplicated line now is parallel. Very strange......

      Any idea?

      Comment


        #4
        Hello IkerCB

        I am unable to reproduce the exact scenario since I am using version 4 (not 3). I was able to copy/paste & generate a parallel line both with Equidistant Bar Spacing on & off – same result.
        ChipNinjaTrader Customer Service

        Comment


          #5
          Maybe another forum participant who is using version 3 can try this & see what takes place.

          Depending on the outcome, you may want to upgrade your installation of NinjaTrader to version 4.
          ChipNinjaTrader Customer Service

          Comment


            #6
            Hello Chip, thanks for your answer.

            I have had problems with copy and paste in previous versions of NinjaTrader too, so I do not know if upgrading to version 4 would resolve the problem. Anyway, I will try upgrading.

            If anyone is reading this and is using version 3, I would really appreciate if he could try to reproduce the problem following the steps.

            Thanks.

            Comment


              #7
              Hello IkerCB

              I found another PC here running version 3 & Windows XP. Here’s what I found when I re-ran the scenario

              Equidistant spacing off – paste of Extended Line was non-parallel
              Equidistant spacing on – paste of Extended Line was parallel

              Hope this helps
              ChipNinjaTrader Customer Service

              Comment


                #8
                Hello Chip, thanks!

                It is very strange, if I set Equidistant spacing to false it works ok. I will do some tests before upgrading, maybe I find a solution.

                Thanks Chip, I will notice here if I find any solution.

                Comment


                  #9
                  Sounds good IkerCB – keep us posted on your progress
                  ChipNinjaTrader Customer Service

                  Comment


                    #10
                    Well, I am back!

                    I have done some tests and I have found two ways to duplicate objects without problems (at the moment)

                    My intention was to duplicate a line and to move it with "Snap Mode" set to "Disabled" because if you set it to "Bar" (default value) the inclination of the line sometimes changes a little when you move it.

                    First way:

                    • "Snap Mode" set to "Bar" (default value)
                    • I create an "Extended line".
                    • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.
                    • I set "Snap Mode" to "Disabled".
                    • I move the line and its inclination never changes.
                    • This way works ok, but everytime that I want to duplicate a line (or any other drawing object) I must set "Snap Mode" to "Bar" and then set it to "Disabled" when I move the line.


                    Second way:

                    • "Snap Mode" set to "Disabled".
                    • I create an "Extended line".
                    • I duplicate that line (Ctrl-c + Ctrl-v) The line is not parallel.
                    • I set "Equidistant bar spacing" to "False".
                    • I duplicate that line (Ctrl-c + Ctrl-v) The line is parallel.
                    • I draw and duplicate other drawing objects and everything works ok.
                    • And of course, I can move the line and its inclination never changes because "Snap mode" is set to "Disabled"


                    Well, that is really strange.

                    I do not know if other people have the same problem, but it seems like I am the only one (?)

                    Comment


                      #11
                      Hello,

                      I have upgraded to version 7.0.1000.4 and nothing has changed, same behaviour.

                      Comment


                        #12
                        Hello,

                        Quick question. When you draw these objects how close are the anchors? Are the at least greater then 2 bars or are the anchors(Where you click to draw it) very close together?

                        I look forward to assisting you further.
                        BrettNinjaTrader Product Management

                        Comment


                          #13
                          Hello Brett,

                          Thanks for your answer. Yes, the distance between the anchors is more than 2 bars (much more)

                          Comment


                            #14
                            IkerCB,

                            Can you give us an idea of how many bars so that we may more accurately test on our side?
                            KyleNinjaTrader Customer Service

                            Comment


                              #15
                              I have just reproduced the example with 30 bars between the anchors and then with 5 bars. Same problem.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Skyfly1715, Yesterday, 03:36 PM
                              1 response
                              8 views
                              0 likes
                              Last Post NinjaTrader_Marco  
                              Started by samatron, Yesterday, 09:49 PM
                              1 response
                              9 views
                              0 likes
                              Last Post NinjaTrader_ChrisSch  
                              Started by moulsworth, Today, 12:45 AM
                              0 responses
                              3 views
                              0 likes
                              Last Post moulsworth  
                              Started by Dr3am, Yesterday, 05:10 PM
                              1 response
                              6 views
                              0 likes
                              Last Post NinjaTrader_ChrisSch  
                              Started by Captain Jack, Yesterday, 02:53 PM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_ChrisSch  
                              Working...
                              X