• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Alert not working in indicator

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • eclipsed
    started a topic Alert not working in indicator

    Alert not working in indicator

    Hi
    I am trying to get an alert to sound when an overbought/oversold condition exists in this indicator. It compiles successfully but does not work and I cannot see why,

    Ideally I only want it to sound once but that is less important than sounding in the first place!

    Could you look at the code to see what I am doing wrong please.

    Thanks
    Attached Files

  • bowas
    replied
    Thank you so much! I really enjoy this indicator and is the only one I use, but I am not a programmer. Thank you again!!

    Leave a comment:


  • NinjaTrader_AlanP
    replied
    Hello bowas,

    I have converted the indicator to NT8 and attached the file.

    Please let us know if you need further assistance.
    Attached Files

    Leave a comment:


  • bowas
    replied
    Originally posted by eclipsed View Post
    Hi
    I am trying to get an alert to sound when an overbought/oversold condition exists in this indicator. It compiles successfully but does not work and I cannot see why,

    Ideally I only want it to sound once but that is less important than sounding in the first place!

    Could you look at the code to see what I am doing wrong please.

    Thanks
    I have used this indicator for a long time, but don't know where I got it. Now that I am forced to use NT8, where can I get it converted from NT7?

    Not concerned with the sound function, just the indicator with BUY, SELL and NO TRADE colors.

    Please look at the beginning of this thread to see the indicator. CCITrend2

    Thank you
    Last edited by bowas; 06-05-2018, 05:06 PM.

    Leave a comment:


  • eclipsed
    replied
    Hi Bertrand

    It works for me now! After I modified it, I forgot to re-load the indicator - a bit fundamental really but many thanks for your help and sorry to trouble you.

    Not sure about boolean flag codes though so will have to be satisfied with alarm repeats - it's not too frequent anyway.

    Leave a comment:


  • NinjaTrader_Bertrand
    replied
    eclipsed, the PlaySounds works for me here - are you sure the sounds itself work ok in your NT and the soundfile Alert1 is present in the respective install dir sounds folder?

    Later on you might want to add logic to trigger the sound / alert only if the condition happens the first time and not on subsequent bars, this could be for example done with boolean flags in your code.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by ballboy11, Today, 05:22 PM
0 responses
3 views
0 likes
Last Post ballboy11  
Started by ballboy11, Today, 04:33 PM
2 responses
4 views
0 likes
Last Post ballboy11  
Started by dedouglas, Today, 03:16 PM
1 response
7 views
0 likes
Last Post NinjaTrader_ChelseaB  
Started by TradeMyth, Today, 02:45 PM
3 responses
26 views
0 likes
Last Post NinjaTrader_ChelseaB  
Started by Ticnician, Today, 01:46 PM
1 response
9 views
0 likes
Last Post NinjaTrader_Jim  
Working...
X