• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

No ETFs in fresh installation of NinjaTrader 7.0.1000.4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No ETFs in fresh installation of NinjaTrader 7.0.1000.4?

    I just installed a brand spanking new NT7.0.1000.4 on a new virgin hard drive/operating system.

    When I try to load any ETF, I get a message that it is not in the database. So far, I have tried SPY, IWM, QQQQ, UUP. A search from the Instrument Manager does not find any of them either.

    Now, I am reasonably certain that I have never had to manually add SPY, at least, to the instrument manager, but it has been so long that I will not swear to it.

    Did you really not put ETFs in the instruments.txt file, or is my installation somehow FUBAR, even after a repair installation, and a new installation of a fresh download, after removing the first installation?

    #2
    Hello koganam,

    Yes, unfortunately the ETF's you refer are not present by default in NinjaTrader.

    The quickest way to insert them in the Instrument Manager is as follows. Please create a new chart for an instrument you already have present. Subsequently type in the instrument symbol when the chart is activated and the instrument will be added in the Instrument Manager.

    From the help guide at the link below under 'How to change a Data Series'.
    http://www.ninjatrader.com/support/h...price_data.htm

    Equities can be added to the NinjaTrader instrument database by typing the instrument symbol followed by the exchange into an open chart and pressing the "Enter" key on your keyboard. For example, you can type "YYY NYSE" to add stock "YYY" mapped to the Nyse. Just typing "YYY" without the exchange will map to the Default exchange and will use the "Default 24/7" session template.

    In addition, please note that the QQQQ changed to QQQ.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Thanks. I guess that must be how I added them, without realizing that I was adding them, and not calling something that was already there.

      Thanks.

      Comment


        #4
        Jason - I've followed your instructions above and still can't get any ETFs... unless I'm doing something wrong.

        1. Get chart of AAPL up, ensure daily data for Kinetick EOD feed
        2. Type DBA (or DBA NYSE) data series in the chart
        3. Nothing happens - same for a whole bunch of ETFs

        Please advise?

        Comment


          #5
          Hello BasuraBreakout,

          It worked on my end when I tested. I typed "DBA" and it loaded data.

          Does it work when you try another stock symbol?

          Please note that you do not need to hold the Shift key. As soon as I type "d", it opens the Data Series box with a "D" included. I include "BA" and hit Enter.
          Attached Files
          JasonNinjaTrader Customer Service

          Comment


            #6
            Jason, thanks for the reply - it worked after I logged out and back in.

            Cheers, BB

            Comment


              #7
              I'm having the same issue. I'm trying to get SLV and GLD charts up. I'm connected to IB and stocks like AAPL and ES futures are working fine.

              I get 2 pop ups

              Error onloading chart data for SLV default. Unable to change order. Please assign and additional exchange to this instrument in the IM SLV default

              and

              Unable to subscribe to market data. Please assign and additional exchange to this instrument in the IM SLV default


              And I have the chart up in IB so I do have real time data

              Thanks

              Comment


                #8
                Hello liam33,

                Thanks for your post.

                The exchange for both of these instruments would need to be changed from 'Default' to the correct setting 'Arca'. Please:
                Open the Instrument Manager by clicking Tools > Instrument Manager.
                Select an instrument (GLD for example) from the list on the right, then click the Edit button.
                In the menu which appears, check ARCA, then click OK.

                Close and then re-open the Instrument Manager, then remove and re-add the instrument to your default instrument list by following the steps listed here: http://www.ninjatrader.com/support/h...ment_lists.htm
                KyleNinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by itrader46, Yesterday, 01:09 PM
                4 responses
                21 views
                0 likes
                Last Post RedDuke
                by RedDuke
                 
                Started by Tradwell385, Today, 12:26 PM
                1 response
                2 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by vivekniwas, Today, 11:31 AM
                1 response
                11 views
                0 likes
                Last Post NinjaTrader_Heath  
                Started by Austiner87, Yesterday, 04:59 PM
                1 response
                9 views
                0 likes
                Last Post NinjaTrader_Jesse  
                Started by rlcheny, Today, 10:38 AM
                1 response
                8 views
                0 likes
                Last Post NinjaTrader_Tyler  
                Working...
                X