• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Order Confirmation Problem between IB and NT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Order Confirmation Problem between IB and NT

    Hello,

    I've had this strange probelm for the past two days. After an order is filled NT gives an error message saying that NT did not recieve confirmation of one or all of the stop-loss and exit oders accompanying the trade. I check IB and everything is OK. I checked the IB and NT nfo per the installation guide and everything is OK. I reinstalled NT and the probelm still exists. I am using IB-TWS 853.7 2005/10/25 Java Version 1.4.2.

    I've attached a JPG pic of the actual error message

    How can I fix this problem?

    Thanks,

    Chip


    Attached Files

    #2
    imported post

    Hi Chipper,

    can you downgrade to TWS version 851.9. You can do so from this link:

    http://www.interactivebrokers.com/cgi-bin/windows_standalone_tws.pl

    It could be that you need to Cut and Paste the link into your browser

    Vincent
    Vince B.NinjaTrader Customer Service

    Comment


      #3
      imported post

      The link I provided won't be available for a long time any more, can you use this link. Then you can use it as long as V4 is available:

      www.ninjatrader-support.com/ninjatrader/TWS/tws40_install_851.exe



      Vincent
      Vince B.NinjaTrader Customer Service

      Comment


        #4
        imported post

        Vincent,

        Rolling back installations works like a charm.

        Ty

        Chip


        Comment


          #5
          imported post

          I am using TWS version 851.9 on NT version 4.0.42, but received notice today that IB will no longer support less than TWS 852 after 12/18/05. Will this work without problems?

          Can you give an address to whichever version will work?



          Thanks

          Comment


            #6
            imported post

            We are looking into this right now.

            - V4.0.43 whichis due out to be released January 1, 2006 will work with the current TWS

            - V5.XXX works the current TWS will also work

            Ray
            RayNinjaTrader Customer Service

            Comment


              #7
              imported post

              Meaning what Ray? That there will possibly be a solution before Dec. 18?

              Comment


                #8
                imported post

                Possibly but not sure yet. Looking into it.
                RayNinjaTrader Customer Service

                Comment


                  #9
                  imported post

                  Go ahead and update to the latest TWS. NT V4.0.42 should work. I have tested it and it worked fine. Let me know if you see otherwise.

                  Ray
                  RayNinjaTrader Customer Service

                  Comment


                    #10
                    imported post

                    How do I get a copy of TWS 852? The oldest version on the IB website is 853.

                    Comment


                      #11
                      imported post

                      Why do you want an older TWS version? Use the latest TWS with NT 4.0.42.

                      Ray
                      RayNinjaTrader Customer Service

                      Comment


                        #12
                        imported post

                        Unless Ninja 4.0.42 has recently been changed to handle the new TWS version, it fails. (Just look at the beginning of this thread.) Was it changed & tested? If so, when?

                        Comment


                          #13
                          imported post

                          Look at the post at 9:32 AM.
                          RayNinjaTrader Customer Service

                          Comment


                            #14
                            imported post

                            I'm using NT v4.0.42 with latest TWS v854.7, Java 1.5.0_04 but still using API v8.3.

                            Works fine here, fwiw.

                            al_gorithm

                            From: SellUmHi
                            Date: 2005-12-13 11:58:18
                            Reply: http://ninjatrader.mywowbb.com/reply.php?topic_id=468

                            Unless Ninja 4.0.42 has recently been changed to handle the new TWS version, it fails. (Just look at the beginning of this thread.) Was it changed & tested? If so, when?

                            Comment


                              #15
                              imported post

                              To complete the information: NT is not using any IB API software.
                              DierkNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by thgamey, Today, 06:46 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post thgamey
                              by thgamey
                               
                              Started by AxelrodWins, Yesterday, 09:56 PM
                              2 responses
                              22 views
                              0 likes
                              Last Post AxelrodWins  
                              Started by Johnny Santiago, Yesterday, 08:47 AM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_EricB  
                              Started by GLFX005, Today, 05:48 AM
                              1 response
                              10 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Started by TSmith, Today, 01:40 AM
                              2 responses
                              38 views
                              0 likes
                              Last Post TSmith
                              by TSmith
                               
                              Working...
                              X