• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Historical

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Historical

    I don't understand.

    I had this code working fine:

    protected override void OnBarUpdate()
    {


    if (Historical)
    return;

    From now and I don't know why with the same code it's executing code on historical. Did you have anyu similar issue?

    #2
    guillembm, is this a single or multiseries strategy / script?
    BertrandNinjaTrader Customer Service

    Comment


      #3
      Multi-instrument strategy. But it always worked. I'm LOST

      Comment


        #4
        guillembm, as first step please ensure you load enough bars for all series involved so that BarsRequired would be fulfilled.
        BertrandNinjaTrader Customer Service

        Comment


          #5
          Increasing the number of bars was enough. I don't understand. Two hours ago with the same number of bars than always I had no problem. What is the explanation?

          Comment


            #6
            Glad to hear, I would tip on a data loading issue for one or more series so the BarsRequired could not be satisfied.
            BertrandNinjaTrader Customer Service

            Comment


              #7
              Check here:

              http://www.ninjatrader.com/support/f...d.php?p=267652



              Originally posted by guillembm View Post
              I don't understand.

              I had this code working fine:

              protected override void OnBarUpdate()
              {


              if (Historical)
              return;

              From now and I don't know why with the same code it's executing code on historical. Did you have anyu similar issue?

              Comment


                #8
                Uff! this is an old thread.

                I had to reinstall NT and the error was solved. Could be whatever

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by nailz420, Today, 09:15 PM
                0 responses
                0 views
                0 likes
                Last Post nailz420  
                Started by ATMtrader0001, Today, 01:27 PM
                1 response
                7 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by ATMtrader0001, Today, 01:16 PM
                1 response
                2 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by elnoppo, Today, 01:25 PM
                2 responses
                8 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by FabianoTrader, Today, 04:00 PM
                2 responses
                15 views
                0 likes
                Last Post FabianoTrader  
                Working...
                X