Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Data correction in HDM doesn't show on chart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Data correction in HDM doesn't show on chart

    Hi,

    a data error appeared on my 60 min chart for 2011-09-15, putting a big-assed bar right in the middle of the chart.

    I went into the Historical Data Manager and corrected the minute bar which was causing the problem and saved it.

    Back on the chart, I reloaded it but the data error remained visible.

    So I closed NT and restarted it but the error remained visible. I tried renaming the $EURUSD directory in the NT7/db/cache/timezone/minute directory. That blanked the whole chart.

    What do I have to do to force the chart window to display the corrected data?

    Thanks

    PS I changed down to the minute timeframe to make sure there was only one bar that was wrong. The tick data is OK.

    #2
    Hello adamus,

    Can you please create a new EURUSD chart via Control Center-->File-->New-->Chart and check if the large bar persists.

    If so, please go back into the Historical Data Manager and check if the change is still in effect.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Hi Jason,

      I did this too and the large bar persisted.

      Then later on after posting here, I close and re-opened NT7 and the last couple of days of data (this week) had disappeared. I figured this was due to renaming the folder for this symbol in the db/cache directory. I had to re-download the data, and at that point the bad bar was removed.

      This took out about an hour of my day, including posting here and other things. Surely this isn't meant to happen? I had this problem before but didn't need to see the correct data so I didn't post about it, so it's not the first time it's happened.

      Comment


        #4
        Hello adamus,

        I see, good to hear the incorrect data does not persist after downloading fresh historical data.

        Yes, sorry to hear about the issue - editing historical data in the Historical Data Manager should reflect in charts.

        Please note that NinjaTrader acts like a radio receiver and displays the data it receives. If these incorrect prices are received in real-time, you can setup our real-time tick filter to filter them out.

        Can you please go to Control Center-->Tools-->Options-->Data-tab. Subsequently, enter a percentage for the 'Filter bad ticks % off market' field. A value of of 10, represents 10 %. So if a real-time tick is outside the range of 10 % compared the tick received prior, it will be excluded.

        Let me know if you run into the issue when modified historical data is not reflected in the chart and send me an email via Control Center-->Help-->Mail to support. Please include all items such as chart data, templates, workspaces, etc.
        JasonNinjaTrader Customer Service

        Comment


          #5
          To tell you the truth, I'd rather my problem was solved through technical know-how than just by chance, and I'm not worried about minor mistakes as long as I know how to put them right. I use that "bad ticks" functionality, and like I said above, the tick data in the HDM is perfect - the error was in the Minute bar data.

          What am I supposed to do to correct bad data? (I mean, apart from informing you if it goes wrong)

          Should I do anything with the cache, or is that irrelevant?

          Comment


            #6
            I suggest to perform the same steps. Please manually edit the data in the Historical Data Manager first.

            If this will not work, please let me know and I will try to find a reproducible scenario so I can report it to Development.

            Subsequently, please delete the current historical data and load fresh historical data. Please delete the historical data in the db-->cache folder as well before loading fresh historical data.
            JasonNinjaTrader Customer Service

            Comment


              #7
              I just suffered another data error and now I think I know more about the problem.

              In another post about IB instruments I found out that there are problems that occur when using the same quote provider symbol for different instruments. I think that is what is causing me problems here.

              I tried to download the data for the time that is in error, but I cannot get it to display on the chart, despite doing everything I can think of.

              What will happen if I delete the instrument data in the cache folder using Windows file manager? Will NT7 then display it properly? I don't want to mess up any of the rest of my data.

              Thanks

              Comment


                #8
                Yes, please do not use multiple instruments with the same symbol mapping. This is known to cause issues.

                Can you please delete any instrument that is using a duplicate symbol mapping and restart NinjaTrader. Subsequently, check if the data is loaded in a chart.

                Deleting the cache folder will not affect data you have saved in the (My) Documents-->NinjaTrader 7-->db-->tick/minute/day folders.
                JasonNinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by pvtrader, Today, 10:34 AM
                2 responses
                13 views
                0 likes
                Last Post pvtrader  
                Started by Tamza, Today, 08:56 AM
                1 response
                28 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Started by teafortwo, Today, 09:17 AM
                4 responses
                23 views
                0 likes
                Last Post teafortwo  
                Started by Abdullah_KSA, Today, 08:47 AM
                1 response
                15 views
                0 likes
                Last Post NinjaTrader_Jim  
                Started by sdauteuil, Today, 09:13 AM
                1 response
                6 views
                0 likes
                Last Post NinjaTrader_PaulH  
                Working...
                X