• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Day chart gaps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Day chart gaps

    Hi,

    I have everything pretty much the way I like it, except for my Day Chart. The 60 and 240 min charts are fine and my Weekly and Monthly charts are fine. I am using Zenfire and your own Kinetick feed. Attached is a screen shot, for clarity the LEFT side is Ninja Trader and RIGHT side is TS. As you will see, it is only in the 'Daily' chart that things really go amise (third graph down), but works again on the weekly.

    The problem is the Day chart, this has gaps, now I know this is something to do with zenfire 'daily' data only supplying pit hours not Globex hours (had previous issue with pivots). Is there a way of telling Ninjatrader to ignore zenfire historical data and load from kinetick? Even if I could tell the chart to 'choose' a feed, that would be fantastic step forward. As you can appreciate this is frustrating when I am fairly close to my goal - but again the 'daily' data issue rears it's ugly head again.

    Please put option to 'ignore Zenfire daily data' near to the top of any development list - thanks!

    Sunrise

    Attached Files
    Last edited by Sunrise; 09-22-2011, 11:25 AM.

    #2
    Hello Sunrise,

    Thank you for your post.

    If you require ETH bars (without gaps) from your data provider, you can use 1440 Minute bars to replicate the Day bars and set this to the ETH Session template.

    This will replicate the Daily bars and ensure they are plotted as continuous without gaps
    MatthewNinjaTrader Product Management

    Comment


      #3
      Matthew,

      Thanks for the reply. I understand what you have said, and I can use this as a quick fix solution, however, you have to realise for a trader that has been trading for many years how truely silly that is, other platforms manage OK.

      Ninjatrader should have fixed this by now, so that daily graphs work (if I choose ETH session template) showing ETH hours, or allow user to choose which feed should be used. I can change it as you mention, however, we will laugh at the screen everytime someone points out the '1440' chart and we joke that 'Ninjatrader cannot even get its daily bars right!'

      Please, for Ninjatrader's credibility sake, if not my own - get it fixed! [Yes, I am afraid it is Ninjatrader that will be pointed at as there is a solution should ninjatrader choose to implement it].

      I will now go and play with my 1440 chart !

      Still smiling....

      Enjoy,

      Sunrise

      Comment


        #4
        Sunrise,

        The limitation is due to the data servers only offering RTH bars on your primary connection. NinjaTrader has no issues displaying ETH bars as long as they are sent from your provider.

        Since your primary provider does not offer RTH bars, you will need to use 1440M to supplement.

        If you would like to use ETH Daily bars, I would recommend using your Kinetick connection as primary as the Kinetick Daily bars with be ETH and will not display gaps.

        To ensure Kinetick is your primary connection, you will want to connect to this first. More information on Multiple Connections will be found below:

        http://www.ninjatrader.com/support/h...onnections.htm
        MatthewNinjaTrader Product Management

        Comment


          #5
          OK, that solves one problem, but creates another. When placing Kinetic as first connection I can no longer use the Sim accounts - I think it assumes they are real trade entries.

          Also, because I cannot modify the 'Kinetic' connection I cannot tick the 'connect at start-up' option (which would ensure that I always loaded the connections in the right order).

          Any way of solving the above two issues?

          Regards,

          Sunrise.

          Comment


            #6
            Unfortunately when trading in simulation only the first connection is recognized and orders cannot be submitted to the Kinetick End of Day connection since this does not provide real time data.

            When trading in simulation the only option is to connect to Zen-Fire and create Daily bars using a 1440 Minute chart.

            Keep in mind when trading live you will then have the ability to connect to the Kinetick End of Day connection first and Zen-Fire second and submit orders to your live account without this limitation.

            The Kinetick End of Day connection is created by default within NinjaTrader and unfortunately cannot be modified and will need to be connected to manually.
            Christopher J.NinjaTrader Customer Service

            Comment


              #7
              Thanks for the reply.

              Surely you can see that this is a messy solution? The simple answer would be for a tick box to ignore daily data from a connection, possible tick box in connection setup.

              Can you please forward this as a suggestion to your development team as a needed item. This would resolve a whole list of issues.


              Regards,

              Sunrise.

              Comment


                #8
                I have forwarded this to our development team as a suggestion on how we can improve the NinjaTrader platform. Once this suggestion has been input into our tracking system I will forward you the assigned ID number for tracking.
                Christopher J.NinjaTrader Customer Service

                Comment


                  #9
                  Many thanks,

                  Sunrise

                  Comment


                    #10
                    This request has been submitted to our development team and has been assigned ID #10 for tracking.

                    Thanks again for your suggestion and please let me know if I may be of further assistance.
                    Christopher J.NinjaTrader Customer Service

                    Comment


                      #11
                      btw its 1405 min for the us minis and 1395 min for crude oil

                      btw its 1405 min for the us minis and 1395 min for crude oil

                      on a 24/5 template to have the same "daily" bars

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by Wingo, Today, 04:52 PM
                      1 response
                      9 views
                      0 likes
                      Last Post bltdavid  
                      Started by Bionian, Today, 10:10 AM
                      3 responses
                      20 views
                      0 likes
                      Last Post Bionian
                      by Bionian
                       
                      Started by D Trader, Today, 01:41 PM
                      0 responses
                      13 views
                      0 likes
                      Last Post D Trader  
                      Started by rexmie888, Today, 04:00 AM
                      1 response
                      10 views
                      0 likes
                      Last Post NinjaTrader_ShawnB  
                      Started by terminatorT1000, Today, 01:23 AM
                      1 response
                      17 views
                      0 likes
                      Last Post NinjaTrader_ShawnB  
                      Working...
                      X