Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Simple RSI(2) on Market Analyzer not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Simple RSI(2) on Market Analyzer not working

    Hi, I am trying to the a simple RSI(2) on Market Analyzer but it's giving me different results from what I get on the chart.

    I have configured to use Daily bars but still not working, do I need to change any parameters on the Market Analyzer settings?

    Thanks

    #2
    Hello tradinghumble,

    Please provide me with a copy of your workspace and tell me which instrument you're comparing values with.

    You will find the workspace in the Documents > NinjaTrader 7 > Workspaces folder.
    KyleNinjaTrader Customer Service

    Comment


      #3
      Kyle, sorry for the delay, it's not too much about the workspace but the Market Analyzer window which is not working, I get my quotes real-time (IQFeed) and the RSI(2 periods) I added as a column in MA but it doesn't seem to be calculating based on 'daily bars' it seems to be using the period of the Market Analyzer which I have no idea where to set ... can you please help?

      Comment


        #4
        Hi,

        By obtaining a copy of the workspace, I'm simply looking for a copy of your settings - this way you and I are working from the same starting point.
        KyleNinjaTrader Customer Service

        Comment


          #5
          Kyle, attached, please rename it back to .xml
          Attached Files

          Comment


            #6
            tradinghumble, please try using a higher # of days lookback here so the value can be normalized sufficiently when comparing to your charts.
            BertrandNinjaTrader Customer Service

            Comment


              #7
              Bertrand, can you please provide details on your suggestion to increase number of days? Where are you referring to? In the indicator RSI (2), I increased the # of bars lookback to 50 and the RSI(2) calculation is still incorrect. Can you please expand? Thanks in advance.

              Comment


                #8
                I was referring to the # of bars lookback entry you have for every indicator in its parameters in the Market Analyzer, if this is set high enough and the issue persists :

                Are you using the same CalculateOnBarClose setting for your chart and Market Analyzer column?

                Are you using comparing the same plot of the RSI and not for example the smooth plot in the MA to the Default RSI value in the chart?

                Thanks,
                BertrandNinjaTrader Customer Service

                Comment


                  #9
                  Bertrand, setting the indicator's "calculate on bar close" to true fixed the issue, thanks for your help.

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by xmess777, Yesterday, 07:16 PM
                  1 response
                  22 views
                  0 likes
                  Last Post NinjaTrader_Jesse  
                  Started by 8033075, Yesterday, 08:13 PM
                  1 response
                  34 views
                  0 likes
                  Last Post NinjaTrader_Jesse  
                  Started by futurenow, Yesterday, 06:13 PM
                  1 response
                  24 views
                  0 likes
                  Last Post NinjaTrader_BrandonH  
                  Started by trader3000a, Today, 07:34 AM
                  6 responses
                  23 views
                  0 likes
                  Last Post NinjaTrader_PaulH  
                  Started by focus333, Yesterday, 11:28 PM
                  1 response
                  23 views
                  0 likes
                  Last Post NinjaTrader_BrandonH  
                  Working...
                  X