• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Bars Required parameter difference in NT6.5 and 7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bars Required parameter difference in NT6.5 and 7

    Hi,

    I am trying to go to NT7 fully from NT6.5 but I am not getting the same results in walk forward testing in the strategy analyzer for historic data back testing. At this point, it looks like my results differ because of the bars required parameter in the UI.

    Is there a fundamental difference for the way that bars required parameter works between NT 6.5 and NT7?

    #2
    pantelis, the change going to NT7 you're likely runing into is that the BarsRequired is skipped in the WalkForward test now in the rolled to WalkForward period. This was documented in our code breaking changes docs here - http://www.ninjatrader.com/support/f...ad.php?t=21016
    BertrandNinjaTrader Customer Service

    Comment


      #3
      In NT6.5, my strategy has been optimized for a barsrequired value of 1 in the walk forward testing of historical data. The strategy uses 15 minute (primary instrument) bars and daily (secondary instrument) bars with its DM indicators.

      What must I do in NT7 to ensure I get the same results?

      Comment


        #4
        Hello pantelis, unfortunately for the change in the WalkForward approach I posted this could not be set to mimic NT 6.5's behavior exactly.
        BertrandNinjaTrader Customer Service

        Comment


          #5
          So it's not possible to get the exact result and I should start fresh again with NT7 until I am happy with the result?

          Comment


            #6
            Yes, it would be then best to retest your strategy in the new environment - are the results close together if you just 'normally' backtest over historical data? If not then I would first look into how to bring align them better, for example ensure the data is exactly the same and also that sessions used are fitting (NT7 now goes by the session templates defined under Tools > Session Manager).
            BertrandNinjaTrader Customer Service

            Comment


              #7
              Data and session templates are exact. I get different results and would have to conclude that the back testing algorithms have been changed. Hopefully for the better?

              Comment


                #8
                Still no joy. My backtest parameters optimised are the same for NT 6.5 and 7. It seems like the walkforward execution is different. When the code breaking changes say that "BarsRequired is skipped in the rolled forward period of a walk forward optimization" does this mean that walk forward uses the default setting of 20? If so, how can I change the default?

                Comment


                  #9
                  Hi Bertrand,

                  Any idea on when you can get back to me regarding this issue?

                  Regards

                  Pantelis

                  Comment


                    #10
                    Hello pantelis, thanks for ringing my bell on this issue - BarsRequired is not applicable then to the rolled to periods for testing of the WFO, so the same as BarsRequired being 0 here. The setting you enter when starting the WFO optimiztion would apply to the optimization period only, this is the change from 6.5 here. Hope that helps,
                    BertrandNinjaTrader Customer Service

                    Comment


                      #11
                      Hi Bertrand, for NT6.5, I use barsrequired of 1 for the WFO which means barsrequired of 1 for the optimization test period and a barsrequired of 1 for the rolled to WF test period. For NT7, I use barsrequired of 1 for WFO which means barsrequired of 1 for the optimization test period and a barsrequired of 0 for the rolled to WF test period. The result is that my optimization test period results are 99.9% the same but my rolled to WF test period results look 100% different and on closer inspection, it does not seem to follow my multi time frame indicator rules correctly.

                      If the barsrequired parameter is the problem, is there a way I could change it from 0 to 1 for the rolled to WF test period?

                      Comment


                        #12
                        Unfortunately the parameter could not be changed for the rolled to WFO data window, I will however add this as suggestion to our product development lists.

                        For the WFO - would it run correctly with our shipped SampleMultiTimeFrame strategy?

                        If you like me to give this a test run on my end, please contact me directly at support at ninjatrader dot com.
                        BertrandNinjaTrader Customer Service

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by Balage0922, Today, 07:16 AM
                        0 responses
                        2 views
                        0 likes
                        Last Post Balage0922  
                        Started by frankduc, Today, 07:10 AM
                        0 responses
                        3 views
                        0 likes
                        Last Post frankduc  
                        Started by mbesha, Today, 07:00 AM
                        1 response
                        4 views
                        0 likes
                        Last Post NinjaTrader_Jesse  
                        Started by faustf, Today, 06:28 AM
                        1 response
                        4 views
                        0 likes
                        Last Post NinjaTrader_PaulH  
                        Started by svadukia, Today, 05:41 AM
                        3 responses
                        4 views
                        0 likes
                        Last Post NinjaTrader_PaulH  
                        Working...
                        X