• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

CliSecure Protecting Your Code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    CliSecure Protecting Your Code

    Hello to All:
    I am new to this forum.
    I want to know the correct version and install it.

    Protecting Your Code
    CliSecure .NET code protection module offers better protection for your .NET code by providing a protection that goes beyond standard obfuscation methods., .....

    1. Before
    public bool VerifyLicense()
    {

    string file = GetLicenseFile();
    Trace.WriteLine("License file path:{0}",file);
    if (File.ReadAllText(file)!=this.licenseKey)
    {
    throw new LicenseException(null,null,"Invalid license");
    }
    return true;
    }


    2.After
    public bool VerifyLicense()
    {
    return false;
    }

    thank you very much

    #2
    Hello,

    Thanks for the note and welcome to the forum.

    Please use these instructions located here for protection.

    http://www.ninjatrader.com/support/h...l_security.htm

    Let me know if I can be of further assistance.
    BrettNinjaTrader Product Management

    Comment


      #3
      Hi
      If this procedure do not let me import it and that's fine, but I also want a certain program, if I put it on another PC, do not see the algorithm to run the export compiled assembly. How to do it, thanks.

      Comment


        #4
        Sorry i don't understand. It will import into another PC no problem when it is protected no problem.

        -Brett
        BrettNinjaTrader Product Management

        Comment


          #5
          Hi
          Will not let me import it gives me error.
          thank

          Comment


            #6
            Hello,

            Can you please let me know what error you are getting on import.

            I look forward to assisting you further.
            BrettNinjaTrader Product Management

            Comment


              #7
              Import failed.The NinjaScript Archive File may contain duplicate method names that already exist on your PC or there is a required file missing on either your PC or in the import archive.
              Thanks,

              Comment


                #8
                Mariano,

                Please go to tools > edit ninjascript > select a random file.

                Then, please hit the compile button at the top of the screen. From here, please report any error messages generated.

                I look forward to helping you solve your issue.
                Adam P.NinjaTrader Customer Service

                Comment


                  #9
                  Does not fail, I can change what you want. thanks

                  Comment


                    #10
                    Mariano,

                    This means your NinjaTrader directories are in a compilable state so there is nothing wrong with your setup. It most likely means the indicator you are attempting to import either has programming errors in it or its for the wrong version of NinjaTrader. If you want me to check, please attach the indicator to a forum post and give me your version number. You can find this in Help > About.

                    Please let me know if I may assist further.
                    Adam P.NinjaTrader Customer Service

                    Comment


                      #11
                      Import from forum SimpleHighLowCross.zip
                      Then I used export compiled assembly / * Protect compiled assemblies, and then not let me import it to another PC.Thanks

                      Comment


                        #12
                        Mariano,

                        Do you perhaps have a direct link to this or have it available to send to [email protected]?
                        Last edited by NinjaTrader_AdamP; 12-02-2011, 04:10 PM.
                        Adam P.NinjaTrader Customer Service

                        Comment


                          #13
                          06.09.2007, 20:52
                          NinjaTrader_Josh
                          NinjaTrader Product Manager

                          Strategy: Trading crossovers
                          ...........
                          Import instructions:
                          Download the file contained in this thread to your PC desktop
                          From the Control Center window, select the menu File > Utilities > Import NinjaScript
                          Select the downloaded file
                          Attached Files
                          SampleHighLowCross.zip (1.2 KB, 1697 views

                          Comment


                            #14
                            If I have compiled exported in the first PC, then the second PC will not let me import it?

                            Comment


                              #15
                              Mariano,

                              What version of NinjaTrader is on the second PC?

                              The second PC could also have compiling errors from some indicators, you will need to check the PC you are trying to import the strategy onto for compiling errors, as the one you export from has no bearing on whether or not the second PC is in a compilable state.

                              You can check using Tools > Edit NinjaScript > Select a file > Hit compile > report any errors.
                              Adam P.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Janfor, Yesterday, 10:19 AM
                              1 response
                              9 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by Brian F, Yesterday, 10:00 AM
                              1 response
                              17 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by Perceivedshift, Yesterday, 05:17 AM
                              0 responses
                              22 views
                              0 likes
                              Last Post Perceivedshift  
                              Started by Ashley_Mogg, Yesterday, 12:31 AM
                              1 response
                              8 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by b16_aln, Yesterday, 03:11 AM
                              2 responses
                              340 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Working...
                              X