Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NtDirect;TradeStation charts not starting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NtDirect;TradeStation charts not starting

    I've been running NT for a while in sim mode to develop some code for a client. I'm using the external data feed from TS and coding in an ELD to send orders from a TS strategy to the NT platform. Since I started working on this I've noticed that my TS charts which use only regular day session would not start when the session started. I could get them to start by logging off and then back on. Today before the market opening, I shut down all the NT stuff and the charts started normally so I'm concluding that the problem is caused in some way by my use of the NtDirect dll.

    I would like to see if someone else can confirm this.

    Thanks.

    Tom

    #2
    Hello,

    To confirm exactly what NT strategies do you have running on the TS charts, are you using the NTExternalFeed strategy? Anything else?

    Would also be interested if you ran this test for Monday morning and had two charts up of the same symbol starting starting at the same time. Have only one with the NinjaTrader strategies applied. Does tradestation data not flow in on both charts or just one or none?

    I look forward to assisting you further.
    BrettNinjaTrader Product Management

    Comment


      #3
      Originally posted by NinjaTrader_Brett View Post
      Hello,

      To confirm exactly what NT strategies do you have running on the TS charts, are you using the NTExternalFeed strategy? Anything else?

      Would also be interested if you ran this test for Monday morning and had two charts up of the same symbol starting starting at the same time. Have only one with the NinjaTrader strategies applied. Does tradestation data not flow in on both charts or just one or none?

      I look forward to assisting you further.
      I am running the NTExternalFeed strategy. In addition, I am running a TS ELD which makes extensive use of many of the function calls available through NtDirect. The chart that I'm running the NT stuff on has no problem because it's a continuous symbol (@ES). The ones which are not starting are charts in other workspaces which use the symbol @ES.D or @ESxxx.D. Another chart which uses the symbol @ES, but with a custom session starting at 8:27 am rather than 8:30 am starts without problem. It's only the day session charts which are not starting, and it's all of them in every workspace.

      Comment


        #4
        Hello,

        I would not expect any interference on any TS charts that are not running the strategy.

        -Brett
        BrettNinjaTrader Product Management

        Comment


          #5
          Originally posted by NinjaTrader_Brett View Post
          Hello,

          I would not expect any interference on any TS charts that are not running the strategy.

          -Brett
          I wouldn't either, but it's beginning to look like this is the case. My trading computer only runs three apps. TS and NT plus Synergy, which allows me to use one mouse and keyboard with multiple computers. I've used the Synergy for years and not had this problem. Today the only thing that was different was that I shut down NT and the workspaces that were communicating with it. There has to be a connection. Any suggestions?

          tom

          Comment


            #6
            Tom, I will have Brett get back to you on Monday.
            AustinNinjaTrader Customer Service

            Comment


              #7
              Hello,

              Do you have another PC we could try this on by any chance? If not can you please post your exact tradestation workspace this occurs on so that I can try to duplicate it on my side.

              -Brett
              BrettNinjaTrader Product Management

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by glivv, Today, 09:17 AM
              0 responses
              5 views
              0 likes
              Last Post glivv
              by glivv
               
              Started by cmv727, Today, 08:48 AM
              0 responses
              6 views
              0 likes
              Last Post cmv727
              by cmv727
               
              Started by Kaiviti57, Today, 04:13 AM
              2 responses
              8 views
              0 likes
              Last Post bltdavid  
              Started by aslane, Today, 08:02 AM
              0 responses
              6 views
              0 likes
              Last Post aslane
              by aslane
               
              Started by DTSSTS, Today, 07:03 AM
              0 responses
              14 views
              0 likes
              Last Post DTSSTS
              by DTSSTS
               
              Working...
              X