• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Decimals in Stop/Target amts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Decimals in Stop/Target amts?

    The stop and target amounts that you set for an ATM strategy should be in ticks, right? Like if you want a stop to be 15 ticks, you enter "15"? Why is my DOM requiring me to enter stop and target in the decimal ticksize? See that attached screen shot of DOM. For the 6E instrument, I expect to type 15 for stop and 10 for target. Instead it's forcing 0.0015 and 0.0010. This causes the strategy that is using this ATM to calculate its limit orders for the stop and target incorrectly. See screen shot of error I get.

    I have done Reset Instruments, and also have deleted the NinjaTrader.sdf file so that it would create a new one. It is still not allowing integers for the stop and target -- even though a friend with NT7 can enter integer stop and target for the 6E on his DOM.

    Thanks!
    Bryan
    Attached Files
    Last edited by cassb; 12-02-2011, 08:30 PM.
    cassb
    NinjaTrader Ecosystem Vendor - Logical Forex

    #2
    Right-click and choose properties, check the Parameter type row and make sure it is set for ticks and not price. Sounds like that should take care of what you're seeing.

    VT

    Comment


      #3
      Originally posted by VTtrader View Post
      Right-click and choose properties, check the Parameter type row and make sure it is set for ticks and not price. Sounds like that should take care of what you're seeing.

      VT
      Hello cassb,

      VT is correct. Please let us know if this resolves your issue.

      Thank you VT!
      Ray S.NinjaTrader Customer Service

      Comment


        #4
        Originally posted by VTtrader View Post
        Right-click and choose properties, check the Parameter type row and make sure it is set for ticks and not price. Sounds like that should take care of what you're seeing.

        VT
        That did the trick, thank you! I don't use the DOM much, so such a simple thing didn't occur to me. :-)

        Bryan
        cassb
        NinjaTrader Ecosystem Vendor - Logical Forex

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by aslane, Today, 01:29 PM
        1 response
        8 views
        0 likes
        Last Post aslane
        by aslane
         
        Started by itrader46, Today, 01:09 PM
        0 responses
        5 views
        0 likes
        Last Post itrader46  
        Started by elnoppo, Today, 12:38 PM
        1 response
        6 views
        0 likes
        Last Post NinjaTrader_Kate  
        Started by TradingRocks, Today, 11:44 AM
        1 response
        10 views
        0 likes
        Last Post NinjaTrader_Jesse  
        Started by Brillo, Today, 11:39 AM
        2 responses
        11 views
        0 likes
        Last Post Brillo
        by Brillo
         
        Working...
        X