• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

IB TWS Issue NT connecting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IB TWS Issue NT connecting

    The issue I am having is that when I tried to login to my IB account via NT, the TWS opened, but NT never got the green connection status on the NT bottom left status bar.

    What prompted me to post this issue was that it seemed to work on another computer that had the latest TWS version on it, but I just got a new computer and installed NT and TWS latest versions on both.
    Thanks

    #2
    Hi designer,

    Thanks for your post.

    Which build of TWS are you running? To check, please click Help > About Trader Workstation.
    KyleNinjaTrader Customer Service

    Comment


      #3
      TWS Build 921

      Comment


        #4
        Hi designer,

        Thanks for getting back to me.

        Please shut down NinjaTrader and TWS, then install the 917.8 build with this direct link: http://www.ninjatrader.com/ninjatrad...tall_917_8.exe

        After installing this version, please restart NinjaTrader and attempt to connect to IB - is the connection successful?
        KyleNinjaTrader Customer Service

        Comment


          #5
          I installed the TWS version from your link but now I am not able to open TWS at all nor from NT nor alone...

          Comment


            #6
            Hello,

            Can you please try and older build of TWS on your PC.

            http://dl.dropbox.com/u/10361150/NT/...nstall_911.exe

            Please uninstall TWS and then install this version. Will it now login?

            I look forward to assisting you further.
            BrettNinjaTrader Product Management

            Comment


              #7
              To confirm I re-installed TWS v921 again and it opens OK....NT can not connect to TWS v921 still.
              I called Interactive Brokers and said that older versions of TWS do not work with Windows 7 properly any more. only windows XP.
              I need to have Ninja Trader and TWS work with Windows 7 ... My XP machine is old and not powerfull enough anymore.
              What shall we do?
              Thanks

              Comment


                #8
                On these PC's we have been using 911 with success.

                Please see my post below for the download link. Download that and let me know if you are able to connect.

                -Brett
                BrettNinjaTrader Product Management

                Comment


                  #9
                  Why can't I use the current TWS version?

                  Comment


                    #10
                    Hello designer,

                    When possible, we update our supported version of IB’s Traders Work Station at regular intervals with each new NinjaTrader release. Due to the number of releases IB has, we may be behind their current release, simply because we may not update our platform at the same time they do. It is also important to note that we can only begin testing new versions of TWS once those releases have been publicly made available, this also contributes to the time required to update the to the our supported version of TWS.
                    KyleNinjaTrader Customer Service

                    Comment


                      #11
                      I am not able to run IB TWS version 911 as shown in link of this thread below. I get this message

                      "The version of the application you are running, 911.3, is no longer supported.
                      Please download the current version from our web site "

                      Is there a newer version of TWS that Ninja Trader supports?
                      Thanks

                      Comment


                        #12
                        Hello,

                        The supported version of TWS for NinjaTrader is 917.

                        This can be downloaded from here: http://www.ninjatrader.com/Connectio...tion-Guide.php

                        Let me know if I can be of further assistance.
                        BrettNinjaTrader Product Management

                        Comment


                          #13
                          TWS 917 does not work at all.
                          Since a couple of weeks there was a IB message that support willl be stopped for older versions of TWS, so I installed the latest issue build 922.6. Then I can log in with TWS, however there is no connection with Ninja Trader possible. So I consulted this forum and on advice of Brett , I downloaded and installed version 917. But that version will not even log in. So reinstalled 922.6. With that version , log in is possible but no connection to Ninja. For back-up I use TradeStation. TradeStation works flawlessly with the latest TWS version. I hope Ninja will soon find a solution.

                          Jaap

                          Comment


                            #14
                            Hello,

                            In this case please send a note to support at ninjatrader dot com ATTN: Management in the subject line and I will send you an updated build.

                            -Brett
                            BrettNinjaTrader Product Management

                            Comment


                              #15
                              Hello Brett,

                              kindly escalate this issue to your management. I am a big fan and supporter of NinjaTrader. I do public appearances with it and talk very positive about your SW.

                              However as Jaap pointed out a big problem is coming your way. I get a message every time I log into my TWS (v 917.8) that it will not be supported from 24. 2. 2012. You had a long time since v 917.8 to fix the issue with TWS connection but obviously did not need to do it.

                              When version 917.8 will no longer be supported you will loose me after many years as well as number of other traders I believe.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by idleme125, Today, 02:15 AM
                              1 response
                              6 views
                              0 likes
                              Last Post NinjaTrader_Marco  
                              Started by junkone, Today, 02:42 AM
                              0 responses
                              4 views
                              0 likes
                              Last Post junkone
                              by junkone
                               
                              Started by pmfracer, Today, 01:45 AM
                              0 responses
                              5 views
                              0 likes
                              Last Post pmfracer  
                              Started by voltation, Today, 12:58 AM
                              1 response
                              10 views
                              0 likes
                              Last Post NinjaTrader_ChrisSch  
                              Started by RobertoPaez, Yesterday, 08:13 PM
                              1 response
                              15 views
                              0 likes
                              Last Post brucerobinson  
                              Working...
                              X