• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Diffeculty connecting to tradestation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TroyEarth
    started a topic Diffeculty connecting to tradestation

    Diffeculty connecting to tradestation

    Hi,

    I have a problem connecting to Tradestation this morning. It gives me the error message: IB.Adapter,Massage.Loop. An attempt to connect to failed due to the part that created the connection, didnt answer correctly after a periode, or an connection got cut off. I still use NT7 and i havent made any changes since yesterday and it worked fine there.


    Thanks in advance

  • TroyEarth
    replied
    Hi Jason,

    I changed the IP address on my stationary to 127.0.0.1 from local and that solved the issue. Is't strange as it worked untill today with local IP.

    thx for you help.

    Leave a comment:


  • NinjaTrader_Jason
    replied
    Hello TroyEarth,

    Please note that TWS 917 is not the latest version. Can you please check your TWS version and make sure the TWS API options are setup properly as well.

    You can find the IB connection guide at the link below.
    http://www.ninjatrader.com/Connectio...tion-Guide.php

    Leave a comment:


  • TroyEarth
    replied
    Hi Kyle,

    Anymore suggestions please. I have updated the TWS to latest version and I am running NT7. It is still not connecting.


    Thanks

    Leave a comment:


  • TroyEarth
    replied
    Hi Kyle,

    Done the updating to 917.8 build, unfortunately the same error message pops up.

    thanks.

    Leave a comment:


  • NinjaTrader_Kyle
    replied
    Hi TroyEarth,

    Thanks for getting back to me.

    With the current release of NinjaTrader, it is critical that the 917.8 build of TWS be used. Please shut down NinjaTrader and TWS, then install the 917.8 build via this link: http://www.ninjatrader.com/ninjatrad...tall_917_8.exe

    After installing the 917.8 build of TWS, please restart NinjaTrader and TWS and try the connection again.

    Leave a comment:


  • TroyEarth
    replied
    Hi Kyle,

    You are absolutely right it is the Interactive brokers, sorry for this.

    Build 918.8, Jun 29, 2011 4:25:40 PM Jolt Build 1.1.10, Apr 19, 2011 02:52:18 PM Nia Build 1.8.1, Apr 20, 2011 05:27:43 PM ModelNav Build 1.1.32, Mar 30, 2011 04:02:07 PM

    Thanks a lot.

    Leave a comment:


  • NinjaTrader_Kyle
    replied
    Hi TroyEarth,

    Thanks for your post.

    Just to clarify, you're connecting to TradeStation or to Interactive Brokers' Trader Workstation?

    It sounds like you are likely using the Interactive Brokers connection. If that is the case, which build of TWS do you use? To check, please click Help > About Trader Workstation within the TWS software itself.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by digibob, Today, 03:00 PM
0 responses
1 view
0 likes
Last Post digibob
by digibob
 
Started by yeshujbp, Today, 02:50 PM
0 responses
2 views
0 likes
Last Post yeshujbp  
Started by tonynt, Today, 12:39 PM
0 responses
11 views
0 likes
Last Post tonynt
by tonynt
 
Started by Martyb, 06-13-2019, 05:14 AM
10 responses
78 views
0 likes
Last Post iq200
by iq200
 
Started by Erwin Beckers, 11-04-2018, 02:39 AM
4 responses
71 views
2 likes
Last Post brucerobinson  
Working...
X