Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

editing/removing bad ticks/data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    editing/removing bad ticks/data

    In the past when Ninja would crash it often left behind bogus data . But lately when I start Ninja in the morning it is happening with greater frequency:
    Click image for larger version

Name:	candleproblem.gif
Views:	1
Size:	24.3 KB
ID:	890155Click image for larger version

Name:	candleproblem2.gif
Views:	1
Size:	24.1 KB
ID:	890156Click image for larger version

Name:	candleproblem3.gif
Views:	1
Size:	18.4 KB
ID:	890157 -bogus data is generated scrunching all my candles into a tiny row of dots and throwing off all my level based indicators. Also bogus volume data is generated showing perhaps 170,000 contracts on one 2 minute candle which also scrunches the rest of the volume into illegible hash.I have tried reloading the data from zen-fire and the default historical data feed but I can't get rid of it. Also notice that for the same contract the spike is different sizes for each screen. Occasionally one of my multiple windows will have unaffected data but if I change the time frame it corrupts. It is impossible afaik to zoom in past the offender because the screen must show all vertical data. This really throws off my game for the day. Any way to quickly right the data before the market open? or a slow laborious fix in the off hours that will last?
    Thanks in advance for help and suggestions!
    Cheers,
    Taters

    #2
    Unfortunately there is no data editing available at this time. Please try Tools->Historical data->Reload. If issue persists, then data was submitted incorrectly by the exchange.

    Comment


      #3
      I would try reloading the data via Tools > Historical Data > Reload since the bad tick you speak of does not exist in the Zen-Fire historical data dabase. I just loaded the last 15 days and all looks as I would expect.
      RayNinjaTrader Customer Service

      Comment


        #4
        It's happening again

        I have been having the "bad tick" issue again lately, I think something is corrupted in a Ninja database some where ( just a guess).It occurs when I quit Ninja and reopen it on the same day. Reloading the data does not help. If I create a new chart it still shows the bogus data. Oddly, if I create a chart that does not include the current day''s data the problem shows up on any chart's last candle.I made a chart that loaded dated only 'til 2/6 ( today is the 9th.) It's Still there.My broker swears its not them, and the experiment I just outlined seems to underscore their point. Also, I use multiple charts (1/2 hr 5 & 1 minute. Some times one chart will not have the bad data but if I switch time frames on that chart it gets "infected" and even going back to the original TF will not solve the problem.The only answer is to "come back tomorrow" and it's usually ok, but why? Does Ninja redo the data after Midnight or something? Like many issues I have w Ninja, this one is extremely intermittent but comes in bunches and is hard to repeat.
        I think that either being able to edit the candle should be a major priority in the next major release, or to be able to unlock the vertical scroll to allow the candle to go off screen.
        Thanks for your help,
        Taters

        today's data:Click image for larger version

Name:	candletrouble.gif
Views:	1
Size:	21.7 KB
ID:	848586

        data loaded to end yesterday:Click image for larger version

Name:	candletrouble2.gif
Views:	1
Size:	22.3 KB
ID:	848587
        Last edited by Taters; 02-08-2008, 12:27 PM.

        Comment


          #5
          Please proceed as per Ray's below right below. If issue still is there than the data coming from the provider is corrupted in which case you could need to contact the provider.

          We have the data editing feature on our list of potentials future enhancements yet. Thanks for suggestion though.

          Comment


            #6
            I have tried Ray's suggestion...

            it does not work. As Ray said above, he took the time to check the ZenFire data and it looked good. I don't understand how it is the fault of the data provider if loading historically good data only until a past date shows 1000 point candles on any charts last candle, ie the data is good, only until I load it. I hope I am making myself understood.

            Comment


              #7
              Please double check that
              - you have set the timezone of your PC clock to the timezone you actually life in
              - you do not change the PC lock time to e.g. set it to an exchange time

              Comment


                #8
                it is plain old Eastern Standard Time.

                Is there a way to dump all the historical data before I reload it?

                Comment


                  #9
                  In NT6.5 there is Tools->Historical data->Delete

                  Comment


                    #10
                    a better example of the problem

                    these pics may explain the problem better than my words:

                    restarted NT, created fresh YM chart @ 2:18
                    bad candle
                    Click image for larger version

Name:	candletrouble3.gif
Views:	1
Size:	23.2 KB
ID:	848588

                    closed NT

                    restarted NT @ 2:33
                    bad candle is now ok, but the 2:33 candle is bad.
                    Click image for larger version

Name:	candletrouble4.gif
Views:	1
Size:	23.7 KB
ID:	848589

                    weird daily chart: note how the candle high/low are drawn to exactly fill the fib high/low. At least the chart remains legible in this case.
                    Click image for larger version

Name:	candletrouble5.gif
Views:	1
Size:	62.5 KB
ID:	848590

                    I will try dumping the historical data but I dont think it is the problem.

                    Comment


                      #11
                      Please provide feedback as per my post #7. Thanks

                      Comment


                        #12
                        See subject of my post #8

                        sorry- I answered in the subject line.
                        All my clocks are set normally as per your post. I think this is a drawing issue somehow, not a data issue. a clue may be in the third picture
                        of my previous post (Attachment #1726)...

                        Comment


                          #13
                          Sorry, I would not know what causes this nor do we have any similar reports. I'm out of ideas.

                          Comment


                            #14
                            Thanks for your time-

                            I will just have to keep digging...
                            If I figure it out I will post.
                            -T

                            Comment


                              #15
                              That would be great

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by WalterSkinner, 02-07-2022, 09:22 AM
                              27 responses
                              126 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by c4vito, 06-03-2021, 01:11 AM
                              6 responses
                              103 views
                              0 likes
                              Last Post hellboy78  
                              Started by trdninstyle, Yesterday, 09:32 AM
                              29 responses
                              173 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by antcoster, Today, 11:26 AM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_Oxana  
                              Started by TonyRovere, 12-13-2021, 09:36 AM
                              5 responses
                              611 views
                              0 likes
                              Last Post culpepper  
                              Working...
                              X