• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

DOM holds old contract

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    DOM holds old contract

    Around contract rollover, I get one or 2 instruments held over in the DOM, even though they are not in the instrument manager. What is it that I'm doing to create this issue?

    #2
    Hello,

    This can be caused if you select 'Set Default' from the SuperDOM properties with the earlier contracted selected.

    To resolve this, please select an active instrument and expiry (ES 03-12 for example) and then right click on the SuperDOM--> Select Properties--> Select "Set Default". Then restart your SuperDOM

    Please let me know if you need further assistance.
    MatthewNinjaTrader Product Management

    Comment


      #3
      Thanks, Matt, so if I've got this right, the current ES 03/12 will be held over at rollover at the end of Mar? Or are you saying I've set the default with an expired contract in place on the DOM?
      Sorry I don't click "Set Default" very often and can't remember the last time I did this.
      Thanks for your help

      Comment


        #4
        Yes, it will be held over the next roll over unfortunately and you will need to reselect the current contract at that time and hit set default again.

        Development is aware of this limitation and is looking into improving this in a future release.
        MatthewNinjaTrader Product Management

        Comment


          #5
          DUH I finally got it through my thick skull, thanks a bunch !!

          Comment


            #6
            DOM holding on to M6E 12-11 contract

            Its been a month past and I can't get rid of the M6E 12-11 contract in the DOM, its driving me nuts!! I've tried going to instrument mgr and removing all the intruments and reloading them with current ones(ES 3-12 & M6E 3-12), but then when I reopen the DOM the old M6E contract is still there. Setting default does not help.

            ........frustrated

            Comment


              #7
              What contract do you have selected when you hit "Set Default"? Are you opening a new DOM after doing so?
              MatthewNinjaTrader Product Management

              Comment


                #8
                Fixed !

                Ok, I just fixed it, I reset the DOM then I made sure to set default to the current contract, thnx for your response

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by ntbone, Yesterday, 09:54 PM
                0 responses
                7 views
                0 likes
                Last Post ntbone
                by ntbone
                 
                Started by rwilliam, Yesterday, 03:14 PM
                0 responses
                8 views
                0 likes
                Last Post rwilliam  
                Started by rwilliam, Yesterday, 03:10 PM
                1 response
                7 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by rontronimous, Yesterday, 03:04 PM
                2 responses
                12 views
                0 likes
                Last Post rontronimous  
                Started by zacharydw00, Yesterday, 03:14 PM
                0 responses
                9 views
                0 likes
                Last Post zacharydw00  
                Working...
                X