Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Problem updating chart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem updating chart

    Hello, I had a problem for all over the morning(Spain time) and I have just solved it, but I don't know what was wrong and I wouldn't like that it happen to me again.

    As usual I went to File > New Chart and open the graphs for the ES and CAC40, but when I was trying to do the same for the Mini Russell 2000 (TF) the chart I could see finished 9/01/2012 and not 10/01/2012.

    The thing is that when I was trying to open this graph it was taking so many time loading that I closed it and abort it and tried to do it again. Then it opened quickly but with this error, it skipped yesterday. I tried to do it over and over again but with the same result.However in the control center I could see the data for the TF although it was not time for the session yet
    I had to wait till the session for the TF started,then I tried to open it and it was ok


    a) Which datafeed/broker connection are you connected to? Also, in which connection sequence (i.e. I connect to Kinetick and then IB)?
    IB. Then I tried IB and Kinetick with the same result

    b) Do you receive any data for the instrument in the Control Center or SuperDOM?
    Yes
    c) Which instrument are you attempting to receive data for?
    TF MiniRussell 2000
    d) Can you re-produce this behavior? Could you please provide exact steps.
    e) What happens when you close your chart and open a New Chart under File > New > Chart?
    Explained above
    Same thing as explained above
    f) Have you installed any 3rd Party NinjaTrader indicators/strategies? If yes, please specify which ones and of which version (if possible).
    No

    Thanks

    Daniel

    #2
    Hello,

    Thanks for the detailed report.

    What type of chart was this? Daily/Minute

    What session template was applied to the chart? Right click->Data Series->Session template.

    -Brett
    BrettNinjaTrader Product Management

    Comment


      #3
      It is a 15 minute chart.

      The session template was one made from me that goes from the beginning of the session 15:30 till 22:00 from Monday to Friday (Spanish time)

      Thanks

      Daniel

      Comment


        #4
        Hello,

        I suspect possibly something going on pug or incorrect settings in the session template.

        Can you please create a new chart of this same chart instead use the Default 24/7 session template on it. Keep this chart open and in the background during your operations. If this was to ever happen again in the future I would be interested to know if this chart with the Default 24/7 session template has the same problem or not.

        Finally, make sure you are on all the right versions.

        Please check your version of NinjaTrader and insure you are running version 7.0.1000.8, please check this by going to Control Center->Help->About...

        If you are running an older version of NinjaTrader please download the latest version of NinjaTrader Here:

        http://www.ninjatrader.com/download-registration.php

        Make sure to close NinjaTrader before you install the updated version of NinjaTrader, all of your settings will be maintained. Let me know if you needed to upgrade.
        BrettNinjaTrader Product Management

        Comment


          #5
          I am running an older version of NinjaTrader, 7.0.1000.6
          So I guess that could be the problem.

          Can you tell me the steps to upgrade so all of your settings will be maintained??
          Although I have some stretegies running now and I couldn't do it till night

          Thanks

          Comment


            #6
            A simple over the top installation will do the upgrade for you.

            -Brett
            BrettNinjaTrader Product Management

            Comment


              #7
              Same problem

              Hello,

              I had today exactly the same problem I explained in the first post of this thread, so I guess that time was not only a problem of updating NT and there is something else.

              I had to wait till the session started and then open the chart so it loaded correctly.

              What can I do? I can't be everyday in front of the computer for doing this due to work...

              Thanks

              Daniel

              Comment


                #8
                Daniel,

                In this case please go to help->mail to support in the NInjaTrader control center and send me your log and traces for today. Reference this forum post so I can look into it further.

                I look forward to assisting you further.
                BrettNinjaTrader Product Management

                Comment


                  #9
                  I have just mail it to you.

                  Thanks

                  Comment


                    #10
                    Hello,

                    I got the same problem last Monday and today. I have to wait now till the market opens...
                    I don't think it is a problem of RAM, I checked the RAM usage and it is good (though te attached picture is not my virtual desktop, I followed the steps to check my RAM usage).

                    I don't think the problem is the third party indicator either. I am not using this indicator with any of my strategies yet

                    It must be something related to the instrument, it always happens with the Mini Russell 2000 (TF)

                    Any idea?

                    Thanks

                    Daniel

                    Comment


                      #11
                      Hello,

                      Only thing that would be different is the session template in use on the TF.

                      Can you please try using the same session template as for example the ES just as a test would be the next idea I have.

                      -Brett
                      BrettNinjaTrader Product Management

                      Comment


                        #12
                        Error Massage

                        Date;Category;Message;
                        25-01-2012 17:00:34;Default;Failed to call method 'Initialize' for indicator 'StatusBox': 'TickSize' property can't be accessed from within 'Initialize' method;


                        I have this massage after add my script on chart. Could you please tell me what's going wrong

                        Ty

                        Comment


                          #13
                          Hello,

                          This means there is a coding problem on TickSize being used inside of Initialize(). This needs to be removed from the script in NinjaTrader 7.

                          -Brett
                          BrettNinjaTrader Product Management

                          Comment


                            #14
                            Hi Brett,

                            The session template is exactly the same for both the ES and t he TF...

                            :-(

                            Comment


                              #15
                              Error Massage

                              Originally posted by NinjaTrader_Brett View Post
                              Hello,

                              This means there is a coding problem on TickSize being used inside of Initialize(). This needs to be removed from the script in NinjaTrader 7.

                              -Brett
                              Can you please tell me what to do. I don't have any "TickSize" word on all script, so I don't know what have to be removed.

                              Ty

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by neoikon, Today, 05:47 PM
                              0 responses
                              1 view
                              0 likes
                              Last Post neoikon
                              by neoikon
                               
                              Started by wjadevries, Today, 03:35 PM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Started by Mykro, Today, 03:59 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post Mykro
                              by Mykro
                               
                              Started by venkateshdvk, Today, 01:34 PM
                              1 response
                              24 views
                              0 likes
                              Last Post NinjaTrader_Kate  
                              Started by westofpluto, Today, 01:54 PM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Working...
                              X