• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Different walkforward results

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Yes, if installing the new version does not make a difference, please remove your historical data and load it anew from one data feed.

    You can delete historical data at Control Center-->Tools-->Historical Data Manager-->Edit. Instructions can be found at the link below.
    http://www.ninjatrader.com/support/h...t7/editing.htm

    Close NinjaTrader and delete the following folder: (My) Documents-->NinjaTrader 7-->db-->cache

    Check if the issue persists now that new data will be used.
    JasonNinjaTrader Customer Service

    Comment


      #17
      I did exactly as you suggested but the problem is still there.
      Next I also deleted .sdf file in db folder but nothing has changed.
      Do you have any ideas what shall I do more?

      Comment


        #18
        Can you please select the Optimizer-tab and then the Instruments-tab. Select a different sub-tab.

        Select the Walk forward-tab again and subsequently the Chart sub-tab. Does it still list the trades at 1/15 and 1/16?

        Upon testing again, I see this first trade after I finished the walk forward test. However if I switch around in tabs, the first trade will be gone. I will report it to development to further troubleshoot the issue.
        JasonNinjaTrader Customer Service

        Comment


          #19
          Jason,

          Yes, I have it too. I do walkforward test, then I am clicking around instruments and optimizer tabs and sub-tabs. Following that I click into walkforward tab and I get correct chart and trades list (without first two trades).
          Please note that the result in walkforward tab is still wrong - there is 41 trades where it is 39 in fact.

          Please report that to your development. I will be waiting for feedback regarding this issue..

          Comment


            #20
            Thank you for reporting. It is on our list to fix the issue in a future version.

            We recommend to use more realistic settings to check walk forward tests. So use minute data instead of daily data when using an optimization period of only 2 days.
            JasonNinjaTrader Customer Service

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Started by claxxical, Today, 10:00 PM
            0 responses
            5 views
            0 likes
            Last Post claxxical  
            Started by ct, Today, 08:13 PM
            0 responses
            6 views
            0 likes
            Last Post ct
            by ct
             
            Started by Lumbeezl, Today, 05:17 PM
            0 responses
            6 views
            0 likes
            Last Post Lumbeezl  
            Started by wishing, Today, 03:33 PM
            0 responses
            10 views
            0 likes
            Last Post wishing
            by wishing
             
            Started by ATMtrader0001, Today, 01:48 PM
            1 response
            8 views
            0 likes
            Last Post NinjaTrader_PaulH  
            Working...
            X