• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT not working correctly with eSignal data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NT not working correctly with eSignal data

    There are several problems here:
    1. NT still doesn't support eSignal on the 64-bit version of NT7
    2. NT refuses to connect to CL #F=1, GC #F=1, or any symbol with =1 in the map
    3. NT is charting incorrect price data - see attached screen shot

    How can we trust NT charting with problems like this? All 3 need to be fixed.

    Attached is a screenshot of Soybeans (ZS) March, May, and November contracts. They should NOT all have exactly the same price data! This is NOT an eSignal problem -- I use the exact same eSignal feed into Multicharts, and they are charting correctly.

    I can't believe y'all claim eSignal is a partner. It seems obvious that NT does not want to support eSignal as a data feed.
    Attached Files

    #2
    Hello,

    Thanks for the forum post.

    I will answer your concerns below:

    1) This is currently on development list to look into adding into NinjaTrader. I do not have a release date on when this support would be added however adding 64 bit support for providers is on developments list to finish looking into.

    2) This is a current limitation with ninjaTraders eSignal adapter. Development is aware of it and may look to make a change in a future major release of NinjaTrader.

    3) This occurs as you most likely are using the auto merge feature in NinjaTrader. You cannot use the auto merge feature on contracts that are not the current contract as you are merging in the same historical data.

    Please go to control center->tools->options->data tab to set the auto merge policy to DoNotMerge.

    This setting is required if you plan to look at expires that are not the current expiry and needed the data from that expiry only and not auto merged.

    -Brett
    BrettNinjaTrader Product Management

    Comment


      #3
      Thank you for your reply, Brett.

      Correcting the default to DoNotMerge fixed one chart. The others had to be forcibly reloaded, which takes a while when it starts with 1991.

      [EDIT} - Removed non constructive comments.
      Last edited by NinjaTrader_Brett; 02-17-2012, 09:24 AM.

      Comment


        #4
        Thanks for the feedback. I have sent it into development and thanks for letting me know the auto merge worked. Yes you would need to do a reload for that setting to take effect.

        -Brett
        BrettNinjaTrader Product Management

        Comment


          #5
          eSignal FX data Feed

          Brett,

          Hey Lost Trader, hope you don't mind me joining in but after reading your eSignal issue it prompted me to write about mine. It's not exactly the same as yours but it does have the common thread of NT / eSignal issues.

          My issue is having the session times (plot session break line) display correctly on the chart and ensure the price bars have the correct date on the daily chart. I have researched this forum and found some information which was enlightening, but not really an answer.

          ================================================== ==============
          First off, what are the correct settings for the forex session template within the session manager, when using the forex data feed from eSignal?
          ================================================== ==============

          I'm surprised this is not given as part of the connection settings help text / video because changes made to the session template effect the quality of the price bars on the chart. By quality I mean displaying the correct dates for daily price bars and ensuring all daily price bars for the trading week are displayed.

          It appears time is my enemy!

          I am using eSignal charting to compare with NT charting. My eSignal time zone (time displayed on the chart) is GMT and the clocksetting (a small digital clock, displayed bottom right of the application) is GMT+10. This is all within eSignal's application properties dialogue box.

          My Win 7 computer time is also GMT+10 (Melbourne, Victoria). I am using Ninja Trader 7.0.1000.9

          I look forward to resolving this issue as part of my evaluation to move from eSignal to Ninja Trader.

          Comment


            #6
            Hello,

            Thanks for the forum post.

            Yes this is a fact, you must use the correct session template for the data you are viewing. If you use one that is not correct it can cause issues with the correct data being displayed.

            You may specifically have issue with this as I see you are in Australia. Are you charting US stocks or Eurex data by any chance.

            In which case here is what occurs->

            NinjaTrader MUST have all times in the chart be your local PC time.

            NinjaTrader according to the session template applies an offset to the time stamped data from eSignal to display data in your NATIVE time zone.

            This most likely for you is next day since your in Australia.

            This is 'technically' correct since the time zone is in your native time zone. However if you preferred that this did not occur there are a few solutions. You can change the time zone on the session templates so the offset does not occur that you use or change the time zone the PC resides in so your PC clock is reporting NY or chicago time. Which solution would you prefer and I will send steps.

            -Brett
            BrettNinjaTrader Product Management

            Comment


              #7
              I would like the time on the charts to display as GMT.

              I do not want any changes or dependencies on my system clock.

              Comment


                #8
                Hello,

                Currently, the PC's clock must use GMT as it's time setting for charts to display in GMT. A change here is something development is considering in the future, but this is the only way to accomplish the change currently.
                KyleNinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by Oracletrades, Yesterday, 02:56 AM
                1 response
                9 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by Bbrandon5567, Today, 04:56 PM
                1 response
                5 views
                0 likes
                Last Post Bbrandon5567  
                Started by NeverDownMoney, Today, 11:05 AM
                1 response
                8 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Started by NeverDownMoney, Today, 12:19 PM
                1 response
                7 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Started by pstrusi, Today, 04:30 PM
                1 response
                4 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Working...
                X