• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Level II data from IB (working for futures but not equities?)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Level II data from IB (working for futures but not equities?)

    Hello, I have a problem with accessing the Level II data for equities coming from my IB connection. I've found a similar thread from some time ago, and maybe there's a worked solution for my problem:

    http://www.ninjatrader.com/support/f...ad.php?t=29623

    Details:
    - I am using NT 7.0.1000.9
    - I am able to access Level II data for futures and equities on TWS with no problem... I see the MM IDs etc.
    - My NT's IB connection is working; I have access to Level I data for both futures and equities, but I can access Level II data for futures only.

    How can I fix this? Is this a NT technical issue or a IB subscription issue (do I need a special IB subscription for Level II equities on NT?)

    #2
    Hello,

    Can you please clarify what symbols you are loading? What exchange do they trade on?

    Do you have this exchange selected from the Instrument Editor?

    Some instruments will need extra configuration to work correctly from IB/TWS. You will first need to look up the exchange that is being reported from TWS and manually input this information into NinjaTrader.

    Please see the following forum post which covers this topic in detail:


    http://www.ninjatrader.com/support/f...ad.php?t=45833
    MatthewNinjaTrader Product Management

    Comment


      #3
      Hi... I took a look at your suggestion but those settings are already correct for my instruments. The same problem occurs for all of my symbols. For instance, I have AAPL from installation defaults - "Default" and "Nasdaq" are checked as the exchanges, and I am receiving Level I data with no problem. It's just that there's no activity on the order book when I open the Level II window (the L2 data's not coming through).

      I also have GLD and DBP set up properly by myself - only "Arca" is checked as the exchange, my NT can access L1 but not L2 data, while my TWS has no problem receiving both L1 and L2.

      On the other hand, I have ES 09-12 using default settings and my NT is retrieving the L2 data from my IB account properly - I can see the order book activity.

      Does this information help? Thanks in advance!

      Comment


        #4
        When you added AAPL to your default instrument list, did you have "Default" or "Nasdaq" selected from the Instrument Manager? I'm not referring to the Instrument Editor where you can check these exchange - I mean that exchange that was selected when you added it to your default list using the "<" button.

        In order for us to display L2 data from IB, we need to make sure the right exchange is selected.

        If you're unsure, you can also check this from the chart from the instrument drop down menu. You should see it say either AAPL Default or AAPL NASDAQ.

        We want to ensure NASDAQ is that selected instrument in the list, then added to the Level II window.
        MatthewNinjaTrader Product Management

        Comment


          #5
          ^Hi, just checked this out today and noticed that I had "Default" selected for AAPL. I tried switching it to "Nasdaq" and I get an error message about the instrument being unrecognized when I try to load the chart, so I can't even get L1 data using "Nasdaq" as the exchange.

          To try this out with other equities, I had QID, DBP and GLD set up with "Arca" as the only exchange, and as such I selected "Arca" when I added it to my default list using the "<" button. I had no problems loading the chart for these 3, but no L2 data is showing up for them.

          What should be my next step? Thanks for the prompt responses!

          Comment


            #6
            I'm "bumping" this up, still looking for a solution. Thanks!

            Comment


              #7
              Hello,

              If you're sure you have the instruments configured and set the the same exchange, this would indicate that your account does not have complete Level II for these equities to be sent to NinjaTrader. You will received limited market depth information on a basic subscription. In order for me to tell you for sure if you can expect to get Level II with your current subscription, I will need to test your account on my end.

              To do this, please email support[at]ninjatrader[dot].com with Attn: Matthew in the subject line and a reference to this thread.
              MatthewNinjaTrader Product Management

              Comment


                #8
                I've sent you the email. Thanks very much and I hope to hear from you soon!

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by daya123, Today, 09:16 PM
                0 responses
                2 views
                0 likes
                Last Post daya123
                by daya123
                 
                Started by Wingo, Today, 04:52 PM
                1 response
                9 views
                0 likes
                Last Post bltdavid  
                Started by Bionian, Today, 10:10 AM
                3 responses
                20 views
                0 likes
                Last Post Bionian
                by Bionian
                 
                Started by D Trader, Today, 01:41 PM
                0 responses
                13 views
                0 likes
                Last Post D Trader  
                Started by rexmie888, Today, 04:00 AM
                1 response
                10 views
                0 likes
                Last Post NinjaTrader_ShawnB  
                Working...
                X