Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Acct # not appearing in list

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Acct # not appearing in list

    Hi,

    I'm taking the next step and starting to test my strategy with live data and live paper trading account broker connection. The broker is IB. Previously, I used Ninja for charting only with an old IB acct, which number still appears in the account list in the strategy parameters.

    However, the current paper acct number does not appear on the list. I tried restarting NT, but no change. What do I need to do to get new acct number to show. I'd also like to get rid of the old numbers too.

    Thanks.

    EDIT: In account groups, the new acct # does not appear. Also, TWS keeps quitting and restarting.
    Last edited by coolmoss; 03-16-2012, 10:02 AM.

    #2
    Hi coolmoss,

    NinjaTrader loads the account drop down list according to what accounts are available with the connection you're on. You could also checks accounts tab of control center for this information.

    You should see consistency with the accounts available in the TWS instance and those you can see in NinjaTrader. Are you seeing something different? What version of TWS are you running? Check using their Help > About TraderWorkStation menu.
    Last edited by NinjaTrader_RyanM1; 03-16-2012, 10:16 AM.
    Ryan M.NinjaTrader Customer Service

    Comment


      #3
      Hi Ryan,

      I only have one TWS open, with acct# DU10001 (not real # )

      In the NT control center, the only acct that shows is sim101. In the strategy drop down list of accounts, all kinds of old numbers from a previous account show up, but not DU10001.

      Also, on the Log tab, it says Verifying license at primary server, then the next line up is IB: Primary connection=Connecting, Price feed=connecting.

      After a minute or two, TWS shuts itself down (or NT is causing it, don't know), then restarts itself, then shuts down again.

      Comment


        #4
        What version of TWS are you running?
        Ryan M.NinjaTrader Customer Service

        Comment


          #5
          Sorry, forgot to say: 923, very latest version, just updated now and tried again, no luck.

          Comment


            #6
            The current supported version of TWS is 921.5. It's available from the link below:
            http://www.ninjatrader.com/Connectio...tion-Guide.php

            Uninstall the one you're using now, and then install 921.5 from that link. That should help with connectivity and account access. Let us know if you're still not seeing it.
            Ryan M.NinjaTrader Customer Service

            Comment


              #7
              Sorry, still no go. I think the problem is it's just not connecting at all. It's in a perpetual state of "connectING".

              I am getting time outs in the log.

              Comment


                #8
                I tried renaming the db .sdf file (per instructions in another thread). The old acct #'s are gone. But, I still can't connect to IB. Just for heck of it, I fired up 6.5, tried to connect to IB using my @sim license (which I was able to do for eons) and that won't connect either.

                I'd really like to get this resolved today so I can get back to work on the strategy on Monday. Please let me know how to expedite this. Happy to do any testing directed to. THanks much!

                Comment


                  #9
                  Sorry, I'm not sure. It should work provided all connection setup is followed correctly. I'm happy to take a look at your setup over remote assistance. Please send a note to support 'at' ninjatrader 'dot' com, include your phone number, availability (with time zone), and a link to this thread.
                  Ryan M.NinjaTrader Customer Service

                  Comment


                    #10
                    Before you do a login, here is one more puzzle piece:

                    I just uninstalled TWS. I also then manually deleted the JTS folder, so everything is really clean. Then reinstaslled. I also manually started TWS to make sure it ran.

                    Then I started NT7, tried to connect to IB, and I get a message box saying that IB login failed due to jts\jts.ini does not exist.

                    Comment


                      #11
                      Okay,

                      I just installed NT7 .9 and got this message...

                      Click image for larger version

Name:	message.png
Views:	1
Size:	6.2 KB
ID:	864963

                      Comment


                        #12
                        Finally got it to connect. After having gone through all the other hoops, on this last fresh TWS install the great trading genius forgot to configure API settings in TWS.

                        Sorry for all the traffic here on this. I really don't know what the issue was, but it seems okay now.

                        Thanks much as always!

                        Comment


                          #13
                          Great that you got it sorted out. Thanks for updating us here!
                          Ryan M.NinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by Tradarr, Yesterday, 06:23 PM
                          2 responses
                          48 views
                          0 likes
                          Last Post -=Edge=-  
                          Started by trader3000a, Today, 01:33 PM
                          1 response
                          15 views
                          0 likes
                          Last Post NinjaTrader_ChrisL  
                          Started by Behungr101, Today, 01:35 PM
                          4 responses
                          21 views
                          0 likes
                          Last Post Behungr101  
                          Started by babouin77, Today, 12:27 PM
                          12 responses
                          64 views
                          0 likes
                          Last Post babouin77  
                          Started by ezrollin, Today, 11:20 AM
                          6 responses
                          27 views
                          0 likes
                          Last Post NinjaTrader_ChelseaB  
                          Working...
                          X