Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Problem with Uploading FTSE Sector Indexes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with Uploading FTSE Sector Indexes

    Hi,

    I am trying to upload a number of FTSE 350 sector indexes.

    For instance:

    FTSE 350 TOBACCO (^NMX3780)
    http://uk.finance.yahoo.com/q?s=%5ENMX3780&ql=1

    FTSE 350 - TECHHARD (^NMX9570)
    http://uk.finance.yahoo.com/q?s=%5Enmx9570&ql=1

    FTSE 350 REIS (NMX8630.L)
    http://uk.finance.yahoo.com/q?s=NMX8630.l&ql=1

    Of the 30+ sector indexes, Ninjatrader will only recognize one and that it is FTSE 350 REIS (NMX8630.L). The rest of the symbols for the sector indexes begin with ^ and don't have .L at the end.

    For the NMX8630.L symbol NT can show the chart and can run backtests. For the rest of them it can't.

    I presume this has something to do with the symbols having ^ at the start instead of .L at the end.

    Anyone got any ideas how NT can connect to these symbols?

    Thanks for your time.

    All replies are appreciated.

    #2
    Hello,

    I was able to get these loaded by using the exact symbol that Yahoo! is using.

    For example, the FTSE 350 - TECHHARD is added with:
    Master Instrument: (user defined name) FTSE350TECH
    Instrument Type: Index
    Tick Size: 0.01
    Session Template: Default 24/7
    Symbol Map: Yahoo: ^NMX9570
    Exchange: Default

    Please let me know if you are unable to get this charted with these settings in a Daily interval.
    MatthewNinjaTrader Product Management

    Comment


      #3
      I have been trying to import the indices as a list through the "Import Stock Symbol List" utility.

      Where do I go to add the index in the way you described?

      Thanks.

      Comment


        #4
        Hello,

        Due to the custom "^" symbol, you will not be able to use the import list wizard and will have to add these manually.

        Please follow the instructions below to add an instrument in the Instrument Manager.
        • From the NinjaTrader Control Center window select the menu Tools > Instrument Manager
        • Press the "New" button
        • *Enter in instrument specific information and select the appropriate exchange (add Default exchange for equities in addition to the actual exchange)
        • Fill in any relevant information under the "Misc" tab such as symbol mapping for your target connectivity provider
        • Press the "OK" button
        MatthewNinjaTrader Product Management

        Comment


          #5
          I see. That is where I will have been going wrong then.

          Thanks everyone.

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by nandhumca, Today, 08:47 PM
          0 responses
          6 views
          0 likes
          Last Post nandhumca  
          Started by BullyWig Trader, Today, 07:15 PM
          0 responses
          5 views
          0 likes
          Last Post BullyWig Trader  
          Started by ezrollin, Today, 05:13 PM
          1 response
          13 views
          0 likes
          Last Post ezrollin  
          Started by ineuron, Today, 04:29 PM
          0 responses
          8 views
          0 likes
          Last Post ineuron
          by ineuron
           
          Started by topa11, Today, 04:21 PM
          0 responses
          17 views
          0 likes
          Last Post topa11
          by topa11
           
          Working...
          X