Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Why NT is downloading for previous contract (ES) Tick Data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why NT is downloading for previous contract (ES) Tick Data

    Hi,

    I wanted to download the tick data for ES 12-12 contract from 1 Jun 12 to 30 Jun 12 using the historical data manager.

    When started downloading the above data 27/5/ 6/6, it has started downloading the tick data for ES 06-12 for period from 27 May 12 to 6 Jun 12 and after saving these data, Ninja Trader has started downloading data for ES 09-12 for period from 02 Jun 12 to 30 Jun 12.

    After downloading the tick data for above two contracts (which are the prev contract to the one for which I require the data), NT has stopped the downloading.

    Now when I changed the date range for ES 12-12 to 06 Jun 12 to 30 Jun 12, it has downloaded the tick data correctly. After that I have downloaded tick data from 25 May 12 to 5 Jun 12 as well but I did not use the complete one month in one go.

    I have already gone through all of the youtube videos as well.

    Would you please explain why NT is not allowing the download of tick data for a whole month in one go.

    Thanks and regards,
    Fxheaven

    #2
    ES 03-13 - Tick Data

    Hi,

    When I tried to download tick data for ES 03-13, I got the following error message.

    Error on reloading data: Ninja Trader data server does not support this instrument, no data available. (InvalidInstrument).

    Would you please explain why this instrument is not supported.

    Thanks and regards,
    Fxheaven

    Comment


      #3
      Hello,

      You need to turn off the auto merge, you cannot use auto merge on contacts that the expiry is in the future.

      Control Center->tools->options->data tab->Merge Policy: Do Not Merge.

      Once this is set the download will download justs the pure contract data.

      Note: This operation done when the 12-12 is the current contract would then work fine.

      -Brett
      BrettNinjaTrader Product Management

      Comment


        #4
        How to download ES tick data to load the chart from 1st Feb till today

        Hi,

        I have got a data connection from Optimus Futures and my goal is to download data for different contracts (that is contracts with different maturities) of ES and create a tick data chart for a period from 1st Feb 12 to the current date.

        Now I understand that I need to create a continuous contract to load 6 months tick data on chart and for that I want to use Ninja Trader's facility to create the continuous contract data.

        The following contracts were / are traded for the period from 1st Feb to current date, so I have to download the tick data for all the following contracts, either from 1st Feb 12 or the start date of each contact, whichever is later.

        ES 03-12
        ES 06-12
        ES 09-12
        ES 12-12
        ES 03-13
        ES 06-13
        ES 09-13

        1. Please let me know if my above understanding is correct.

        2. Now you have advised me to turn off the data merge. So if I download the tick data with data merge turned off, will Ninja Trader download the tick data which is not in the form of continuous contract?

        3. And in above case (2), after downloading the data, I have to use NT’s facility to create a continuous contract. Am I correct?

        4. If I keep data merge on, will NT download the data for above different contract as continuous contract data and then I don’t have to use further NT’s facility to create the continuous contract data?

        5. If I download as said in above (4), how will I download data for the contracts which are not yet expired? I understand that to load the data in the chart up to yesterday, the data for the contracts which are not expired will also be needed to complete the chart.

        I am looking forward to hearing back from you. I understand that the above cases cover all the options on downloading data.

        Thanks and regards,
        Fxheaven
        Last edited by Fxheaven; 07-11-2012, 02:48 AM. Reason: To insert the title

        Comment


          #5
          Hello Fxheaven,

          1. I would only load data for 03-12, 06-12 and 09-12.

          2. Yes, you will now only load data for the expiry in question - it will not load and merge data from other expiries in a chart.

          3. Yes, you would set 'Merge policy' back to MergeBackAdjusted. Subsequently if you create a new chart, data from the different expiries will be merged as per the rollover dates that are setup.

          You can check the rollover date as follows. Please go to Control Center-->Tools-->Instrument Manager. Highlight an instrument in the 'Available master instruments' section and click Edit. Subsequently select the Misc-tab and scroll to the bottom. Select the 'Contract months' row and click the '...' button that appears. Select an expiry month and you will see a rollover date listed.

          The instruments rolls over on this date to the expiry you have selected. This means historical data from the previous expiry will be loaded before this date.

          4. Yes, if you keep this option enabled all charts you will create will automatically merge data from different expiries (providing the chart requests data after the rollover date).

          5. You will only download data for one expiry per time period. It seems you are under the assumption that data is loaded for multiple expiries per time period, subsequently the average is taken and then plotted. This is not the case.
          JasonNinjaTrader Customer Service

          Comment


            #6
            Video/Help Article explaining how to download data and create a chart for six months

            Hi Jason,

            Thanks for all your help.

            Do you have any video / help article which explains how to download data for say six months / one year and create a chart for any security for say six months / one year.

            I am little confused what you said below.

            I am looking forward to hearing back from you soon.

            Thanks and regards,
            Fxheaven

            Comment


              #7
              Hello Fxheaven,

              You download historical data automatically when you create a chart. You can find instructions and a video how to create charts at the link below.
              http://www.ninjatrader.com/support/h...ng_a_chart.htm

              If you have 'Merge policy' enabled, data will be loaded as per the rollover dates that are setup.

              Can you please let me know what is confusing so I can clarify.
              JasonNinjaTrader Customer Service

              Comment


                #8
                Hi Jason,

                Thanks for all your help and sorry for inconvenience caused to you by forming the questions incorrectly.

                If the historical data is downloaded when the chart is created, why separated download manager is given? Please explain. I understand that if I donwload data using the download manager, the loading of the chart becomes little quicker.

                What I don't understand is - How to complete the following back testing.

                I want to backtest my strategy on each contract separately and also on the continuous as well. Let's say current actively traded contract is ES 09-12 but I want to test my strategy on contact ES 12-12 and also ES 03-13.

                So please let me know how to download data and create a chart for each contract separately, for ES 12-12 and ES 03-13, say for a period from start date of these contracts to current date, because each contract is being traded for roughly 14 months.

                At the same time, I want to test my strategy on actively traded contract for say last 12 months. In this case I have to merge the data of more than 1 contract, say 4 contracts as each contract is actively traded for 3 months only.

                So Please let me know how to see the charts separately for each contact and as a merged contract, say continuous contract.

                Thanks again and with best regards,
                Fxheaven

                Comment


                  #9
                  Hello,

                  The download option is essentially the same, just another way to download data.

                  Here is what I suggest to you if you need to work with continuous on the standard contracts.

                  Use the ES ##-## contract, this is a continuous contract that your provider should support(Some do not however) Please test and see if you can pull up a chart of ES ##-##.

                  IF so tha tI suggest that you use this for the continuos chart(This will automatically be continous) then go to control center->tools->options->data tab->merge policy: Do Not Merge so that the ES 09-12 or whichever you select is the straight native contract.

                  This way you use the ##-## for continuous and the 09-12 for straight.

                  -Brett
                  BrettNinjaTrader Product Management

                  Comment


                    #10
                    Hi, Brett,

                    I am trying to download historical data for DX #-# from Vision, but get an error that "NT server does not support this instrument /"InvalidInstrument"...I can do it for many other continuous futures contracts, but cannot for DX#-#, NG, RF, TF....What might the reasons be?

                    thanks a lot for your support.
                    E.

                    Comment


                      #11
                      Hello E,

                      Are you able to view the normal contract expires on the chart for example the DX 03-13?
                      JCNinjaTrader Customer Service

                      Comment


                        #12
                        No, I get the same error message...

                        Comment


                          #13
                          Hello zheka,

                          Thanks for your reply.

                          Please ensure you are running the current version of NinjaTrader and then reset your instruments.

                          To check what version of NinjaTrader you are running go to Help> About
                          To upgrade to NinjaTrader version 7.0.1000.11 please follow the link bellow.
                          http://www.ninjatrader.com/download-registration.php
                          Under Current User paste your license key.
                          You can locate your license key under Help> License key
                          Select Download NinjaTrader
                          Download Version 7.0.1000.11 (Current)
                          Before running the installer ensure NinjaTrader is closed.

                          To reset your instruments please: go to the Tools menu, select the Options menu item, select the Data tab, and then click on 'Reset Instruments'.
                          BrandonNinjaTrader Customer Service

                          Comment


                            #14
                            I am running the most current NT, and did Reset Instruments.

                            Does not help. Still getting the same error

                            Comment


                              #15
                              Hello zeheka,

                              Thanks for your reply.

                              So I may assist you further please send your trace file to support[at]ninjatrader[dot]com
                              In the message put ATTN Brandon and include a link to this forum post.

                              You will find the trace file on your PC in the (My) Documents > NinjaTrader 7 > Trace folder.
                              The trace file will be named "trace.20130121.txt"

                              I look forward to assisting you further.
                              BrandonNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by peregrine, Today, 05:49 PM
                              0 responses
                              3 views
                              0 likes
                              Last Post peregrine  
                              Started by JamesBond, Today, 04:22 PM
                              0 responses
                              10 views
                              0 likes
                              Last Post JamesBond  
                              Started by Parmenides48, Today, 03:29 PM
                              0 responses
                              20 views
                              0 likes
                              Last Post Parmenides48  
                              Started by ezrollin, Today, 03:09 PM
                              1 response
                              13 views
                              0 likes
                              Last Post ezrollin  
                              Started by JamesBond, Today, 01:38 PM
                              2 responses
                              23 views
                              0 likes
                              Last Post JamesBond  
                              Working...
                              X