Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Historical data import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • James Beale
    replied
    Yes. Thank you. That did the trick. I didn't realise that being connected to a data feed would cause the issue.

    Leave a comment:


  • NinjaTrader_Jason
    replied
    Hello James Beale,

    Thank you for clarifying.

    The SPXNT should be listed in the Instrument Manager. Can you please disconnect from any data feed in NinjaTrader. Subsequently open the Instrument Manager, set Type to <Any>, enter SPXNT in the Name field and hit the Search button. Check if you see the SPXNT listed.

    Leave a comment:


  • James Beale
    replied
    Historical Data Manager / Edit tab shows SPXNT.

    No stock instrument named "SPXNT" in the Instrument Manager.

    Leave a comment:


  • NinjaTrader_Jason
    replied
    Hello James Beale,

    Can you please tell me what instrument is listed in the Historical Data Manager-->Edit-tab that shows the data you imported.

    Do you see a stock instrument named "SPXNT" in the Instrument Manager?

    Leave a comment:


  • James Beale
    replied
    Hello

    I'm also having some trouble with data import for the S&P500 index. I've imported correctly, and everything is visible in the Historical Data Manager, and a manual check of the data confirms.

    I've been advised to import a text file called SPXNT. I understand the import should have created a new Master Instrument called something like $SPXNT, but nothing.

    I've tried creating a new instrument, using Stock and Index, but nothing saves, and there is no error message.

    Where should I look next?

    Leave a comment:


  • NinjaTrader_Jason
    replied
    I am not quite sure if it will rewrite the data. I recommend to delete the incorrect data first at Control Center-->Tools-->Historical Data Manager-->Edit-tab.

    Shut down NinjaTrader and navigate to the folder below.

    C:\-->Users-->*Windows user account*-->Documents-->NinjaTrader 7-->db

    Delete the "cache" folder.

    Start NinjaTrader and import the correct data.

    Leave a comment:


  • donmuthu
    replied
    Thx Jason. "DoNotMerge" and removing and adding again worked.

    A related query: Say, I have uploaded incorrect data. Would uploading the correct data rewrite the old data? or Do I have to delete the old data first?

    Leave a comment:


  • NinjaTrader_Jason
    replied
    Hello donmuthu,

    Does it make a difference if you right click in the chart and you select 'Reload All Historical Data'? If not, please exit NinjaTrader and go to C:\-->Users-->*Windows user account*-->Documents-->NinjaTrader 7-->db and delete the cache folder. Start NinjaTrader and check again.

    If the issue remains, please try the following. Go to Control Center-->Tools-->Instrument Manager, highlight the NIFTY and click Edit. Set 'Merge policy' to DoNotMerge and click OK.

    Remove and re-add the NIFTY 07-14 to your instrument list. Instructions can be found at the link below.
    http://www.ninjatrader.com/support/h...ment_lists.htm

    Click OK in the Instrument Manager and create a new NIFTY 07-14 chart. Check if data is loaded up to June 2nd.

    Leave a comment:


  • donmuthu
    replied
    I seem to be facing the same issue. Even though data from June 2 has been imported successfully the chart starts only from June 19. Please suggest where I am going wrong. Thx,
    Attached Files

    Leave a comment:


  • NinjaTrader_ChristopherJ
    replied
    Please adjust your PC clock to 2007 with the steps I have provided below in order to view earlier expiry dates.
    • Shut down NinjaTrader
    • Right mouse click on your PC clock
    • Adjust Time/Date
    • Click on Change data and time....
    • Adjust your date to a June date in 2007
    • Click Ok
    • Start NinjaTrader and 2007 expiries will be available

    After you have added the additional instruments please set your PC clock back to 2012.

    Leave a comment:


  • Malcik
    replied
    One more question - now that I've imported some historical data (namely, YM 03-11), I would like to display it. I understand that I have to go to Instrument Manager first and add YM 03-11 to my instrument list. In Instrument Manager window, I locate YM in the master instrument list.

    The problem arises when I want to select expiry. 03-11 is not available in the drop down list (the list only goes back to 09-11; see attached screenshot). What do I do for expiries before 09-11?

    Thanks
    Attached Files

    Leave a comment:


  • NinjaTrader_ChristopherJ
    replied
    Glad to hear that did the trick.

    Leave a comment:


  • Malcik
    replied
    Hi Chris,

    Thanks for your help. Everything is working now. It seems the "Session Template" setting is making the difference. For some reason, I can't leave that setting as preset.

    Leave a comment:


  • Malcik
    replied
    Originally posted by NinjaTrader_ChristopherJ View Post
    So I can test the data you have imported can you please forward the .txt file to me at [email protected] and include a link to this forum post as well as Attn: Chris J in the Subject line.
    Forwarded. Thanks

    Leave a comment:


  • NinjaTrader_ChristopherJ
    replied
    So I can test the data you have imported can you please forward the .txt file to me at [email protected] and include a link to this forum post as well as Attn: Chris J in the Subject line.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by tobiaste, Today, 03:11 AM
0 responses
3 views
0 likes
Last Post tobiaste  
Started by fastketousa, Today, 03:01 AM
0 responses
3 views
0 likes
Last Post fastketousa  
Started by fastketousa, Today, 02:59 AM
0 responses
3 views
0 likes
Last Post fastketousa  
Started by s.kinra, Today, 02:59 AM
0 responses
6 views
0 likes
Last Post s.kinra
by s.kinra
 
Started by JimB17, 01-10-2020, 10:27 AM
15 responses
339 views
0 likes
Last Post cls71
by cls71
 
Working...
X