Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

A lot of gaps in charts that are using historical data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    A lot of gaps in charts that are using historical data

    Hello,

    I imported tick data into NT for this week and selected the option to generate minute bars from the imported tick data. All data correctly appears in the Historial Data tool.

    Then I downloaded data for this week for Market Replay.

    The problem I am having is that when I create a new chart (which will use the historical data to draw past prices), there are loads of gaps in all timeframes. Attaching an example of the 30min timeframe, where I can see gaps from 30mins to 18hours.

    As said, the data correctly appears in the Historical Data tool; any idea what the problem could be?

    Attaching an screenshot with the problem...
    Attached Files

    #2
    Hello Tronader,

    Thank you for your forum post.


    Who are you connected to? This is displayed in the lower left hand corner of the Control Center in green.


    What session template is applied to the chart?
    • Right mouse click on the chart background > "Data series..."
    • Under "Data" > "Session template"



    If you download minute data from the historical data manager as well as the tick data, does this data help to resolve the situation?
    Ryan L.NinjaTrader Customer Service

    Comment


      #3
      Hi Ryan,

      The session template appears as '<Use instrument settings>' and I had selected the Period (Last / Minute / 1) for the ES 12-12.

      I selected the 'File - Connect - Market Replay Connection' option so the green information on the lower left hand side says: 'connected - replay'.

      I'm starting out, so I don't have a data provider yet. What I did was to import the tick data I have and select the option to create minute data from that. Then I've check in the Edit tab of the Historical Data Manager that the minute information appears correct, all the minutes for all the days. But those same minutes after are not displayed when I create a new chart in the 30mins or 60mins timeframe for example.

      On a side note, although this is not the main problem of the post, is it possible to configure the cursor (pointer or cross air) so that it displays the day as well as the time? without it, it's difficult to make sure the correct minute data has been imported into the Historical Data Manager.

      Thank you!

      Comment


        #4
        If you are not connected to Market Replay are you able to open a Minute chart for the date you have imported?

        When using the Cross Hair feature time will be displayed at the bottom of chart however to view the date you would need to open the Data Box or hold down the middle mouse button (scroll wheel) to view the mini data box.
        Christopher J.NinjaTrader Customer Service

        Comment


          #5
          Hi,

          Thanks for the info about the pointer, really useful now.

          Yes, I am able to open a Minute chart when I am not connected, although I've noticed 2 issues:
          1. It just goes back until the 10th of October, even though I've got data until the 1st.
          2. Data is still missing in some charts and displayed in other timeframes. For example, have a look at the new attachment (missing_data_in_certain_charts.png), almost the whole day 11th is missing in the 60min timeframe even when it's simultaneously displayed in the 30min chart.

          Any idea what could be going on?

          *Editing to add another misleading example, I was using market replay in the 1min chart and then I received a massive gap (another_misleading_example.png). I don't understand the nature of this big jump.
          Attached Files
          Last edited by Tronader; 10-15-2012, 05:39 PM.

          Comment


            #6
            Please send a note to Support [AT] NinjaTrader [DOT] com with "ATTN: Chris J" in the subject line.

            In the message, please include the following:
            1.) A link to this forum thread.
            2.) Your most current trace and log files.

            You will find the file here: My Documents > NinjaTrader 7-> Trace > trace.YYYYMMDD.txt

            Log file will be located by going to Documents->NinjaTrader 7->Log->log.YYYYMMDD.txt
            Christopher J.NinjaTrader Customer Service

            Comment


              #7
              Hi Guys

              I am having exactly the same problem with the ES 12-12, as an example, except that my charts looks even worse, with more gaps, missing data and 4 day weeks some of the time.
              I use Kinetick EOD, and IB for my live data feed. My issue is that the RTH and ETH charts looks exactly the same, which they shouldn't, in the Daily format. The gaps are understandable in the RTH charts but make no sense in the ETH charts, especially when the data is there in the shorter time frames such a minutes etc.

              thanks

              Comment


                #8
                When connected to Kinetick Daily data uses the Daily Settlements from the CME Group for Daily data therefore may have different values when compared to other providers depending what they use for price where as the minute data will retain the Open, High, Low, Close as normal.

                For information on the Daily Settlement Procedures please visit the following link:

                http://www.cmegroup.com/market-data/...Procedures.pdf

                Also when viewing Daily data NinjaTrader will display all data that is provided by the data provider and will not reflect Session Templates times used. We have assigned this feature request ID #55 in our tracking system.
                Christopher J.NinjaTrader Customer Service

                Comment


                  #9
                  Is this also true for ZenFire?

                  I have tried multiple settings but this is what my daily looks like. If i go back to a 1 hr chart the gaps are not there.


                  How can i get the daily to display properly?
                  Attached Files

                  Comment


                    #10
                    Zen-Fire will use RTH data for it's daily calculations

                    If you would like ETH charts, you will need to connect to Kinetick End of Day (free) as the first connection, and then connect to Zen-Fire. Once connected, right click on your chart and select 'reload all historical data'.

                    Otherwise, you can load a 1440 minute bar chart from Zen-Fire and set the Session Template to either ETH or RTH depending on what you prefer.
                    MatthewNinjaTrader Product Management

                    Comment


                      #11
                      thanks that got it

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by schmidtbc16, Today, 03:36 PM
                      1 response
                      7 views
                      0 likes
                      Last Post NinjaTrader_ChelseaB  
                      Started by RT001, Today, 03:25 PM
                      2 responses
                      13 views
                      0 likes
                      Last Post RT001
                      by RT001
                       
                      Started by mbrandau, Today, 01:58 PM
                      5 responses
                      37 views
                      0 likes
                      Last Post mbrandau  
                      Started by remcovdmeulen, Today, 02:15 PM
                      1 response
                      12 views
                      0 likes
                      Last Post NinjaTrader_Jim  
                      Started by gbrad, Today, 09:57 AM
                      7 responses
                      15 views
                      0 likes
                      Last Post NinjaTrader_Jesse  
                      Working...
                      X