Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Can't load SPY and SSO from IB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't load SPY and SSO from IB

    Hi there,

    I can't load data for SPY and SSO from Interactivebrokers. I've looked at the Interments Manager, but there is way too things in there I don't know. What do I do?
    Thanks.

    #2
    Hello 10percent,

    Thank you for your note.

    You may just need to add the proper exchange for these ETFs.


    Here are the written and video instructions on how to add an instrument from TWS, this uses SPY as an example.
    http://screencast.com/t/ShiCvNgeg4r

    * Enter the instrument in TWS, e.g. SPY

    * Right click the instrument in TWS select Contract Info -> Details -> The Interactive Brokers symbol website will open.

    * Take note of the BOLD exchange in the list, e.g. ARCA

    * Open the NinjaTrader Control Center

    * Tools -> Instrument Manager

    * Search for the instrument to make sure that it is not part of the list or the name is not taken.

    * Press 'New'

    * Fill in the Master Instrument with the instrument label, e.g. SPY

    * In the exchanges menu, check 'Default' and check the exchange that was BOLD on the IB website (ARCA).

    * On the 'Misc' tab, scroll to the Interactive Brokers field under the Symbol Map section. Set this field to the same symbol it is in TWS.

    * Press 'OK'

    * Use the '<' Arrow to add it to your Default List.



    Similar instructions can be found here:
    http://www.ninjatrader.com/support/f...ad.php?t=45833
    Let me know if there is anything else I can do for you.
    CameronNinjaTrader Customer Service

    Comment


      #3
      Thanks Cameron. It works now, but I have another problem.

      It seems to take quite a lot of time for NinjaTrader to download data when pick a new symbol, in all timeframes. I wait for "loading data..." anywhere from 15 secs to 45 secs.
      and when I switch fast between symbols, I get an error saying "IB historical data pace violation"
      My guess NT is downloading data everytime I pick a symbol, even if I come back to the same symbol after couple of minutes It downloads again and causing IB to block historical data for 5 minutes.
      A fix for this?

      Thanks a lot.

      Comment


        #4
        Hello,

        Please open the Options menu (Tools > Options) and navigate to the Data tab. Check the 'Save Chart Data as Historical' box, then click OK. This change should help to limit the requests for data which NinjaTrader makes.
        KyleNinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by schmidtbc16, Today, 03:36 PM
        1 response
        8 views
        0 likes
        Last Post NinjaTrader_ChelseaB  
        Started by RT001, Today, 03:25 PM
        2 responses
        14 views
        0 likes
        Last Post RT001
        by RT001
         
        Started by mbrandau, Today, 01:58 PM
        5 responses
        37 views
        0 likes
        Last Post mbrandau  
        Started by remcovdmeulen, Today, 02:15 PM
        1 response
        13 views
        0 likes
        Last Post NinjaTrader_Jim  
        Started by gbrad, Today, 09:57 AM
        7 responses
        17 views
        0 likes
        Last Post NinjaTrader_Jesse  
        Working...
        X