Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Market Replay Not Loading Charts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Market Replay Not Loading Charts

    Hello.

    I downloaded historical data for my instrument and brought up the proper workspace and started market replay, but it says 'Loading data' and fails to bring up the chart.

    Help!

    Thanks

    #2
    Hello nepenthean,

    Thank you for your post.

    If you create a new workspace (File > Workspaces > New Workspace) and add a new chart there would you see the same behavior?
    KyleNinjaTrader Customer Service

    Comment


      #3
      Originally posted by NinjaTrader_Kyle View Post
      Hello nepenthean,

      Thank you for your post.

      If you create a new workspace (File > Workspaces > New Workspace) and add a new chart there would you see the same behavior?

      Yes, Kyle. I have the same situation if I create another workspace and attempt to open the same instrument.

      Comment


        #4
        Hello nepenthean,

        Which instrument and date were you working with? I'll need to know this so that I can test the data here.
        KyleNinjaTrader Customer Service

        Comment


          #5
          Originally posted by NinjaTrader_Kyle View Post
          Hello nepenthean,

          Which instrument and date were you working with? I'll need to know this so that I can test the data here.
          thanks for the quick reply!


          HG, 7/16/12 RTH

          It was working fine until I rewound it a bit and then I cannot load any data.

          Comment


            #6
            Hello nepenthean,

            Thanks for getting back to me.

            Please download a new copy of the data via the File > Utilities > Download Replay Data menu then try the replay again. If you run in to the same issue, please let me know.
            KyleNinjaTrader Customer Service

            Comment


              #7
              Kyle,

              Yes, the same thing occurs after re-downloading the same data. The bars load normally, but as soon as I start market replay all charts just hang with, 'loading data'.

              Comment


                #8
                Hello,

                From which point to which point are you rewinding in the data set?

                Which indicators are used in your charts?
                KyleNinjaTrader Customer Service

                Comment


                  #9
                  Originally posted by NinjaTrader_Kyle View Post
                  Hello,

                  From which point to which point are you rewinding in the data set?

                  Which indicators are used in your charts?

                  I am forwarding the replay to start at RTH. I have EMA, SMA, and Acme volume profile for indicators. Everything was fine until I rewound during RTH. From that point on, it would not work.

                  Comment


                    #10
                    Hello nepenthean,

                    Can you please try the following. Go to Control Center-->Tools-->Options-->Data-tab and click Repair DB. Restart NinjaTrader and check if charts continue to display data when using the Market Replay connection.

                    If not, please exit NinjaTrader and go to C:\-->Users-->*Windows user account*-->Documents-->NinjaTrader 7-->db and delete the cache folder. Start NinjaTrader and check again.
                    JasonNinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by NinjaTrader_Jason View Post
                      Hello nepenthean,

                      Can you please try the following. Go to Control Center-->Tools-->Options-->Data-tab and click Repair DB. Restart NinjaTrader and check if charts continue to display data when using the Market Replay connection.

                      If not, please exit NinjaTrader and go to C:\-->Users-->*Windows user account*-->Documents-->NinjaTrader 7-->db and delete the cache folder. Start NinjaTrader and check again.
                      I clicked on 'Repair DB' and I received a 'Not Responding' message. I closed NT and restarted it and received 2 messages stating the data file is corrupt. I downloaded NT to repair installation and after the repair I started NT to receive the same messages.

                      I will now remove NT and download it again.

                      Update: I removed NT and installed it again. I still get the same message, and now I cannot even open NT!

                      "Unable to connect to database. Database file may be corrupt. Run repair utility."

                      So I did what was instructed, and things are now worse.

                      Update 2: I uninstalled NT through windows and I still have the same problem.
                      Last edited by nepenthean; 11-14-2012, 05:19 PM.

                      Comment


                        #12
                        I deleted the old db file in the the NT directory, so I can now open NT.

                        I deleted the cache folder in the db directory but am still having the same issue: I am unable to open 7/16/12 in market replay. My charts are not loading data.

                        Comment


                          #13
                          Hello,

                          Please contact me via email: Support [AT] NinjaTrader [DOT] com

                          In your message, please include:

                          1.) A link to this forum thread.

                          2.) A copy of today's trace file.
                          You will find this diagnostic file in the Documents > NinjaTrader 7 > Trace folder. I'll need a copy of the file named 'trace.20121114.txt'.

                          Thank you!
                          KyleNinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by schmidtbc16, Today, 03:36 PM
                          1 response
                          5 views
                          0 likes
                          Last Post NinjaTrader_ChelseaB  
                          Started by RT001, Today, 03:25 PM
                          2 responses
                          10 views
                          0 likes
                          Last Post RT001
                          by RT001
                           
                          Started by mbrandau, Today, 01:58 PM
                          5 responses
                          31 views
                          0 likes
                          Last Post mbrandau  
                          Started by remcovdmeulen, Today, 02:15 PM
                          1 response
                          9 views
                          0 likes
                          Last Post NinjaTrader_Jim  
                          Started by gbrad, Today, 09:57 AM
                          7 responses
                          14 views
                          0 likes
                          Last Post NinjaTrader_Jesse  
                          Working...
                          X