Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Interactive Brokers Placing orders through NT7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Interactive Brokers Placing orders through NT7

    I am trying to place order using IB through NT7 .

    I found that when I place any other types of order, it takes 5 second from "pending" to become "accepted". I am afraid that will make a great lag in my trading. Is it the case? Or any setting in can make it faster?

    #2
    Hello abcdabc,

    Thank you for your post.

    The order state pending means the order has been submitted to the connectivity provider, and is awaiting confirmation from the connectivity provider.
    A state of accepted means the order has been confirmed as received by the broker.
    For information on order state definitions please visit the following link: http://www.ninjatrader.com/support/h...efinitions.htm

    There is no setting to change here to increase the speed of execution. Standard latency applies here as well.

    I would ask that you are on the latest version of NinjaTrader (7.0.1000.11) and the supported version of TWS (927.7).
    If not you may download both from the following links:
    Download NinjaTrader: http://www.ninjatrader.com/download-registration.php
    Download TWS 927.7: http://www.ninjatrader.com/ninjatrad...tall_927_7.exe

    Please let me know if I may be of further assistance.

    Comment


      #3
      Thanks for the assistance. I am on the latest version for both you have mentioned.

      Comment


        #4
        I tried again and have the same result.

        I think it is abnormal to have an order placed and pending for almost 10 seconds before execution.

        I would like to know is it my own problem or it is common to wait 10 seconds for even a market order for Interactive Brokers via NT7? Thanks

        Comment


          #5
          The problem resolved after I re-open IB TWS. Thanks

          Comment


            #6
            I found how the problem caused. I would like to share and looking for an update for it in the future.

            The order placing works fine before I changed the execution price by pressing the increase(+) or decrease(-) buttons in the NT7 control center. After that, the order execution time will be delayed from 0.5second to almost 10 seconds for ordering later on. Hope it helps for NT improvement.

            Comment


              #7
              Hello abcdabc,

              Thank you for your response on this matter.

              Please provide a step by step process that we can use to re-create this item on our end. Please include as much detail as possible including order type and instrument.

              Comment


                #8
                Sorry I got that I was wrong. The problem still exists.

                I am trading YM. I got no problem when I was trading HSI.
                For YM, I connect CQG first for data and then IB for broker.
                For HSI, I just connect IB for both data and broker.

                Below is the case trading YM.

                I tried placing order in TWS and it worked fine, almost no pending time, for both limit or stop order.

                When I place orders through NT7, it takes 10 seconds pending time with some 2 to 5 seconds, but it is enough to ruin the trades.

                I wonder whats the problem is. Thanks.

                Edit: I set 3 setting in TWS configuration and the pending time not longer exist, for this moment (I don't know if it is short time luck only).
                1. API - Precaustions, checked "Bypass Order Precaustions for API for APR orders"
                2. API - Precaustions, checked "Bypass negative yield to worst confirmation for API orders"
                3. Orders - Set 0 second in "Leave cancelled orders on the screen for X seconds"
                Last edited by abcdabc; 12-04-2012, 09:55 AM.

                Comment


                  #9
                  Hello abcdabc,

                  Thank you for your update on this matter.

                  Please go to Edit > Global Configuration > API > Settings, and advise what the Master API Client ID is set to in TWS.

                  I look forward to your response.
                  Attached Files

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by MonteK, Yesterday, 09:31 PM
                  0 responses
                  25 views
                  0 likes
                  Last Post MonteK
                  by MonteK
                   
                  Started by nkhoi, Yesterday, 09:27 PM
                  1 response
                  11 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Started by SuperDude123, Yesterday, 03:52 PM
                  4 responses
                  26 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Started by ErikY, Yesterday, 01:16 PM
                  1 response
                  25 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Started by BullyWig Trader, Yesterday, 12:42 PM
                  1 response
                  17 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Working...
                  X