• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Market Replay

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Market Replay

    I am having problems recording my day session. I followed the instructions from the video (great videos by the way) but my sessions end shortly after I started them. This morning I turned it on thru the options -etc. After the market closed I tried to replay - the "available instruments" are showing a Begin time of 7:09am and End time of 7:35am. If I changed something on the chart such as the minute chart, would that have stoppped the charts?

    #2
    imported post

    No that would not affect anything. Is the available instruments you are looking at set for today's date?
    RayNinjaTrader Customer Service

    Comment


      #3
      imported post

      Yes, I currently have two dates showing up. yesterday's date when I tested the process and today's date. Today's date has 3 issues - the Euro, ER and YM. I had opened two charts this morning - ER and YM.

      Comment


        #4
        imported post

        Tomorrow, here is what I would like you to do:

        1) Before application start, Tools-->Options, Misc tab, check "Run market data recorder" and set interval to 1 minute
        2) In Order Panel, set instrument to ER2 03-06 (don't change all day)
        3) Run it all day
        4) End of day, disconnect and connect to Market Replay Connection
        5) Select todays date and tell me what the time frame you have recorded for the ER2 03-06

        Thanks
        RayNinjaTrader Customer Service

        Comment


          #5
          imported post

          I followed the instructions exactly and my results weren't any different. In the order I am showing the ER and that was the only chart I opened for the day - 1min. When I open Market Replay under today's date I have the option of two market instruments - the ER and YM. For the ER Begin time is 7:13 am - End time 7:31am. The YM shows Begin 7:14am - End time 7:37am. I had two Super Domes open - one for the ER and one for the YM.I had a connection to Patsystems and Esignal open.

          Comment


            #6
            imported post

            So to wrap up:
            a) you had the ER2 03-06 selected on the order panel
            b) you have been connected to you broker (which one?)
            c) you have not been connected to Simulated data feed or the External data feed
            d) you left this setup definitely longer that 7:31 am and did not disconnect or shutdown and restart NT5 after that
            e) you did see ER2 03-06 updating on the orders tab in cc for at least some minutes after 07:31 am

            -> so there really should be more recorded ER2 03-06 data than just until 07:31 am.

            Could you please confirm statements above and let me know if one or more are incorrect.

            Now let's try to isolate the issue:
            a) Was there any indication of connection loss around 7:31 am?
            b) Please send us traces and logs (Help->Mail to support)
            c) Please send us zipped directory <install>\db\data (= recorded market data)
            d) Which broker are you connected to?

            Thanks
            DierkNinjaTrader Customer Service

            Comment


              #7
              imported post

              In answer to your questions below:
              a. yes
              b. yes - Patsystems Open Ecry
              c. no
              d. correct - i was connected the entire time without internet problems
              e. yes it was updating

              Second part
              a. no loss that I was aware of
              b. not sure how to send the log
              c. sent
              d. Open Ecry

              I tried again today only connected to Patsystems OpenCry and not touching a thing in the control center. I noticed the control center was updating correctly. And again i have a Begin time of 7:09 for ER and 7:10 for YM and end time of 7:32 for both of them. I only had open one chart which i had minimized for most of the day. I can't figure out what is happening or what triggers the replay to stop. Hopefully you will find something in the database.

              Comment


                #8
                imported post

                Thanks.

                a) Logs and traces are attached by default to any mail you send out via Help->Mail to support. The mails you sent us already hold them. Thanks.

                b) You did send me the DB (<install>\db\ninjatrader.mdb). However I would need zipped <install>\db\data directory, since recorded market data is stored there (see below).

                Thanks
                DierkNinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by SAILIKITY, 05-22-2019, 05:41 PM
                1 response
                5 views
                0 likes
                Last Post NinjaTrader_PaulH  
                Started by rmillar, 01-09-2019, 06:02 PM
                6 responses
                64 views
                1 like
                Last Post eDanny
                by eDanny
                 
                Started by mlarocco, Today, 11:39 AM
                4 responses
                20 views
                0 likes
                Last Post mlarocco  
                Started by roblogic, Today, 11:19 AM
                4 responses
                21 views
                0 likes
                Last Post roblogic  
                Started by saeed, Today, 10:17 AM
                8 responses
                53 views
                0 likes
                Last Post NinjaTrader_Kate  
                Working...
                X