• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Chart unhandled exception errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Chart unhandled exception errors

    Hi again,

    When I run more than one chart at a time (eg. different time frames, same market), after a while one goes blank with a big red cross and gives me an "unhandled exception error", with option to continue or close.

    Is this normal? - I mean for running mutliple charts? Am I allowed to run multiple charts?

    I have a copy of the details of the error message if required.

    thanks,

    Antraman

    #2
    imported post

    Hi Antraman,

    Can you send over the details of the errormessage to [email protected]

    Vince
    VinceNinjaTrader Customer Service

    Comment


      #3
      imported post

      Done.

      Comment


        #4
        imported post

        Not sure its related but had another problem with a third chart opened.

        I am running a 10 tick, a 1 minute, and a 1 hour chart on the ES, and after almost 1 hour, on the 60min chart, a red line indicating a new day came up, and the chart started ticking along very fast, almost as though it was running in ticks, but the time at the bottom kept scrolling out at 0.00.

        Then it did an unhandled exception error again.

        The other two charts continued to run as normal...

        thanks

        Antraman

        ps: I'm running a Sony Vaio 2.66GHz P4, with 1GB Ram, Radeon IGP 345M graphics card (64MB)and XP Pro SP2

        Comment


          #5
          imported post

          I sent you a PM.
          DierkNinjaTrader Customer Service

          Comment


            #6
            imported post

            Issue is fixed with NT5R7.

            Note: You need to resave all your chart templates (including the default one), since there was some "garbage data" saved with the templates which could throw off charts as they are opened.
            DierkNinjaTrader Customer Service

            Comment


              #7
              imported post

              Hi Dierk,

              What file did I have to delete again? I have version 5.07 running but it did the exception error again. I think I installed the update before deleting the old folders...

              thanks

              Comment


                #8
                imported post

                <install>\charttemplates\*.xml
                DierkNinjaTrader Customer Service

                Comment


                  #9
                  imported post

                  Uh ohhh!

                  That was not good.

                  I deleted all the files for the charts in charttemplates folder. When I tried to run NT5 after that, it paused for a while, gave me the installer window, and the blue bars crept slowly across until about midway then it gave an error that said

                  The feature you are trying to use is on a network resource that is unavailable.

                  Click OK to try again, or enter and alternate path to a folder containing the installation package NinjaTrader Install.msi


                  After clicking OK, another warning said

                  Installation Package for the NinjaTrader 5 cannot be found. Try again using a valid copy of NT Install.msi

                  I then uninstalled NT5 (and NT4) and deleted a remaining NT5 folder in programs.

                  I then downloaded the new version again from the Ninja webpage and ran the installer. It downloaded OK but when I ran the wizard it got halfway then gave me the following error message:

                  Exception occurred while initialising the installation.
                  System.IO.FileNotFoundException: File of assembally name NinjaTrader.Core.dll, or one of its dependencies was not found.


                  I tried downloading twice and got the same message.

                  Please help!!!

                  Antraman

                  Comment


                    #10
                    imported post

                    Hmmm. This is getting complicated now.

                    I tried a fresh install on a machine that has not yet had a copy of NT on it. I had to install the .NET framework, but the Jet database and the the MDAC dll was already current with my version of XP.

                    I downloaded the Install.msi from the NT website, ran it and got halfway through the install wizard when it gave me the follwoing message:

                    "The cabinet file 'blah blah blah***' reqired for this installation is corrupt and cannot be used. THis could indicate a network error, an error reading from the CD ROm, or a problem with this package. "

                    *** Note: 'blah blah blah' is a bloody long string of numbers and text...

                    I suspect there is nothing wrong with my machines after all, and that it may be with the release on the website. Could that be correct?

                    I recall now that it did take a long time to download the msi installer...and I have a broadband connection.

                    cheers,

                    Antraman

                    Comment


                      #11
                      imported post

                      Please check out this KB article on how to recover your installation: http://www.ninjatrader-support.com/a...b/questions/25
                      DierkNinjaTrader Customer Service

                      Comment


                        #12
                        imported post

                        OK, I have NT5 working again. For thos who have similar troubles, the process on the link suggested below did not work. In fact I was left with a Ninja Trader 5 folder that when I clicked on, gave me a nasty wiondws message saying that the folder cannot be viewed. So I was left with a folder that shouldn't be there.

                        I tried a number of combinations of reinstalling/uninstalling/deleting which still did not work, so used the one good function XP is good for, a system restore.

                        So I ended up with a NT4 folder, and 2 NT 5 folders. I could remove NT4 and one copy of NT5 through Add/Remove programs, doing a restart between each step. Then the remaining copy of NT5 was actually the zip file the link below asked us to run. I deleted that, restarted and had what appeared to be a Ninja free system.

                        Installed now OK.

                        That doesn't explain the corrupted installation on my second meachine from last night which never had NT on it all. I am thinking there must have been a network problem last night between Oz and US.

                        Will try that now...

                        cheers,

                        Comment


                          #13
                          imported post

                          Please make sure you only remove the files (!) <install>\charttemplates\*.xml and NOT the directory (!) <install>\charttemplates.
                          DierkNinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by chartish, Today, 04:43 PM
                          1 response
                          10 views
                          0 likes
                          Last Post NinjaTrader_EricB  
                          Started by Trader17, Today, 04:07 PM
                          0 responses
                          4 views
                          0 likes
                          Last Post Trader17  
                          Started by GussJ, Today, 01:30 PM
                          2 responses
                          20 views
                          0 likes
                          Last Post GussJ
                          by GussJ
                           
                          Started by GARZONJ, Today, 12:25 PM
                          3 responses
                          18 views
                          0 likes
                          Last Post NinjaTrader_PaulH  
                          Started by RandanAL, Today, 11:53 AM
                          1 response
                          14 views
                          0 likes
                          Last Post NinjaTrader_ChelseaB  
                          Working...
                          X