• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Unable to import indicators

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unable to import indicators

    Getting this error message trying to import an indicator. How do I fix this?

    Thank you.
    Attached Files

    #2
    Open Tools -> Edit NinjaScript -> Indicator, select any one of the indicators displayed and edit it. Then compile via F5.

    This should produce a bunch of error messages. Please remove all indicator and strategy files that are at the origin of the error messages. You can do this via Tools -> Edit NinjaScript ....

    If the errors are related to assemblies, you should remove those assemblies via File -> Utilities -> Remove NinjaScript Assembly. If this is not possible, indicators strategies and assemblies can also be removed manually, This should be avoided, but is the appropriate measure of last ressort. In case that you remove any files manually, you also need to remove the references to those indicators or assemblies.

    Comment


      #3
      ok, will go ahead and remove these files.
      Attached Files

      Comment


        #4
        I am unable to remove the files. I get a box saying "you can't delete a system indicator."

        Comment


          #5
          Originally posted by babba View Post
          I am unable to remove the files. I get a box saying "you can't delete a system indicator."
          Your problem is more complex. I have not seen this before.

          You should either contact NinjaTrader support or reinstall NinjaTrader.

          Comment


            #6
            babba, please close down NT and then do a repair install of the current R14 installer from here -

            http://www.ninjatrader.com/download-registration.php

            Once that is done, reopen NT and recompile all scripts - the issue should be resolved. If not please get in touch with us via Help >> Mail to Support and we will take a remote look at the setup for you.

            Thanks,
            BertrandNinjaTrader Customer Service

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Started by thgamey, Yesterday, 08:38 PM
            2 responses
            11 views
            0 likes
            Last Post thgamey
            by thgamey
             
            Started by stredtity, Today, 01:21 AM
            0 responses
            4 views
            0 likes
            Last Post stredtity  
            Started by superg3, Yesterday, 10:12 PM
            0 responses
            8 views
            0 likes
            Last Post superg3
            by superg3
             
            Started by johnnybegoode, Yesterday, 07:02 PM
            0 responses
            12 views
            0 likes
            Last Post johnnybegoode  
            Started by YevhenShynkarenko, Yesterday, 05:02 PM
            1 response
            18 views
            0 likes
            Last Post YevhenShynkarenko  
            Working...
            X