• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

TICK and TRIN Stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TICK and TRIN Stopped working

    I have been working with the paid version of NT for the last two weeks getting ready for real time trading I depend on TICK and TRIN for market direction. I use IQFeed as my primary data provider with IB connected also.

    After two weeks with no problems today TICK & TRIN just stopped working????? When I started up today I got error message "Unable to subscribe to market data." I have AmiBroker as a back-up TICK and TRIN update in real time just fine on it as I write this.

    Why did these symbols just suddenly stop working in NT?????

    #2
    Hello,

    Thank you for your post.

    What is the full error message you are receiving?

    Can you restart NinjaTrader, connect to IQFeed and verify that the TICK and the TRIN are streaming live data before connecting to Interactive Brokers?
    CameronNinjaTrader Customer Service

    Comment


      #3
      I attached the error messages I'm getting, I shut down and restarted same messages.

      Again TICK and TRIN work in AmiBroker but not NT. I have been using TICK and TRIN for the past two weeks with no problems until today. So NT changed a setting on it's own I touched nothing.
      Attached Files

      Comment


        #4
        Hello,

        Please reset your master instrument list.


        To reset your instruments please: go to the Tools menu, select the Options menu item, select the Data tab, and then click on 'Reset Instruments'.


        Once the reset is complete, restart NinjaTrader.
        CameronNinjaTrader Customer Service

        Comment


          #5
          Well your suggestion partially fixed the problem, still get the 1st error message I posted. The TICK & TRIN charts load to the current time but no Real Time updating. I tried loading a new chart same thing no RT updating.

          Comment


            #6
            Hello,

            Please send a note to Support[At]NinjaTrader[Dot]Com.

            Put ATTN: Cameron in the subject field and a link to this forum post in the body.

            Please provide me with your latest Log and Trace files.
            You will find the log file in the Documents > NinjaTrader 7 > Log folder.

            * The log file will be named log.20130801.txt

            You will find the trace file in the Documents > NinjaTrader 7 > Trace folder.

            * The trace file will be named trace.20130801.txt


            Please attach both of these files to your next response. If these files are over 4MB, please let me know and I can respond with alternative instructions.
            CameronNinjaTrader Customer Service

            Comment


              #7
              I sent the requested files to support.

              As a follow-up, I disconnected NT from IB feed and the TICK and TRIN from IQFeed began working again.

              It appears that IB is interfering with IQFeed's data stream.

              So how do I arrange it so I have IQFeed as my primary data feed and IB for sending trades?? Although I require IB's data for Level II & Total View in NT.

              Comment


                #8
                Hello,

                I sent a follow up via email.

                I see the following message in your diagnostic file:

                Max number of tickers has been reached 101



                Are you able to lower the number of symbols you are viewing to test if TICK and TRIN are able to receive data?

                If this works for you after lowering the total number of symbols you are viewing, you can either run at a lower amount or contact IQ Feed to receive more concurrent symbols at the same time.
                CameronNinjaTrader Customer Service

                Comment


                  #9
                  I think I solved the problem.

                  If I log into IB first then IQFeed the TRIN & TICK stop working. When I log onto NT then start IQFeed 1st, then IB TRIN & TICK work fine, as well as all IB Level II data. I tried this twice and was able to replicate/correct the problem both times.

                  The 101 message is coming from IB as I have their Mosaic scanner running, but this still should not interfere with IQFeed providing the primary TICK & TRIN.

                  Bottom Line, looks like I need to make sure I log into IQFeed first then IB to avoid conflicting data problems.
                  Last edited by gapmeister; 08-01-2013, 11:40 AM.

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by cociahange, Today, 03:53 AM
                  0 responses
                  1 view
                  0 likes
                  Last Post cociahange  
                  Started by dukeoferl, Today, 03:26 AM
                  0 responses
                  1 view
                  0 likes
                  Last Post dukeoferl  
                  Started by Titelluvifa, Today, 02:49 AM
                  0 responses
                  2 views
                  0 likes
                  Last Post Titelluvifa  
                  Started by rehagen, Today, 01:44 AM
                  0 responses
                  2 views
                  0 likes
                  Last Post rehagen
                  by rehagen
                   
                  Started by bouncetherubble, Yesterday, 07:33 PM
                  0 responses
                  7 views
                  0 likes
                  Last Post bouncetherubble  
                  Working...
                  X