• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Stop Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Stop Problem

    I have an automated strategy trading Soybeans (ZS) for the first time this morning. It entered a long trade at 1404 on the contract and was supposed to set a 1% stop (not simulated). A stop was entered of the number 14 (which is 1% of 1404). The stop entered should have been 1390.50. Please help.

    #2
    Hello jrtrader,

    Thanks for your post.

    May I have an export of this strategy to test?

    To export your script do the following:
    1. Click File -> Utilities -> Export NinjaScript
    2. Enter a unique name for the file in the value for 'File name:'
    3. Select the strategy from the objects list on the left -> click the right facing arrow ">" to add the strategy to the export
    4. Click the 'Export' button -> click 'yes' to add any referenced indicators to the export -> click OK to clear the export location message


    By default your exported file will be in the following location:
    (My) Documents/NinjaTrader 7/bin/Custom/ExportNinjaScript/<export_file_name.zip>

    Below is a link to the help guide on Exporting NinjaScripts.
    http://www.ninjatrader.com/support/h...nt7/export.htm


    If you would like to keep the code private for this strategy you may email the exported script to support[at]ninjatrader[dot]com with Attn: Chelsea written in the body of the email along with a link to this forum thread.

    I look forward to receiving the script.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Will do. But could the problem be my quote comes in from iqfeed in decimals, and IB trades in fractions?

      Comment


        #4
        Hello jrtrader,

        NinjaTrader uses a master instrument that will have settings and mapping for both providers. This means that the point size will be the same between the providers and any orders placed should be calculated via the point size and submitted at an actual price. Because of this, I do not think the issue will be the differences in data, unless you are getting two very different prices from each provider.

        At this point, I'm not entirely sure what may be causing the issue, however, I will be sure to test this with both Interactive Brokers and IQFeed separately to see if there are any differences in data, or with the script.
        Chelsea B.NinjaTrader Customer Service

        Comment


          #5
          I think this has something to do with the way the execution is reported back from IB. I had a stop hit for ZS at 1390.50 and it got reported in my log as price = 13.905 Strange. Anything I need to adjust?

          Comment


            #6
            Hello jrtrader,

            Thank you for letting me know the instrument and broker you are using.

            We have identified an issue that affects some IB accounts and not others where execution confirmations on ZC, ZS, ZW instruments are sent with a misformatted decimal.

            We have been in contact with Interactive Brokers development and are currently working with Interactive Brokers to fix the issue.

            Right now there is not a workaround for this but a fix is being developed.
            Chelsea B.NinjaTrader Customer Service

            Comment


              #7
              Hey Chelsea,

              Any update on the resolution to this problem? THX

              Comment


                #8
                Hello jrtrader,

                So far there has not been any word about the progress of this, except to say that this is still in the works.

                I will let you know when the issue has been resolved.
                Chelsea B.NinjaTrader Customer Service

                Comment


                  #9
                  Hi,
                  The same problem here...Any update on the resolution to this issue?...
                  Thanks in advance!
                  Regards,

                  Comment


                    #10
                    Hello reflam,

                    Currently, we are awaiting changes on the TWS platform before moving forward.

                    When I have received a note from our developers letting us know this has been corrected I will updated this thread with that notice.

                    I cannot say how long this change may take.
                    Chelsea B.NinjaTrader Customer Service

                    Comment


                      #11
                      Hi,
                      My problem is quite different and perhaps you can help me...
                      I use an automated system and when the system decide to enter in the market...the price is 1/10 the real price...
                      For instance if the price is 1275..it takes the 12,75 price and it buys or sells with a market order...but it uses the Take Profit and Stop Loss using this Price (12,75)...so, as soon as it enters to market, it is out...and disables the strategy because some parametres are negatives...
                      I use tws and a ninjatrader real account...
                      Sorry my english!...
                      And thanks again

                      Comment


                        #12
                        Hello reflam,

                        Do you experience this issue when submitting manual orders to your IB account or only from the strategy?
                        Chelsea B.NinjaTrader Customer Service

                        Comment


                          #13
                          Hi,
                          Thanks for your fast answer!
                          Manual, it works fine...the problem is with the strategy
                          Regards,

                          Comment


                            #14
                            Note:
                            The startegy works fine with CQG data in a demo way....the problems is with IB in real account...
                            Regards,

                            Comment


                              #15
                              Hello reflam,

                              Are you placing the manual orders to Interactive Brokers from NinjaTrader (from a NinjaTrader Chart Trader or SuperDOM) or are you doing this directly in TWS?

                              May I have a toy of your strategy that is able to reproduce this issue? (A toy has all code that is not directly related to the issue removed).

                              You can post this to this thread, or if you would like to keep your code private, you can send this to me at support[at]ninjatrader[dot]com with Attn:Chelsea #911397 in the body of the email.

                              I look forward to your reply.
                              Chelsea B.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by dafty, Today, 10:44 AM
                              0 responses
                              10 views
                              0 likes
                              Last Post dafty
                              by dafty
                               
                              Started by shs232, Today, 10:02 AM
                              0 responses
                              7 views
                              0 likes
                              Last Post shs232
                              by shs232
                               
                              Started by cary1267, Today, 09:37 AM
                              0 responses
                              6 views
                              0 likes
                              Last Post cary1267  
                              Started by kattiehowe, Today, 09:01 AM
                              0 responses
                              10 views
                              0 likes
                              Last Post kattiehowe  
                              Started by Irukandji, Yesterday, 06:24 AM
                              10 responses
                              79 views
                              0 likes
                              Last Post neoikon
                              by neoikon
                               
                              Working...
                              X