• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

no price in chart

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    no price in chart

    Hi,

    I opened a chart in a demoversion, fxcm connection made, but there is no price in the chart ( right vertical axis.

    See attachment.

    Regards,

    Rob
    Attached Files

    #2
    Hello,

    Thank you for the screen shot. The FXCM connection will only provide data for Forex instruments. The ES 03-14 contact is a Futures and would need to be used by a Futures provider.

    For your connection, try opening a Forex instrument such as the $EURUSD and let me know if that does not work.
    MatthewNinjaTrader Product Management

    Comment


      #3
      Unfortunately the same

      Rob
      Attached Files

      Comment


        #4
        In order for me to help determine why this is occurring, I will need to review your log and trace files from the last date that this occurred.

        Please send an email to support[at]ninjatrader[dot]com and include your most recent log and trace files, Attn: Matthew in the Subject line and a reference to this thread.

        You will find the log file in the Documents > NinjaTrader 7 > Log folder.

        * The log file will be named ‘log.20131229.txt’

        You will find the trace file in the Documents > NinjaTrader 7 > Trace folder.

        * The trace file will be named ‘trace.20131229.txt’

        Please attach both of these files to your next response. If these files are over 4MB, please let me know and I can respond with alternative instructions.
        MatthewNinjaTrader Product Management

        Comment


          #5
          Hi,

          tried it as well wit kinetick end of day free data for 6E ( eurdollar) and 6J ( yen)
          All the same picture.

          Rob

          Comment


            #6
            Kinetick End of Day is only going to work for Daily Intervals. I'm not sure what type of data is needed for your Futures4ProfitsBar.

            Please try the Kinetick End of Day connection with a Daily time frame.

            Please try your FXCM connection with the $EURUSD in a 1 minute time frame.

            Let me know your results of these two tests.
            MatthewNinjaTrader Product Management

            Comment


              #7
              I see very similar behaviour. I use Gain for FX spot trading. It is fairly common for me to start charts (any pair, but EURUSD, for example), only to find that the Y-axis starts and ends at ZERO (exactly). No data. Interestingly, this behaviour was, until this year (2014), fairly uncommon on most FX pairs, except NZDJPY where it always happens. But as of the new year, all FX pairs seem to exhibit the behaviour.

              I try to reload all historical data (Ctrl+Shift+R) and that rarely works. I close the chart and try again -- same ... but occasionally, on the next tick, arriving data starts to display on the chart. The behaviour is the same on all charts when this occurs. Stop/restart NT -- same. Data does appear in the Control Center Orders tab, so it does not appear to be a data feed issue. New workspace -- same behaviour. It is as if all historical data is ignored or unavailable.

              This post from NT (http://www.ninjatrader.com/support/f...ead.php?t=3725) asks various questions, and here are my answers.
              • The charts are the default session template, default properties (so, typically, Last, 1 minute)
              • The PC clock is correct
              • The NT version is NinjaTrader 64-bit 7.0.1000.18 (Multi-Broker Live), but it has been an issue on previous versions too
              • Data provider is Gain only
              • Data appears to be received in the Control Center and SuperDOM
              • Any instrument can exhibit the behaviour; e.g. EURUSD, GBPAUD, CHFJPY. Fascinatingly (and frustratingly), this is always the behaviour for NZDJPY.
              • It is reproducible when it starts to occur, but not on demand at any time, except for NZDJPY
              • All charts are opened via File > New > Chart
              • There are no third-party indicators or strategies; I do, however, have an indicator and strategy I have developed myself.

              Note that the trace and log files rarely show unusual messages for most pairs, except NZDJPY. The trace file notes the Data.Bars.GetBarsNow request to the provider and normally no other messages.

              However, for NZDJPY, the request is usually different in form from the others. For example:
              2013-12-21 01:03:26:493 (Gain LIVE FX) Data.Bars.GetBarsNow: instrument='$EURJPY' from='2013-12-20 21:00:00' to='2013-12-21 23:59:59' period=1 Tick - Bid splitAdjusted=False dividendAdjusted=False bars=0 session='Forex'
              2013-12-21 01:03:27:762 (Gain LIVE FX) Data.Bars.GetBarsNow: instrument='$NZDJPY' from='2013-12-20' to='2013-12-21 23:59:59' period=1 Tick - Bid splitAdjusted=False dividendAdjusted=False bars=0 session='Forex'

              Note that the "from" and "to" date/time range specifications for other pairs are always both either a date and time or date only. For NZDJPY, they appear to be always date only for "from" and date and time for "to". That seems to be an aberrant mixture of different formats, which may or may not be significant.

              And often, but not always, the trace file shows this error, usually (though not always) associated with a request for bars from NZDJPY:
              2013-12-31 12:30:49:069 in OnUnhandledThreadException
              2013-12-31 12:30:49:069 *************** unhandled exception trapped ***************
              2013-12-31 12:30:49:069 Index was outside the bounds of the array.
              2013-12-31 12:30:49:069 at Infragistics.Shared.SparseArray.GetItem(Int32 index, ICreateItemCallback createItemCallback)
              at Infragistics.Win.UltraWinGrid.RowsCollection.get_I tem(Int32 index)
              at NinjaTrader.Strategy.StrategyGridDisplay.UpdateStr ategy(StrategyBase strategy, Int32 rowIndex)
              at NinjaTrader.Strategy.StrategyGridDisplay.OnStrateg yStatus(Object sender, StatusChangedEventArgs e)
              at NinjaTrader.Strategy.StatusChangedEventHandler.Inv oke(Object sender, StatusChangedEventArgs e)
              at NinjaTrader.Strategy.StrategyBase.StartedNow()
              at System.Windows.Forms.Control.InvokeMarshaledCallba ckHelper(Object obj)
              at System.Threading.ExecutionContext.runTryCode(Objec t userData)
              at System.Runtime.CompilerServices.RuntimeHelpers.Exe cuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
              at System.Threading.ExecutionContext.Run(ExecutionCon text executionContext, ContextCallback callback, Object state)
              at System.Windows.Forms.Control.InvokeMarshaledCallba ck(ThreadMethodEntry tme)
              at System.Windows.Forms.Control.InvokeMarshaledCallba cks()

              Comment


                #8
                I wondered if the source of my historical data may be causing the problem. I have always used the NinjaTrader historical data servers, as selected in Account Connections for my broker connection to Gain.

                So, I changed the source of my historical data to be the Gain servers, not the NinjaTrader servers. I made the change, restarted NinjaTrader and ... VOILA! All charts, including NZDJPY, get historical data as expected! It is noticeably slower than the NT servers, but the data comes without issue ... on every chart ... every time.

                I had also noticed that with the NinjaTrader servers, OnBarUpdate was not getting called, even though the chart showed changes. With the Gain servers, OnBarUpdate is now being called as expected.

                So ... one has to ask, what might be the issue with the NinjaTrader historical data servers? Clearly, there appear to be some fundamental problems at times.

                Comment


                  #9
                  Hello jeronymite,

                  There have been some issues with the primary historical data servers used to record this data for GAIN. As of now the historical data servers are offline and unavailable for this connection. In the mean time you can switch your connection to the GAIN servers as you have done and that should allow your data to display this historical data.
                  MatthewNinjaTrader Product Management

                  Comment


                    #10
                    Thanks for the update, Matthew. I'm glad to hear there is work being done on the historical data servers for GAIN.

                    Comment


                      #11
                      Just wondering when the NinjaTrader historical data servers for GAIN will be fixed and back online. Any ETA? Thanks.

                      Comment


                        #12
                        We anticipate this weekend during schedule maintenance, but cannot gurantee their availability at this point in time.
                        MatthewNinjaTrader Product Management

                        Comment


                          #13
                          Fixed?

                          Any update on this situation? Thanks.

                          Comment


                            #14
                            There were further issues which prevented us from restoring access to these servers this weekend.

                            The maintenance required can only be done on the weekend when the markets are closed.

                            We have it scheduled to address these issues again this weekend.

                            Thanks for your patience.
                            MatthewNinjaTrader Product Management

                            Comment


                              #15
                              Status?

                              Any further update on this situation? Thanks.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by nepenthean, Today, 12:36 PM
                              0 responses
                              3 views
                              0 likes
                              Last Post nepenthean  
                              Started by sun0781, Yesterday, 05:02 PM
                              1 response
                              19 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Started by Emma1, Today, 12:14 PM
                              0 responses
                              2 views
                              0 likes
                              Last Post Emma1
                              by Emma1
                               
                              Started by Hanstanz, Today, 04:44 AM
                              1 response
                              17 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Started by Newtrader101, Today, 10:31 AM
                              0 responses
                              8 views
                              0 likes
                              Last Post Newtrader101  
                              Working...
                              X