• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

ninja trader showing orders in log, but not procesing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ninja trader showing orders in log, but not procesing

    Hi,

    I am sending orders from tradestation to Ninja. It had been working fine so far until yesterday. I am seeing orders getting queued up in the log, but they are not getting executed. How do I fix this?

    I was running some serious simulations yesterday, and sending orders every 5 seconds. And then Ninja had reported some problems. I have since then restarted computer, tradestation and ninja, and also reset the sim account in ninja, but still not getting past order execution. I am attaching a picture of log as well.

    Thx
    Attached Files

    #2
    Hello Pkd12,

    Thank you for your post.

    It looks like you are trying to place orders to the @ES which does not exist inside NinjaTrader and is a TradeStation Continous contract.

    I recommend that you use ES 06-14 and place your order then.
    Cal H.NinjaTrader Customer Service

    Comment


      #3
      I am still getting similar error. I tried using symbol ESM14 and GOOG on tradestation. My instrument manager is also set correctly to process june ES.
      Attached Files

      Comment


        #4
        pkd12,

        These images you are attaching show me that you are using the OIF Builder which if so, you would need to use the NinjaTrader master instrument name such as ES 06-14.

        If you want to send orders from TradeStation to NinjaTrader then you would want to look into the email interface with NinjaTrader -
        http://www.ninjatrader.com/support/h..._interface.htm
        Cal H.NinjaTrader Customer Service

        Comment


          #5
          I am using the dll interface. This had been working fine till yesterday. Only today, I am getting this problem. A copy of the instrument manager is attached. Please guide how to fix this problem.
          Attached Files

          Comment


            #6
            pkd12,

            I want you to test the OIF Builder in NinjaTrader to ensure that it is working as expected.
            Go to Tools -> Options -> ATI -> Click OIF Builder
            Input the settings from the screenshot that I have attached

            Additionally, please send me a request to support with your trace and logs attached by going to Help -> Mail to Support: reference this thread in the body and put Attn Cal in the subject line
            Ensure Trace and Logs is checked before sending.
            Attached Files
            Cal H.NinjaTrader Customer Service

            Comment


              #7
              it started working just now after I made these changes. Can you tell what might have gone wrong to begin with, and what specific things I need to look out for in OIF?

              Comment


                #8
                pkd12,

                What changes did you make to the oif files used in the DLL interface?
                Cal H.NinjaTrader Customer Service

                Comment


                  #9
                  I had not made any changes to the OIF file.

                  I am attaching my screenshot. This problem happened again on one of the strategies.

                  If my strategy generates a lot of cancel orders while starting up (lastbaronchart in tradestation was not an initial condition to begin for these cancellations), will that cause a problem in ninja trader, and screw up my settings?
                  Attached Files

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by alfonso, Today, 10:21 AM
                  0 responses
                  1 view
                  0 likes
                  Last Post alfonso
                  by alfonso
                   
                  Started by saeed, Today, 10:20 AM
                  1 response
                  3 views
                  0 likes
                  Last Post saeed
                  by saeed
                   
                  Started by ntbone, Yesterday, 05:21 PM
                  1 response
                  5 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Started by ntbone, Yesterday, 04:05 PM
                  1 response
                  5 views
                  0 likes
                  Last Post NinjaTrader_Jesse  
                  Started by tonynt, Today, 09:35 AM
                  1 response
                  10 views
                  0 likes
                  Last Post NinjaTrader_ChrisL  
                  Working...
                  X