• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Sydney Futures Exchange (SFE) charts not updating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sydney Futures Exchange (SFE) charts not updating

    Hi,

    This issue currently happening on the SFE overnight session.

    Day session closed at 4:30pm AEST with charts running fine. Market re-opens at 5:12, price feed is working as I can see bids and offers on the DOM and Market Analyser, but the charts are not recording, see image.

    Image description:
    YT, XT are SFE contracts.
    Everything else US contracts.

    Things to note in image:
    The time of the last recorded price for XT and YT is 4:30pm AEST
    The 'current' price indicated by the chart remains static, as proven by the Market Analyser.

    Also to note:
    I have reloaded data via the chart context menu (right click menu).
    I have reloaded data via tools -> Historical Data Manager -> Reload -> Reload all.
    I have restarted Ninjatrader after each step described above.
    This issue occured last Friday, due to data being rerouted from the back-up servers, which does not support SFE data. Is this a routine procedure every week?
    Attached Files

    #2
    Hello edcala,

    The SPI futures uses the Snfe RTH session template by default. It runs from 9:50 AM to 4:30 PM UTC +10 (Sydney). This is why the chart and Market Analyzer do not receive data overnight.

    The session template determines during what hours the chart will receive data. You select the session template in the Data Series menu of the chart.

    If set to <Use instrument settings>, it will use the session template that is configured for the instrument in the Instrument Manager. Please go to Control Center-->Tools-->Instrument Manager, highlight the instrument in question and click Edit. You will now see what session template the instrument by default uses.

    You can view the times of each session template in the Session Manager (Control Center-->Tools). It will allow you to create new ones as well. This way you can create a session template that uses the hours you like. More information regarding the Session Manager can be found at the link below.
    http://www.ninjatrader.com/support/h...on_manager.htm

    Rerouting to the backup server is not a routine procedure that will occur every week.
    JasonNinjaTrader Customer Service

    Comment


      #3
      All Fixed

      Great that fixed the issue!

      Thanks James

      It turns out that in the Session Manager, the session times were incorrect, and that the Friday 5:10pm session was not added. I also found that there was an extra session set on Sunday 5:10 to Monday 7:00am. This was incorrect and I had this removed.

      For the SFE traders out there, take note the session times and change session settings in accordance to the exchange website:

      http://www.asx.com.au/about/trading-hours.htm
      Last edited by edcala; 04-07-2014, 12:45 AM. Reason: Supports name is James, not Justin

      Comment


        #4
        Screen Shot??

        Originally posted by edcala View Post
        Great that fixed the issue!

        It turns out that in the Session Manager, the session times were incorrect, and that the Friday 5:10pm session was not added. I also found that there was an extra session set on Sunday 5:10 to Monday 7:00am. This was incorrect and I had this removed.

        For the SFE traders out there, take note the session times and change session settings in accordance to the exchange website:

        http://www.asx.com.au/about/trading-hours.htm


        Thanks Justin
        Hey Justin

        Any chance you could take a screen shot of your session template for ASX SPI 200 ETH (24 hour) and post please?

        Thank you.

        Comment


          #5
          Hi msms88,

          As Jason mentioned, the SPI futures only include the day session by default. To add the night sessions just click on:

          Tools -> Session Manager
          Select the "Snfe RTH" session on the session template dropdown (Or if it isnt there, just add it in by clicking 'New').
          click 'Add' to add the missing sessions.

          For SPI, the night session time is 5:10PM (UTC +10:00) to 7:00AM the following day.
          Make sure that you change the overnight session closing time to 8:00AM between Nov to March as specified on the SFE website:

          http://www.asx.com.au/about/trading-hours.htm
          (under index derivatives)

          PS. Just for the record my name isn't Justin. I was thanking James in the previous, whom I thought was named Justin.
          Attached Files

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by faisamtrader, Yesterday, 10:03 PM
          0 responses
          3 views
          0 likes
          Last Post faisamtrader  
          Started by johnnybegoode, Yesterday, 08:11 PM
          0 responses
          2 views
          0 likes
          Last Post johnnybegoode  
          Started by Bionian, Yesterday, 02:47 PM
          2 responses
          21 views
          0 likes
          Last Post Bionian
          by Bionian
           
          Started by RickB60, Yesterday, 01:55 PM
          1 response
          11 views
          0 likes
          Last Post NinjaTrader_PaulH  
          Started by filopearson, Yesterday, 01:18 PM
          6 responses
          11 views
          0 likes
          Last Post NinjaTrader_Jesse  
          Working...
          X