• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Indicator not displaying

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • plemal
    started a topic Indicator not displaying

    Indicator not displaying

    Not sure why I can't get Keltner to display-actually other indicators are not either:

    http://screencast.com/t/XDy8ljwwU

    Thanks for any help with this...

    Paul

  • NinjaTrader_ChristopherJ
    replied
    You will only need to remove the one that is referenced in the error "SharkIndicators.Common.DLL then add it back in and compile.

    Leave a comment:


  • plemal
    replied
    Thanks Christopher-can I assume that all of these .DLL files are corrupted and need to be removed:

    http://screencast.com/t/Ev29DIM8ly

    I want to make sure before I go removing something that I shouldn't...

    Paul

    Leave a comment:


  • NinjaTrader_ChristopherJ
    replied
    This indicates you are missing some required reference DLL's or have corrupted ones listed - please follow the steps below to rectify the errors.
    on the 'Ok' button.
    • Right click in the code section of the NinjaScript editor.
    • In the context menu click on 'References'
    • In the Reference dialog, if a reference to the noted DLL files exists already then select the DLL's which are giving errors one by one and click on the 'Remove' button.



    After removing, add back the reference with the right path :
    • In the Reference dialog, Click on the 'Add' button.
    • Select all the missing DLL's (located in the Documents\NinjaTrader 7\bin\Custom\ folder
    • Compile the indicator now by pressing F5.

    The issues should be resolved and your NT should be again in properly compiled state


    Please also see the section "How to add a reference" from our help guide

    http://www.ninjatrader.com/support/h...indicators.htm

    Leave a comment:


  • plemal
    replied
    Originally posted by NinjaTrader_ChristopherJ View Post
    Hello,

    Thank you for your post.

    Please compile your indicators with the steps I have provided below.
    • Tools
    • Edit NinjaScript
    • Indicators
    • Select ADL
    • Click Ok
    • Within the code window please right mouse click-->Compile
    • X out of the window


    Next please apply the indicator to your chart once again and let me know if the issue persists.
    Then a new problem arose:

    http://screencast.com/t/RvefpAqM

    Is there a way to avoid having to un-install the indicators I am using?

    Paul

    Leave a comment:


  • NinjaTrader_ChristopherJ
    replied
    Hello,

    Thank you for your post.

    Please compile your indicators with the steps I have provided below.
    • Tools
    • Edit NinjaScript
    • Indicators
    • Select ADL
    • Click Ok
    • Within the code window please right mouse click-->Compile
    • X out of the window


    Next please apply the indicator to your chart once again and let me know if the issue persists.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by chazyang, Today, 08:11 AM
1 response
2 views
0 likes
Last Post NinjaTrader_PatrickG  
Started by Erwin Beckers, 11-04-2018, 02:39 AM
6 responses
77 views
2 likes
Last Post koganam
by koganam
 
Started by sergey_z, Today, 02:34 AM
3 responses
14 views
0 likes
Last Post NinjaTrader_PaulH  
Started by frankduc, Today, 05:24 AM
4 responses
16 views
0 likes
Last Post frankduc  
Started by shmarola, Today, 01:01 AM
0 responses
4 views
0 likes
Last Post shmarola  
Working...
X