• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Charting saturday issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Charting saturday issue

    Dear all ,

    as for this thread i am specific talking about ES 06-14 , where i see friday ETH on chart and it just destroy all charting and display.

    i tried to use instruments setting template and switched between 24/7 , 24/5 defaults - nothing help yet.


    any ideas?

    thanks !

    #2
    Hello be_water,

    What version of NinjaTrader are you using? You can check under Help -> About (Example: 7.0.1000.X)

    Who are you connected to? This is displayed by green on lower left corner of the Control Center window.

    Could you clarify what you are experiencing on your chart?

    Please post a screenshot of your chart.

    To send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

    For detailed instructions please visit the following link

    http://take-a-screenshot.org/
    Christopher S.NinjaTrader Customer Service

    Comment


      #3
      Hello ,

      Attached is the picture , im usining NT 64-bit 7.0.1000.21 (Live) , connecting through Interactive Brokers.

      Thanks,
      Attached Files

      Comment


        #4
        Hello be_water,

        Please double click on the yellow line on the chart.

        Then in the window that opens select 'Auto scale' set to False and press OK.

        Repeat these steps for the blue and red lines.
        Christopher S.NinjaTrader Customer Service

        Comment


          #5
          Did it and its not working well yet.

          the question is why i have any data in this place (25-26 which is saturday and sunday) from the beginning . attached the picture .
          Attached Files
          Last edited by be_water; 04-28-2014, 08:53 AM.

          Comment


            #6
            Hello be_water,

            The line on the chart that is plotting at a price value of zero is changing the scaling of the chart.

            Please select this chart object and set the 'Auto scale' setting to False and press OK.
            Christopher S.NinjaTrader Customer Service

            Comment


              #7
              Ok , again , the when i double click this object all i get is the box of Es 06-14 1 min , which is the instrument and Auto scale option is TRUE by default - cannot be changed. to get it more clear i cleaned up all indicators - attacherd is the picture.
              Attached Files

              Comment


                #8
                Hello be_water,

                Please go to File > Workspace > Save Workspace.

                Then, please send me your workspace, log and trace files so that I may look further into this.
                You can do this by going to the Control Center-> Help-> Mail to Support, checking the box 'Workspaces files and UI settings'.

                Please reference the following in the body of the email: "ATTN:Chris S" with a link to this tread.
                Christopher S.NinjaTrader Customer Service

                Comment


                  #9
                  Done.

                  thanks.

                  Comment


                    #10
                    Resolved by reloading historical data on the chart by right clicking on the chart and selecting 'Reload All Historical Data'.
                    Christopher S.NinjaTrader Customer Service

                    Comment


                      #11
                      Hey Christopher, this happens ALL the time.

                      The real question is why does NT continually egg-beater the price data?

                      You can see what went on here. The poor guy had a price data of ZERO or real close for historical data and then the correct price for the final day.

                      It can happen either way. I always get either the correct data except the last day OR it egg-beaters already perfectly normal historical data and then give me correct price on the last data point. Either way the chart is BBQ'd and a reload is required.

                      What is worse sometimes when i reload historical data, especially if i have 2 different securities on one chart is it decides to reload the NEW price data from one security and re-loads it into the 'other' security historical price.

                      So goodie for us we need to re-load ALL the data all by itself in another chart (again) to un-scramble the previous scramble which was scrambled upon simply connecting to our data provider!

                      What on earth is going on here. This is really a disaster. Annoying as hell, especially when we do not have access to the historical data that got scrambled. That's the worst part of it for me.

                      I've just permanently taped my two finger together in a 'cross' pattern so they're already ready whenever i fire up NT and connect to my broker.

                      When that does not work I pray to Joe Pesci.

                      Comment


                        #12
                        Hello Steve R,

                        This is not expected behavior.

                        Please send your log and trace files to support so I may look into what occurred.

                        You can do this by going to the Control Center-> Help-> Mail to Support.

                        Please reference the following ticket number in the body of the email: ATTN:Chris S Ticket 1064047
                        Christopher S.NinjaTrader Customer Service

                        Comment


                          #13
                          Done Chris. It happened again tonight. Scrambled perfectly good data that I was looking at prior to connect @ broker.

                          Several charts, several securities.

                          I don't even know where to start in this mess but look @ vix 06-14 futures chart and you will the final print that is the SPY etf price, for the easiest problem to see.

                          Sure, reload fixed it this time but what??? every day? nonsense.
                          Last edited by Steve R; 05-13-2014, 08:08 PM.

                          Comment


                            #14
                            Welcome to yet another glorious NT day.

                            All attempts to fix have gone to zero, and here we are again with more lost data, scrambled data problems.

                            Un-freaking believable. Lets be clear here, the only reason i am still using this garbage is that i am way too far invested into strategies to re-code it ALL on a new platform. I am beyond pissed because i am stuck and I know it.

                            So maybe it's just me this time, lets find out as i would hate to place blame where it does not belong.

                            So I run the program and collect the data all day friday on an etf.

                            I fire up NT this Monday morning and presto - no daily data for Friday. Yep it's gone. The minute data is there but no entry for daily.

                            So I re-load the data from IB. Well, they seems to be missing it at their end too, but who cares because I ran it all day on Friday so no problems??

                            Anyway no can do so I un-hook from IB, manually edit the daily entry for 30/05/2014.

                            I reload the chart while not connected to IB. OK I can see the missing day now.

                            Re-connect to IB. Nope!

                            Will NOT load the data that is right before my eyes. I try changing the session times, reload yet again from IB, creating a new chart. Disconnect, shut program down, re-start, re-edit data, reload another chart then reconnect to IB again,

                            nope nope nope and 3-7 more nopes just to make good and sure. No, I'm not annoyed. Nope!

                            I wait until after regular market open (today - Monday) to re-fire NT and connect.
                            NOPE!

                            I can see the data 'green' manual entry on historical data but it WILL NOT dsipaly on any chart while connected.

                            What is the problem now?

                            Let's not even get to the part where charts just stop updating as the days and weeks progress so you have to on a daily basis set the date time-frame. I see ltos of people having this issue as well and I am so consumed with more important problems that that one has been set aside for the moment.

                            It's 2014 - this is truly UN-believable.

                            Comment


                              #15
                              Hello Steve R,

                              What instrument(s)?

                              Do you receive this data in TWS?
                              Christopher S.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Mberg, Today, 05:13 PM
                              0 responses
                              0 views
                              0 likes
                              Last Post Mberg
                              by Mberg
                               
                              Started by Barry Milan, Today, 01:33 PM
                              2 responses
                              7 views
                              0 likes
                              Last Post marcus2300  
                              Started by NW Trader, Today, 03:42 PM
                              2 responses
                              7 views
                              0 likes
                              Last Post NW Trader  
                              Started by ralett, Today, 01:42 PM
                              1 response
                              4 views
                              0 likes
                              Last Post NinjaTrader_ShawnB  
                              Started by dkbyond, Yesterday, 04:11 PM
                              1 response
                              22 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Working...
                              X