• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Currencies Missing from Instrument List

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Currencies Missing from Instrument List

    Hello,

    I don't have any currencies in the Instrument Manager.
    Please could you advise how I can fix this.
    It was also missing TNX (US 10-Year Treasury Note Yield), but I have added that in as a new instrument.

    The version I am using is: 7.0.1000.23

    #2
    Hello Regulus,

    Thank you for your post.

    It depends who you are connected to. When you're connected to a provider who doesn't provide Currency data to us, the currency pairs will not show up in the instrument manager because they can't be used. Who are you connected to?

    As for the TNX, if an instrument isn't listed by default they would need to be set up manually. We already have the 10 Year US Treasury Notes Future listed in the Instrument Manager as 'ZN'.
    VinceNinjaTrader Customer Service

    Comment


      #3
      The data connection is Interactive Brokers.

      Comment


        #4
        Hello Regulus,

        Can you reset your instruments under Tools--> Options--> Data tab--> Reset Instruments. Restart NT after this and then open up the Instrument Manager and check if the Currencies are listed.
        VinceNinjaTrader Customer Service

        Comment


          #5
          No, they are still not listed.
          I did find out the cause of the problem though.
          It is the TWS version, I was running the latest TWS version 9452, switching to TWS 938.1 fixes it.
          The only problem is that I need some of the features in the newer TWS versions.

          Sorry I should have realised it could be the TWS version.

          Comment


            #6
            Hello Regulus,

            You need to have TWS 944.3 as this is the official supported version.

            Please uninstall your version and then install 944.3 from here:
            http://www.ninjatrader.com/Connectio...tion-Guide.php

            After this check if you can bring up the currencies.
            VinceNinjaTrader Customer Service

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Started by Newtrader101, Today, 10:31 AM
            0 responses
            3 views
            0 likes
            Last Post Newtrader101  
            Started by rwilliam, Yesterday, 03:55 PM
            1 response
            6 views
            0 likes
            Last Post NinjaTrader_ChrisL  
            Started by RandanAL, Today, 09:05 AM
            0 responses
            4 views
            0 likes
            Last Post RandanAL  
            Started by cstern71, 09-02-2019, 10:30 AM
            4 responses
            63 views
            0 likes
            Last Post Lancer
            by Lancer
             
            Started by Hanstanz, Today, 04:44 AM
            0 responses
            12 views
            0 likes
            Last Post Hanstanz  
            Working...
            X